Задача настроить MikroTik для подключения IOS

Базовая функциональность RouterOS
evgeniy7676
Сообщения: 26
Зарегистрирован: 19 май 2016, 14:52

Задача настроить MikroTik для подключения IOS

Сообщение evgeniy7676 » 28 ноя 2017, 19:51

/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-256-cbc,3des


/ppp profile
add change-tcp-mss=yes dns-server=8.8.8.8 local-address=192.168.10.1 name=\
ipsec use-encryption=yes

/interface l2tp-server server
set authentication=mschap2 default-profile=ipsec enabled=yes ipsec-secret=\
12345678 max-mru=1460 max-mtu=1460 use-ipsec=yes


/ip ipsec peer
add address=0.0.0.0/0 compatibility-options=skip-peer-id-validation dh-group=\
modp1024 dpd-interval=2s enc-algorithm=aes-256,aes-128,3des \
exchange-mode=main-l2tp generate-policy=port-override secret=12345678

/ppp secret
add name=evgeniy password=evgeniy profile=ipsec remote-address=192.168.10.16 \
service=l2tp


Не подключается логи
18:28:35 ipsec,info respond new phase 1 (Identity Protection): 31.41.111.111[500]<=>46.211.149.111[33916]
18:28:35 ipsec,error no suitable proposal found.
18:28:35 ipsec,error 46.211.149.111 failed to get valid proposal.
18:28:35 ipsec,error 46.211.149.111 failed to pre-process ph1 packet (side: 1, status 1).
18:28:35 ipsec,error 46.211.149.111 phase1 negotiation failed.

Как настроить


evgeniy7676
Сообщения: 26
Зарегистрирован: 19 май 2016, 14:52

Re: Задача настроить MikroTik для подключения IOS

Сообщение evgeniy7676 » 29 ноя 2017, 17:50

что то ни как

Аватара пользователя
Chupaka
Сообщения: 681
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Задача настроить MikroTik для подключения IOS

Сообщение Chupaka » 30 ноя 2017, 08:19

Очень подробно, спасибо...

Конфиг, конфиг в студию! Телепаты ещё не приехали :)

evgeniy7676
Сообщения: 26
Зарегистрирован: 19 май 2016, 14:52

Re: Задача настроить MikroTik для подключения IOS

Сообщение evgeniy7676 » 30 ноя 2017, 23:30

Сверху рабочий windows и android работает

evgeniy7676
Сообщения: 26
Зарегистрирован: 19 май 2016, 14:52

Re: Задача настроить MikroTik для подключения IOS

Сообщение evgeniy7676 » 30 ноя 2017, 23:38

ЕЩе прикол что нет в наличии устройства с IOS просил друзей подключаться,для проверки

Аватара пользователя
Chupaka
Сообщения: 681
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Задача настроить MikroTik для подключения IOS

Сообщение Chupaka » 01 дек 2017, 08:37

Где исправленный конфиг, с которым не работает IOS?

evgeniy7676
Сообщения: 26
Зарегистрирован: 19 май 2016, 14:52

Re: Задача настроить MikroTik для подключения IOS

Сообщение evgeniy7676 » 01 дек 2017, 11:43

/ip ipsec policy group
add name=group1
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-128-cbc,3des \
lifetime=8h pfs-group=none

/interface l2tp-server server
set authentication=mschap2 default-profile=default enabled=yes ipsec-secret=\
12345678 max-mru=1460 max-mtu=1460 use-ipsec=yes

/ip ipsec peer
add address=0.0.0.0/0 dh-group=modp1024 enc-algorithm=\
aes-256,aes-192,aes-128,3des exchange-mode=main-l2tp generate-policy=\
port-override passive=yes policy-template-group=group1 secret=12345678
/ip ipsec policy
set 0 group=group1

/ppp secret
add local-address=172.16.0.1 name=evgeniy password=evgeniy profile=\
default-encryption remote-address=172.16.0.2 service=l2tp
add local-address=172.16.0.1 name=evgeniy1 password=evgeniy1 profile=\
default-encryption remote-address=172.16.0.3 service=l2tp
add local-address=172.16.0.1 name=2 password=2 profile=default-encryption \
remote-address=172.16.0.4 service=l2tp

Аватара пользователя
Chupaka
Сообщения: 681
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Задача настроить MikroTik для подключения IOS

Сообщение Chupaka » 01 дек 2017, 12:33

Может, всё же ",3des" убрать от греха подальше?

evgeniy7676
Сообщения: 26
Зарегистрирован: 19 май 2016, 14:52

Re: Задача настроить MikroTik для подключения IOS

Сообщение evgeniy7676 » 01 дек 2017, 12:54

убрал только из proposal,если убрать из ip ipsec peer то виндовый клиент не подключается
IOs по прежнему те же ошибки
Последний раз редактировалось evgeniy7676 01 дек 2017, 14:02, всего редактировалось 1 раз.

Ответить