Подсчет записей в ARP List, удовлетворяющих условиям.

Автоматизация при помощи встроенного скриптового языка и RouterOS API
Ответить
8ID
Сообщения: 19
Зарегистрирован: 27 фев 2017, 01:00

Подсчет записей в ARP List, удовлетворяющих условиям.

Сообщение 8ID » 22 мар 2017, 19:09

Доброго здоровья всем!

Как скриптом посчитать в файл или в переменную количество "complit" и "dynamic" записей в ARP List кроме записей из адрес-листа arp-service? Как-то желательно сигнализировать о включенных в нерабочее время клиентах в локальной сети.

Аватара пользователя
Chupaka
Сообщения: 681
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Подсчет записей в ARP List, удовлетворяющих условиям.

Сообщение Chupaka » 22 мар 2017, 23:20

Код: Выделить всё

{
	:local n 0;
	
	:foreach i in=[ /ip arp find complete dynamic ] do={
		:if ([ :len [ /ip firewall address-list find list="arp-service" address=[ /ip arp get $i address ] ] ] = 0) do={
			:set n ($n + 1);
		};
	};
	
	:put "num: $n";
}

8ID
Сообщения: 19
Зарегистрирован: 27 фев 2017, 01:00

Re: Подсчет записей в ARP List, удовлетворяющих условиям.

Сообщение 8ID » 23 мар 2017, 05:26

Спасибо) Пошел разбираться.

Ответить