адрес лист и подсети

Автоматизация при помощи встроенного скриптового языка и RouterOS API
Ответить
chas99
Сообщения: 58
Зарегистрирован: 10 фев 2017, 08:52

адрес лист и подсети

Сообщение chas99 » 27 дек 2017, 09:48

Доброго дня всем =)

подскажите, пожалуйста, можно сделать чтобы автоматом добавить в адрес лист сразу всю подсеть ?
например попал входящий 185.70.187.189 в черный список, и сразу добавилась вся подсеть 185.70.184.0/22 в черный список

chas99
Сообщения: 58
Зарегистрирован: 10 фев 2017, 08:52

Re: адрес лист и подсети

Сообщение chas99 » 27 дек 2017, 09:50

и еще вопрос - как можно добавить в адрес лист диапазон адресов, например '5.39.218.128 - 5.39.218.200' ?

Аватара пользователя
Chupaka
Сообщения: 832
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: адрес лист и подсети

Сообщение Chupaka » 27 дек 2017, 10:48

А как вы собираетесь определять размер подсети? :) Проще всего, наверное, предположить, что подсети везде /24 - и просто удалять последнее число, заменяя его на "0/24"

Аватара пользователя
Chupaka
Сообщения: 832
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: адрес лист и подсети

Сообщение Chupaka » 27 дек 2017, 10:49

chas99 писал(а):
27 дек 2017, 09:50
и еще вопрос - как можно добавить в адрес лист диапазон адресов, например '5.39.218.128 - 5.39.218.200' ?
Достаточно неожиданный, наверное, ответ, но... Вот так и добавлять :)

Код: Выделить всё

ip fi address-list add list=test address=1.1.1.5-1.1.1.8

chas99
Сообщения: 58
Зарегистрирован: 10 фев 2017, 08:52

Re: адрес лист и подсети

Сообщение chas99 » 27 дек 2017, 12:01

Chupaka писал(а):
27 дек 2017, 10:49
chas99 писал(а):
27 дек 2017, 09:50
и еще вопрос - как можно добавить в адрес лист диапазон адресов, например '5.39.218.128 - 5.39.218.200' ?
Достаточно неожиданный, наверное, ответ, но... Вот так и добавлять :)

Код: Выделить всё

ip fi address-list add list=test address=1.1.1.5-1.1.1.8
Таки да, работает! спасибо =)

chas99
Сообщения: 58
Зарегистрирован: 10 фев 2017, 08:52

Re: адрес лист и подсети

Сообщение chas99 » 27 дек 2017, 12:03

Chupaka писал(а):
27 дек 2017, 10:48
... просто удалять последнее число, заменяя его на "0/24"
а как-то можно это автоматизировать, чтобы не ручками заменять?

Аватара пользователя
Chupaka
Сообщения: 832
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: адрес лист и подсети

Сообщение Chupaka » 27 дек 2017, 12:48

Что именно вы хотите автоматизировать? Что у вас уже есть?

Например, action=add-src-to-address-list сильно "автоматизировать" не получится - он только /32 и будет добавлять

chas99
Сообщения: 58
Зарегистрирован: 10 фев 2017, 08:52

Re: адрес лист и подсети

Сообщение chas99 » 27 дек 2017, 13:00

так в том и дело, action=add-src-to-address-list добавляет только сам адрес...
хотелось бы наверное скриптик, который бы например раз в ХХ минут "пробегал" address_list и менял адреса aaa.bbb.ccc.ddd на aaa.bbb.ccc.0/24

Аватара пользователя
Chupaka
Сообщения: 832
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: адрес лист и подсети

Сообщение Chupaka » 27 дек 2017, 13:36

В качестве отправной точки можно использовать скриптик типа такого:

Код: Выделить всё

{
	:local a;
	:foreach i in=[/ip firewall address-list find list="conv"] do={
		:set a [/ip firewall address-list get $i address];
		[/ip firewall address-list set $i address=([:pick $a 0 ([:find $a "." ([:find $a "." ([:find $a "." 0] + 1)] + 1)] + 1)]."0/24")]
	}
}

chas99
Сообщения: 58
Зарегистрирован: 10 фев 2017, 08:52

Re: адрес лист и подсети

Сообщение chas99 » 27 дек 2017, 16:52

Chupaka писал(а):
27 дек 2017, 13:36
В качестве отправной точки можно использовать скриптик типа такого:

Код: Выделить всё

{
	:local a;
	:foreach i in=[/ip firewall address-list find list="conv"] do={
		:set a [/ip firewall address-list get $i address];
		[/ip firewall address-list set $i address=([:pick $a 0 ([:find $a "." ([:find $a "." ([:find $a "." 0] + 1)] + 1)] + 1)]."0/24")]
	}
}
супер! браво! респект!

Ответить