Найдено 13 результатов

Ronin
07 июн 2019, 19:00
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Еще раз огромная благодарность!!!!
Ronin
07 июн 2019, 16:46
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Ага, значит, не показалось :) Конечно же вместо :set upload [:pick $alltraf 0 ([:find $alltraf "/"] - 1)]; должно быть :set upload [:pick $alltraf 0 ([:find $alltraf "/"])]; , а то с "-1" оно последнюю цифру аплоада теряет :) Во все заработало как и положено! Ну дружище не знаю как тебя и благодари...
Ronin
07 июн 2019, 13:17
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Судя по логу, исходящий трафик плюсуется к входящему. Не понимаю, где вы увидели обратное. Приветствую!!! Да точно сейчас сложил считает, но!!! Входящий считает нормально, а вот исходящий не понятно, вот что показывает в Queue List https://cdn1.savepice.ru/uploads/2019/6/7/d1dd22922d59931ce5d3aa9e2...
Ronin
06 июн 2019, 19:04
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Chupaka писал(а):
06 июн 2019, 18:32
После ":put $totaltraf;" добавьте какой-нибудь

Код: Выделить всё

:log info "$totaltraf = $upload + $download";
- что будет в лог выводить?
Изображение

Судя по логу исходящий трафик не плюсуется к входящему.
Ronin
06 июн 2019, 19:03
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Chupaka писал(а):
06 июн 2019, 18:32
Ручками - в смысле, в WinBox тыкнуть очередь и посмотреть вкладку Traffic.
Изображение
Ronin
06 июн 2019, 17:51
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Вы так и не показали export ;) Если ручками открываете очередь - там трафик в обе стороны показывается? Показываю export # jun/06/2019 21:46:00 by RouterOS 6.44 # software id = XK0X-TSQ1 # # model = RB941-2nD # serial number = A1C30995CB8D /queue simple add max-limit=3M/12M name=ZTE priority=1/1 ta...
Ronin
06 июн 2019, 15:44
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Да забыл еще вопросик такой, почему скрипт срабатывает именно только при входящем (download) объеме трафика, а по скрипту должно срабатывать когда исходящий (upload) + входящий (download)? Спрашиваю, потому что у меня спутниковый интернет и провайдер выделяет определенный дневной объем трафика в кот...
Ronin
06 июн 2019, 15:30
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Chupaka писал(а):
06 июн 2019, 11:53
Покажите, что конкретно не работает (без подмен всяких) и вывод /queue simple export
Извиняюсь. Все в порядке, мой косяк! Я после IP адреса не ставил /32 поэтому и не срабатывал. Еще раз огромнейшее спасибо за помощь. Если что могу я к Вам обращаться?
Ronin
06 июн 2019, 09:33
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Когда делаю поиск по имени тогда работает.

Код: Выделить всё

:foreach rule in=[find name="Home server"]
Ronin
06 июн 2019, 08:48
Форум: Скрипты
Тема: Помогите разобраться со скриптом?
Ответы: 21
Просмотры: 1810

Re: Помогите разобраться со скриптом?

Немного причесал ваш код: :local alltraf; :local totaltraf; :local upload; :local download; /queue simple :foreach rule in=[find target="IP.AD.DRE.SS/32"] do={ :set alltraf [get $rule bytes]; :set upload [:pick $alltraf 0 ([:find $alltraf "/"] - 1)]; :set download [:pick $alltraf ([:find $alltraf "...