Simple Queues и приоритезация по протоколам

Базовая функциональность RouterOS
Ответить
Аватара пользователя
freewood
Сообщения: 39
Зарегистрирован: 03 мар 2016, 14:47
Откуда: Зеленоград

Simple Queues и приоритезация по протоколам

Сообщение freewood » 24 янв 2018, 17:04

Привет. Бьюсь с приоритезацией трафика через SQ, нифига не получается, хотя вроде бы с документацией все сходится, как и с живыми примерами. Есть такой конфиг:

Код: Выделить всё

/ip firewall mangle
add action=mark-connection chain=forward connection-mark=no-mark dst-address-list=mango new-connection-mark=mango-conn passthrough=yes
add action=mark-packet chain=forward connection-mark=mango-conn new-packet-mark=mango-pck passthrough=no
add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dst-port=80,443 new-connection-mark=http-conn passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=http-conn new-packet-mark=http-pck packet-mark=no-mark passthrough=no
add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dst-port=22 new-connection-mark=ssh-conn passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=ssh-conn new-packet-mark=ssh-pck packet-mark=no-mark passthrough=no
add action=mark-connection chain=prerouting connection-mark=no-mark connection-state=new dst-port=3380-3399,3333 new-connection-mark=rdp-conn passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=rdp-conn new-packet-mark=rdp-pck packet-mark=no-mark passthrough=yes

Код: Выделить всё

/queue simple
add limit-at=1M/1M max-limit=4M/4M name=mango packet-marks=mango-pck priority=3/3 target=br0
add limit-at=10M/10M max-limit=19M/19M name=http packet-marks=http-pck priority=6/6 queue=pcq-upload-default/pcq-download-default target=br0
add limit-at=1M/1M max-limit=18M/18M name=ssh packet-marks=ssh-pck priority=5/5 queue=pcq-upload-default/pcq-download-default target=br0
add limit-at=5M/5M max-limit=15M/15M name=rdp packet-marks=rdp-pck priority=5/5 queue=pcq-upload-default/pcq-download-default target=br0
add max-limit=19M/19M name=all-traff packet-marks=no-mark queue=pcq-upload-default/pcq-download-default target=br0
При этом, стоит загрузить правило http или all-traff на полный канал, как все, в том числе и с более высоким приоритетом (т.е. самое приоритетное), начинает дропать, странички не грузятся, телефония заикается. Мониторил загрузку процессора (это hAP Lite), но выше 70% (в самых пиках) она не поднимается. Честная скорость канала 20mbit. Пакеты маркируются верно.
Буду рад идеям.

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Simple Queues и приоритезация по протоколам

Сообщение Chupaka » 24 янв 2018, 17:30

А первые 4 очереди не должны быть потомками пятой? Чтобы внешняя очередь ограничивала общий трафик (не давая ему приближаться к максимуму канала со стороны провайдера), а уже подочереди между собой боролись за приоритет.

Аватара пользователя
freewood
Сообщения: 39
Зарегистрирован: 03 мар 2016, 14:47
Откуда: Зеленоград

Re: Simple Queues и приоритезация по протоколам

Сообщение freewood » 24 янв 2018, 17:49

А слона то я и не приметил... спасибо большое )

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Simple Queues и приоритезация по протоколам

Сообщение Chupaka » 24 янв 2018, 17:50

И как результат?

Аватара пользователя
freewood
Сообщения: 39
Зарегистрирован: 03 мар 2016, 14:47
Откуда: Зеленоград

Re: Simple Queues и приоритезация по протоколам

Сообщение freewood » 25 янв 2018, 09:54

Все заработало великолепно, спасибо.

Ответить