Настройка VPN сервиса для обхода блокировок

Базовая функциональность RouterOS
Chupakabra303
Сообщения: 22
Зарегистрирован: 24 янв 2017, 11:57

Re: Настройка VPN сервиса для обхода блокировок

Сообщение Chupakabra303 » 17 апр 2018, 15:39

Если comp-lzo обязателен, то mikrotik подключаться не будет. В свое время потратил прилично времени, прежде чем отловил, что из-за этого ключа не работало.

MAKC7891
Сообщения: 3
Зарегистрирован: 09 окт 2017, 23:09

Re: Настройка VPN сервиса для обхода блокировок

Сообщение MAKC7891 » 19 май 2018, 12:15

Здравствуйте. Настраивал vpn (pptp клиент) аналогичным образом (vpn клиент, маскарад на интерфейс впн клиент, маркировка (src адрес ПК из локалки, без dst адресов), маршрут с маркировкой). При активном маршруте через шлюз впн с маркировкой, пропадает пинг с самого Микротика (8.8.8.8 ya.ru), т.е. нет выхода в интернет. При этом пакеты в счётчиках маскарада, мангал и самого впн клиента отсчитываются. На ПК для ip которого указан в мангл тоже нет выхода в интернет. Настройку пробовал на дефолтной конфигурации. В качестве впн сервера пробовал как Микротик с поднятым на нем впн сервером, так и сервер vpnbook. В чём может быть причина такой проблемы. P.S. Микротик стоит после маршрутизатора провайдера на котором активна DMZ на адрес Микротика.

Аватара пользователя
Chupaka
Сообщения: 2177
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка VPN сервиса для обхода блокировок

Сообщение Chupaka » 21 май 2018, 08:03

Да многое может быть. Например, правила IP Firewall Filter могут запрещать пакеты в интерфейс VPN. Не видя конфиг, сложно сказать.

Аватара пользователя
Sir_Prikol
Сообщения: 299
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Настройка VPN сервиса для обхода блокировок

Сообщение Sir_Prikol » 23 май 2018, 21:33

У меня сделано следующим образом (вкратце, если очень интересно будет, выложу все исходники и правила)
Прим1: Все сделано на чистом опенсорсе, без затрат на сторонние VDS.
Прим2: Все работает внутри домашней сети
Прим3: Падения скорости не заметил

Итак, когда в очередной раз мне понадобилось обновить из репозитория определенную софтину, то я столкнулся с тем, что IP репозитория заблокирован на территории РФ. (IP принадежит амазону, а их у нас хлопнули аз 3млн. адресов)
Меня это порядком оскорбило и я решил сделать доступ для всех заблокированных адресов и вообще, получить чистый интернет. При этом чтоб лазать только на заблокированные ресурсы, ибо на всё остальное мне хватало и читого канала.
Перелопатив толпу мануалов и не найдя ничего внятного, решил собрать сам.
Внутри моей сети стоит тестовый стенд vmware (суть дела роли не играет, можно любую виртуализацию, можно любой простой комп на первом пентиуме с 256 RAM и 20Gb HDD, главное, чтоб избавится от тормозов, две сетевые карты)
На компе был развёрнут debian (питаю слабость к этой операционке), на debiane был поднят сервер Tor (не путать с нодой Tor^ за которую и посаить могут), там-же на дебиане я поднял Open VPN сервер (хотя можно хоть ipsec поднимать, тут главное чем меньше шифрования, тем лучше, сейчас вообще подумываю переделать систему на без шифрования, но из-за количества правил маршрутизации, манглов и нат, легче было поднять отдельный интерфейс на микротике, чтоб не запутаться в маршрутах)
Так вот, после того, как был поднят OVPN и с него завёрнут трафф в тор, получилось следующая связка:

Изображение

Всё крутится в одном сегменте сети, на выходе имею чистый интернет без тормозов и блокировок.
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
r136a8
Сообщения: 169
Зарегистрирован: 04 дек 2017, 00:01

Re: Настройка VPN сервиса для обхода блокировок

Сообщение r136a8 » 02 июл 2018, 14:46

Chupaka писал(а):
12 мар 2018, 08:30
Надо просто создать l2tp-клиент, pptp-клиент или ovpn-клиент, соответственно. Там заполнить, куда подключаться и с каким паролем. Убрать галку Add default route. После этого должно нормально подключиться (интерфейс в состоянии established/connected).

Создать правило NAT для трафика, идущего в этот интерфейс (/ip firew nat add chain=srcnat out-interface=l2tp-out1 action=masq).

Затем создать маршрут по умолчанию в новой таблице маршрутизации (например, /ip route add routing-mark=VPN gateway=l2tp-out1).

После этого в mangle отмаркировать (action=mark-routing new-routing-mark=VPN) трафик, который хотите загнать в vpn. Всё :)
Имею два провадера интернета (ether10-WAN-E и ether9-WAN-V) и две сети
https://prnt.sc/k1kxy3
Все работает хорошо, у каждой сети свой интернет провайтер, в случае пропадания интернета на одном из провадеров интернет не переключется от другого.

Настраивал VPN к провадеру ether10-WAN-E и только понял что я сделал что-то не так, как как при пропадании интернета VPN все таки переключается на дугого провайдера + VPN берет интернет не от нужного провайдера это ether10-WAN-E а берет от этого ether9-WAN-V

Тест скорости на ПК с VPN (как видно интернет он берет с ether9-WAN-V) а нужно с ether10-WAN-E
https://prnt.sc/k1k8cj

Еще раз мои настройки

-Создал pptp-клиент (ввел логин, пароль) соединился, статус connected. Убрал галку "Add default route"
-Создать правило NAT для трафика, идущего в этот интерфейс (/ip firew nat add chain=srcnat out-interface=l2tp-out1 action=masq).
-Создал маршрут в таблице маршрутизации
-В mangle создал правило

?-Создал правило в IP - Routers (в случае пропадания интернета в VPN он будет пропадать а не восстанавливаться с параллельной сети) Но не -работает

Я так и не понял, а как указать с какого провайдера VPN будет брать интернет.

Скрин настроек
https://prnt.sc/k1klht

Аватара пользователя
Chupaka
Сообщения: 2177
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка VPN сервиса для обхода блокировок

Сообщение Chupaka » 03 июл 2018, 17:56

r136a8 писал(а):
02 июл 2018, 14:46
Я так и не понял, а как указать с какого провайдера VPN будет брать интернет.
В таблице main будет искаться подходящий маршрут к адресу pptp-сервера - через этот маршрут и пойдёт исходящее подключение.

Аватара пользователя
r136a8
Сообщения: 169
Зарегистрирован: 04 дек 2017, 00:01

Re: Настройка VPN сервиса для обхода блокировок

Сообщение r136a8 » 03 июл 2018, 21:08

Извините не понял, можете более конкретизировать что и куда.
Спасибо

Аватара пользователя
Chupaka
Сообщения: 2177
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка VPN сервиса для обхода блокировок

Сообщение Chupaka » 04 июл 2018, 11:24

Код: Выделить всё

/ip route add dst-address=адрес_сервера_vpn gateway=.219.1

Аватара пользователя
Chupaka
Сообщения: 2177
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка VPN сервиса для обхода блокировок

Сообщение Chupaka » 04 июл 2018, 17:54

Если у сервера много адресов - можно так:

Код: Выделить всё

/ip firewall address-list add list=vpn-server-addresses address=eu-1.vpn.server.com
/ip firewall mangle add chain=output dst-address-list=vpn-server-addresses action=mark-routing new-routing-mark=WAN-E

Аватара пользователя
r136a8
Сообщения: 169
Зарегистрирован: 04 дек 2017, 00:01

Re: Настройка VPN сервиса для обхода блокировок

Сообщение r136a8 » 09 июл 2018, 01:07

Все работает спасибо интернет уже с нужного провайдера, но появилась проблема со скоростью (очень часто прыгает высокая-низкая) и стабильностью работы интернет иногда совсем пропадает. Я так полагаю причина в количестве адресов у сервера. https://prnt.sc/k42a8d

Ответить