IPTV передать по GRE\ipsec

Базовая функциональность RouterOS
sharik987
Сообщения: 29
Зарегистрирован: 03 сен 2018, 12:47

IPTV передать по GRE\ipsec

Сообщение sharik987 » 16 окт 2018, 13:43

Здравсвуйте.
Имеем MT1, с статическим ip, и провайдер даёт IPTV в виде ссылки на плэйлист вида http://ххх.хх/iptv.m3u, в самом плэйлисте ссылки на каналы в UDP:
udp://@224.0.198.183:1234 и таких 100штук. В данной сети просматриваю на ПК телевизор, а так же через приставку.
MT2, белый динамический IP, провайдер не даёт IPTV.
Между роутерами сделан GRE канал с ipsec. Задача на MT2 глядеть IPTV.
MT1

Код: Выделить всё

/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1 upstream=yes
add interface=LOCAL
add disabled=yes interface=MyGRE
МТ2

Код: Выделить всё

/routing igmp-proxy
set quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=MyGRE upstream=yes
add interface=LOCAL(мой бридж)
Что не так?

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: IPTV передать по GRE\ipsec

Сообщение Chupaka » 16 окт 2018, 14:29

Доброго.

Т.е. на МТ1 на бридже LOCAL нормально смотрится, а на MT2 (после включения интерфейса MyGRE в IGMP Proxy) - нет?

GRE чисто для маршрутизации используется? В бриджи ни в какие не входит? Он нормально работает (на всякий случай, а то не очень понятно, не был ли он создан IPTV)?

В целом, у меня нормально работала практически такая же схема.

sharik987
Сообщения: 29
Зарегистрирован: 03 сен 2018, 12:47

Re: IPTV передать по GRE\ipsec

Сообщение sharik987 » 16 окт 2018, 14:43

Chupaka писал(а):
16 окт 2018, 14:29
Т.е. на МТ1 на бридже LOCAL нормально смотрится, а на MT2 (после включения интерфейса MyGRE в IGMP Proxy) - нет?
Да, всё нормально смотрится "за" бриджем LOCAL
Chupaka писал(а):
16 окт 2018, 14:29
GRE чисто для маршрутизации используется? В бриджи ни в какие не входит? Он нормально работает (на всякий случай, а то не очень понятно, не был ли он создан IPTV)?
Да, чисто для маршрутизации, в бридж не в какой не входит. Работает вроде нормально нареканий нет. Всё вижу, за ГРЕ, и меня видят. Отдельный на каждом МТ настроен свой ip, в OSPF эти сети вставленны, всё дружет, работает. Создавал всё сам, автоматически не чего не создавалось.
У меня вообще все правильно сделано? Я просто думаю может чего в самом ПК, брандмауер, или еще чего... Стоит проверять на другом ПК?
Последний раз редактировалось sharik987 16 окт 2018, 15:13, всего редактировалось 1 раз.

sharik987
Сообщения: 29
Зарегистрирован: 03 сен 2018, 12:47

Re: IPTV передать по GRE\ipsec

Сообщение sharik987 » 16 окт 2018, 15:11

Chupaka писал(а):
16 окт 2018, 14:29
В целом, у меня нормально работала практически такая же схема.
Вы используете GRE ? IPsec?

sharik987
Сообщения: 29
Зарегистрирован: 03 сен 2018, 12:47

Re: IPTV передать по GRE\ipsec

Сообщение sharik987 » 16 окт 2018, 15:48

И еще вопрос, есть филиал у него Серый IP адрес, Подключается к МТ1 по OVPN. Возможно ли по той же схеме организовать передачу IPTV ? Или какой то другой канал выбрать? И как это сделать?

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: IPTV передать по GRE\ipsec

Сообщение Chupaka » 16 окт 2018, 16:36

Попробуйте. Если не заработает - всегда можно поверх OVPN поднять какой-нибудь IPIP, EoIP или прочий GRE.

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: IPTV передать по GRE\ipsec

Сообщение Chupaka » 16 окт 2018, 17:39

sharik987 писал(а):
16 окт 2018, 15:11
Вы используете GRE ? IPsec?
EoIP и IPIP, но суть та же. А IPSec вообще на содержимое тоннеля не влияет :)

sharik987
Сообщения: 29
Зарегистрирован: 03 сен 2018, 12:47

Re: IPTV передать по GRE\ipsec

Сообщение sharik987 » 03 дек 2018, 13:14

В общем, поднял между двумя офисами GRE, как в первом посту. На ПК поставил IPTVплеер, и не показывает. Смотрю торчам трафик на ГРЕ на МТ1 и МТ2. Трафик идёт, на двух микротиках. А картинки нет, не погружается... На ПК все брандмауеры отключил, антивирусников нет. Три правила фаирвола добавил:

Код: Выделить всё

/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=MyGRE protocol=igmp 
/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=MyGRE protocol=udp 
/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp
Может чего в маршрутизации? Могу показать чего нужно...

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: IPTV передать по GRE\ipsec

Сообщение Chupaka » 03 дек 2018, 13:18

Т.е. мультикаст улетает к ПК? Значит, роутеры сделали своё дело :) Может, VPN какой на компе мешает? Или виртуальные сетевые карты от виртуальных машин.

sharik987
Сообщения: 29
Зарегистрирован: 03 сен 2018, 12:47

Re: IPTV передать по GRE\ipsec

Сообщение sharik987 » 03 дек 2018, 14:31

Меня смущает что в торче нет IP куда отправляется трафик... Т.е. на МТ2 он вроде как приходит, а на устройства не уходит. Смотри скрин
Вложения
Снимок3.JPG
Снимок3.JPG (222.84 КБ) 62 просмотра

Ответить