Шейпер видео сервисов и блокировка

Базовая функциональность RouterOS
Ответить
bassz
Сообщения: 4
Зарегистрирован: 23 ноя 2018, 20:04

Шейпер видео сервисов и блокировка

Сообщение bassz » 23 ноя 2018, 20:14

Подскажите как зарезать скорость на youtube и запрещать тоже чтото не получается
пробовал для блокирования
/ip firewall layer7-protocol
add name=youtube regexp="^.+(youtube).*\$"

/ip firewall mangle
add action=mark-connection chain=prerouting protocol=udp dst-port=53 connection-mark=no-mark layer7-protocol=youtube new-connection-mark=BLOCK_connection_youtube passthrough=yes
add action=mark-packet chain=prerouting connection-mark=BLOCK_connection_youtube new-packet-mark=BLOCK_youtube_packet

/ip firewall filter
add action=drop chain=forward packet-mark=BLOCK_youtube_packet
add action=drop chain=input packet-mark=BLOCK_youtube_packet
правило блокирует tut.by для ютуба не работает
/ip firewall filter
add action=reject chain=forward content=ithelp21.ru protocol=tcp reject-with=tcp-reset
хочется найти хороший способ блокировки и резать скорость на онлайн видео сервисах

Аватара пользователя
Sir_Prikol
Сообщения: 160
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Шейпер видео сервисов и блокировка

Сообщение Sir_Prikol » 23 ноя 2018, 21:46

Используйте адресс-лист, там теперь можно по доменным именам, Layer7 слишком хорошо кушает процессор
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Шейпер видео сервисов и блокировка

Сообщение Chupaka » 23 ноя 2018, 21:59

Вы маркируете соединение на 53 порт UDP, это DNS-запросы, и их потом дропаете. Это не совсем то, что вы описываете. Ловить надо по protocol=tcp any-port=443, видимо. Ну и я бы заменил prerouting на forward.

bassz
Сообщения: 4
Зарегистрирован: 23 ноя 2018, 20:04

Re: Шейпер видео сервисов и блокировка

Сообщение bassz » 24 ноя 2018, 09:45

придумал резать скорость
метим трафик prerouting по content yotube.com направляем в адрес лист list_yorube
потом
метим forward list_yorube new packet mark packet_yorube
и режем скорость в simple Queues

bassz
Сообщения: 4
Зарегистрирован: 23 ноя 2018, 20:04

Re: Шейпер видео сервисов и блокировка

Сообщение bassz » 30 ноя 2018, 21:47

не очень вариант тот что выше ( в адрес листы попадает много чего нужного кроме ютуба )
нужно как то найти способ метить трафик онлайн видео

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Шейпер видео сервисов и блокировка

Сообщение Chupaka » 30 ноя 2018, 23:05

Сложность в том, что:

а) трафик зашифрован;
б) данные идут с серверов, которые обслуживают и другие сервисы Гугла.

bassz
Сообщения: 4
Зарегистрирован: 23 ноя 2018, 20:04

Re: Шейпер видео сервисов и блокировка

Сообщение bassz » 01 дек 2018, 02:36

может по объему трафика ? с серверов гугла скорость шейпить

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Шейпер видео сервисов и блокировка

Сообщение Chupaka » 01 дек 2018, 12:22

По объёму — это параметр connection-bytes

Ответить