[Решено] Нужен DHCP скрипт/конфиг для мак адресов!

Базовая функциональность RouterOS
Аватара пользователя
Sir_Prikol
Сообщения: 261
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Нужен DHCP скрипт/конфиг для мак адресов!

Сообщение Sir_Prikol » 19 фев 2019, 11:03

Бывает, просто копировал часть кода, полный скрипт выглядит так (правда у меня он исключительно для очередей, но переделать не сложно.

Код: Выделить всё

/queue simple {
    :if ($leaseBound = "1") do={
	    add name="Public-$leaseActIP" target=$leaseActIP max-limit=5M/5M queue=public-wifi-upload-5M/public-wifi-upload-5M;
    } else={
        remove [find name="Public-$leaseActIP"];
    }
}
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Chupaka
Сообщения: 1692
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Нужен DHCP скрипт/конфиг для мак адресов!

Сообщение Chupaka » 19 фев 2019, 12:23

Что не фиксирует-то? Вы хоть нормально объясните, что хотите сделать. Видимо, лучше всего — на конкретном примере.

Tiesto
Сообщения: 58
Зарегистрирован: 28 апр 2016, 22:33

Re: Нужен DHCP скрипт/конфиг для мак адресов!

Сообщение Tiesto » 20 фев 2019, 00:20

Sir_Prikol писал(а):
19 фев 2019, 11:03
Бывает, просто копировал часть кода, полный скрипт выглядит так (правда у меня он исключительно для очередей, но переделать не сложно.

Код: Выделить всё

/queue simple {
    :if ($leaseBound = "1") do={
	    add name="Public-$leaseActIP" target=$leaseActIP max-limit=5M/5M queue=public-wifi-upload-5M/public-wifi-upload-5M;
    } else={
        remove [find name="Public-$leaseActIP"];
    }
}
Спасибо, всё ок

Tiesto
Сообщения: 58
Зарегистрирован: 28 апр 2016, 22:33

Re: Нужен DHCP скрипт/конфиг для мак адресов!

Сообщение Tiesto » 20 фев 2019, 00:54

Chupaka писал(а):
19 фев 2019, 12:23
Что не фиксирует-то? Вы хоть нормально объясните, что хотите сделать. Видимо, лучше всего — на конкретном примере.
Всё ок, заработало. Но вот такой вопрос хотел ещё уточнить.
На dhcp сервере ип адреса полученный с стороны юзера, меняется в время отсутствия от сети?
Скажу так: Данный момент на микротик pppoe сервере, при дисконнекте и реконнекте юзера, микротик не дает разные ип адреса из пула, юзер получает тот же ип адрес. На dhcp сервере тоже самое или зависимо от lease time сессии у юзера есть возможность получат другой ип из пула?

Аватара пользователя
Chupaka
Сообщения: 1692
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Нужен DHCP скрипт/конфиг для мак адресов!

Сообщение Chupaka » 20 фев 2019, 11:35

На pppoe после дисконнекта, если в этот момент другой клиент получит новый адрес, при переподключении первого он тоже, по идее, должен получить новый адрес, а не тот, что у него был. В dhcp, подозреваю, аналогично.

Tiesto
Сообщения: 58
Зарегистрирован: 28 апр 2016, 22:33

Re: Нужен DHCP скрипт/конфиг для мак адресов!

Сообщение Tiesto » 21 фев 2019, 22:24

Спасибо за все информации и помощь.

Ответить