Проблемы с подключением по RDP при двойном NAT

Базовая функциональность RouterOS
Аватара пользователя
sasha300
Сообщения: 96
Зарегистрирован: 03 мар 2016, 16:00
Откуда: Санкт-Петербург

Проблемы с подключением по RDP при двойном NAT

Сообщение sasha300 » 17 мар 2019, 11:53

Привет!
На Xubuntu запускаю Remmina и пытаюсь через по RDP протоколу подключиться к удаленному компу - секунд 5 ждет и вываливает сообщение, что не может установить соединение. Делал несколько раз - ситауция повторяется. На винде запускаю удаленный досуп, подключаюсь, окошко висит секунд 15 и соединение проходит успешно. В дальнейшем из Remmina тоже успешно подключаюсь.
Когда стоял только один Микротик, т.е. был один NAT, то подключение из любой программы происходило мгновенно, а сейчас какие-то траблы =(
В будущем в свою подсеть планирую воткнуть свисток, дабы организовать резервный канал, поэтому пришлось выбрать такую топологию.

Структура сети:
интернет => Микротик с подсетью 192.168.2.0 => Микротик с подсетью 192.168.0.0, ip адрес самого Микротика 192.168.2.50 => комп на винде с разрешением удаленных подключений по RPD протоколу.
На тике с подсетью 192.168.2.0 пробросил порт:
/ip firewall nat
add action=netmap chain=dstnat dst-port=3389 in-interface=\
ether1-External protocol=tcp to-addresses=192.168.2.50 to-ports=3389
на тике с подсетью 192.168.0.0 проброс 3389 порта уже до конечного компа:
add action=netmap chain=dstnat dst-port=3389 in-interface=\
ether1-External protocol=tcp to-addresses=192.168.0.2 to-ports=3389
Есть идеи, как решить данную проблему?

Аватара пользователя
Chupaka
Сообщения: 1810
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение Chupaka » 17 мар 2019, 15:25

Доброго.

Не совсем понимаю, в чём может быть причина такого поведения (при нормальных настройках всё должно работать, как часы), но если причина действительно в двойном NAT'е - то предлагаю просто его убрать :)

Для этого на втором роутере выключить src-nat, а на первом прописать маршрут к 192.168.0.0/24 через 192.168.2.50. Ну и пробрасывать порт на первом сразу на сервер.

Аватара пользователя
sasha300
Сообщения: 96
Зарегистрирован: 03 мар 2016, 16:00
Откуда: Санкт-Петербург

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение sasha300 » 17 мар 2019, 16:05

а потом во второй тик (192.168.0.0) воткну свисток, то он будет работать или надо будет включать nat ?

Аватара пользователя
Chupaka
Сообщения: 1810
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение Chupaka » 17 мар 2019, 18:08

Будет работать. NAT добавится для интерфейса свистка, для вышестоящего роутера он не нужен

Аватара пользователя
sasha300
Сообщения: 96
Зарегистрирован: 03 мар 2016, 16:00
Откуда: Санкт-Петербург

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение sasha300 » 17 мар 2019, 20:00

Спасибочки, сейчас опробую совет!

Аватара пользователя
sasha300
Сообщения: 96
Зарегистрирован: 03 мар 2016, 16:00
Откуда: Санкт-Петербург

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение sasha300 » 17 мар 2019, 20:10

Так?

Код: Выделить всё

/ip route
add distance=1 dst-address=192.168.0.0/24 gateway=192.168.2.50
В нате пробросил порт 3389 прямо на клиентский комп, но не заработало =(

Аватара пользователя
sasha300
Сообщения: 96
Зарегистрирован: 03 мар 2016, 16:00
Откуда: Санкт-Петербург

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение sasha300 » 17 мар 2019, 20:17

попробовал так:

Код: Выделить всё

/ip route
add distance=1 dst-address=192.168.0.0/24 gateway=bridge1 pref-src=192.168.2.50
в нате прописал:

Код: Выделить всё

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-External
add action=netmap chain=dstnat dst-port=3389 in-interface=\
    ether1-External protocol=tcp to-addresses=192.168.0.2 to-ports=3389
не фурычит ( Видать что-то не правильно сделал =(

Аватара пользователя
Chupaka
Сообщения: 1810
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение Chupaka » 17 мар 2019, 20:23

sasha300 писал(а):
17 мар 2019, 20:10
Так?

Код: Выделить всё

/ip route
add distance=1 dst-address=192.168.0.0/24 gateway=192.168.2.50
Да, так. Пинг с роутера на адрес сервера пошёл? А то, может, Policy Routing какой мешает. Правила файрвола на втором роутере пропускают нужный трафик?

С клиентов второго роутера доступ в Интернет есть вообще после выключения НАТа и добавления маршрута? Дайте хоть минимальную диагностику, а не просто "не работает". А то мало ли вы в розетку включить забыли...

Аватара пользователя
sasha300
Сообщения: 96
Зарегистрирован: 03 мар 2016, 16:00
Откуда: Санкт-Петербург

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение sasha300 » 17 мар 2019, 20:26

сейчас опробую, пару минут плиз

Аватара пользователя
sasha300
Сообщения: 96
Зарегистрирован: 03 мар 2016, 16:00
Откуда: Санкт-Петербург

Re: Проблемы с подключением по RDP при двойном NAT

Сообщение sasha300 » 17 мар 2019, 20:34

Chupaka писал(а):
17 мар 2019, 20:23
sasha300 писал(а):
17 мар 2019, 20:10
Так?

Код: Выделить всё

/ip route
add distance=1 dst-address=192.168.0.0/24 gateway=192.168.2.50
Да, так. Пинг с роутера на адрес сервера пошёл? А то, может, Policy Routing какой мешает. Правила файрвола на втором роутере пропускают нужный трафик?
Пинги не идут.
Для чистоты эксперимента на втором тике все правила фаервола отключил. Вобщем ни в Нат, ни в правилах фаервола нет ни одной записи
С клиентов второго роутера доступ в Интернет есть вообще после выключения НАТа и добавления маршрута? Дайте хоть минимальную диагностику, а не просто "не работает". А то мало ли вы в розетку включить забыли...
Я удаленно настраиваю, там не нахожусь, но могу точно сказать, что один из комповв второго роутера точно работает. Попробовал подрубиться через ID TeamViewer - нет коннекта

С первого Микротика пингую комп, который точно включен - пингов нет, вот скрин:
Снимок экрана_2019-03-17_20-35-19.png
Снимок экрана_2019-03-17_20-35-19.png (47.36 КБ) 740 просмотров

Ответить