Приоритет трафика/скорости определенному пользователю (Queues)

Базовая функциональность RouterOS
Аватара пользователя
r136a8
Сообщения: 164
Зарегистрирован: 04 дек 2017, 00:01

Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение r136a8 » 15 сен 2019, 02:45

Добрый день. Пересмотрел несколько статей и немогу понять есть ли возможность реализовать приоритет трафика пользователю через Queues без маркировки трафика? Маркировка для меня сложна и кто-то пишет что для микротика вредно.
https://www.technotrade.com.ua/Articles ... mit_equall
К примеру, в меню Queues - Simple Queues есть правило на определенного пользователя или сети, во вкладке Advanced есть опция priority и там как я понял можно выставлять приоритеты от 1 до 8 где 1 самый высокий приоритет и 8 самый низкий.
Есть сеть на всю квартиру и пользуются ею все члены семьи (грузит ее кто чем - видео закачка, различные автономные устройства и т.д) часто мне нужно что -то скачать и передать но канал загружен кем то или чем то.
Есть ли возможность как-то выставить приоритеты к примеру пк1 приоритет 1, пк2 приоритет 2, пк3 приоритет3 и все остальные в режиме ожидания или что-то в этом роде, когда пк1 перестает что либо передавать или качать все возвращается на место, для всех канал поровну.
Спасибо

Аватара пользователя
Chupaka
Сообщения: 2152
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение Chupaka » 16 сен 2019, 14:00

Добрый.

Основная отправная точка во всех этих приоритезациях - не дать каналу от провайдера до пользовательского роутера забиться, поскольку в этом случае какие пакеты пропускать, а какие дропать будет решать провайдер. Поэтому рекомендуют создать общую очередь для всего трафика и там указать лимит на 5-10% ниже тарифного плана. А потом уже создавать дочерние очереди (через указание Parent) с нужными приоритетами. Более приоритетные очереди (priority=1) имеют шанс достичь своего max-limit быстрее в сравнении с менее приоритетными (priority=8).

Аватара пользователя
r136a8
Сообщения: 164
Зарегистрирован: 04 дек 2017, 00:01

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение r136a8 » 16 сен 2019, 14:30

Chupaka писал(а):
16 сен 2019, 14:00
Добрый.

Основная отправная точка во всех этих приоритезациях - не дать каналу от провайдера до пользовательского роутера забиться, поскольку в этом случае какие пакеты пропускать, а какие дропать будет решать провайдер. Поэтому рекомендуют создать общую очередь для всего трафика и там указать лимит на 5-10% ниже тарифного плана. А потом уже создавать дочерние очереди (через указание Parent) с нужными приоритетами. Более приоритетные очереди (priority=1) имеют шанс достичь своего max-limit быстрее в сравнении с менее приоритетными (priority=8).
Вы не встречали более-менее понятную инструкцию по настройке выше Вами сказанного
Я нашел вот такую, пункт 5.3 (5.3 Использование CIR и MIR при распределении пропускной способности)
https://spw.ru/educate/articles/queues- ... -mikrotik/

Код: Выделить всё

/queue simple
add max-limit=10M/10M anme=queue_parent target=172.16.1.0/24, 172.16.2.0/24
add limit-at=2M/2M max-limit=10M/10M name=queue_R1 parent=queue_parent priority=6/6 target=172.16.1.0/24
add limit-at=2M/2M max-limit=10M/10M name=queue_R2 parent=queue_parent priority=1/1 target=172.16.2.0/24
Спасибо

Аватара пользователя
Chupaka
Сообщения: 2152
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение Chupaka » 16 сен 2019, 15:34

Ну, в целом - то, что я и описал. target, наверное, можно и просто интернет-аплинк указать.

Увы, инструкции не собираю и почти не читаю, ибо много чего в них обычно глаза режет и противоречит моему внутреннему перфекционисту :)

Аватара пользователя
r136a8
Сообщения: 164
Зарегистрирован: 04 дек 2017, 00:01

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение r136a8 » 17 сен 2019, 18:43

Chupaka писал(а):
16 сен 2019, 15:34
Ну, в целом - то, что я и описал. target, наверное, можно и просто интернет-аплинк указать.

Увы, инструкции не собираю и почти не читаю, ибо много чего в них обычно глаза режет и противоречит моему внутреннему перфекционисту :)
Помогите разобратся, вот что я сделал. Нужно первым двум устройствам дать самый высокий приоритет, далее средний приоритет и низкий приоритет. В Advanced - Limit At. чт за скорость надо указать? В General - Max Limit для всех одинаковый?

Скорость сети 200Mb реальная скорость 180Mb +/- на отдачу около 10 Mb +/-

Код: Выделить всё

/queue simple
add max-limit=200M/200M name=queue_parent target=\
    192.168.5.45/32,192.168.5.44/32,192.168.5.47/32,192.168.5.46/32
add limit-at=150M/150M max-limit=200M/200M name=queue_lenovo parent=\
    queue_parent priority=1/1 target=192.168.5.44/32
add limit-at=100M/100M max-limit=200M/200M name=queue_mac parent=queue_parent \
    priority=6/6 target=192.168.5.45/32
add limit-at=100M/100M max-limit=200M/200M name=queue_nas parent=queue_parent \
    priority=6/6 target=192.168.5.47/32
add limit-at=100M/100M max-limit=200M/200M name=queue_miphone parent=\
    queue_parent priority=6/6 target=192.168.5.46/32
Все тоже только в картиках
Изображение

Изображение

Аватара пользователя
Sir_Prikol
Сообщения: 298
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение Sir_Prikol » 17 сен 2019, 20:23

Думаю разберётесь, под себя поправить проблем особых нет

Код: Выделить всё

/queue tree
add max-limit=40M name=DOWNLOAD parent=global
add max-limit=40M name=UPLOAD parent=global
/queue type
add kind=pcq name=torrent-upload pcq-classifier=src-address \
    pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
add kind=pcq name=torrent-download pcq-classifier=dst-address \
    pcq-dst-address6-mask=64 pcq-rate=5M pcq-src-address6-mask=64
add kind=pcq name=PCQ-DOWNLOAD pcq-classifier=dst-address
add kind=pcq name=PCQ-UPLOAD pcq-classifier=src-address

/queue tree
add name=SUPER-HIGH-DOWNLOAD packet-mark=SUPER-HIGH-DOWNLOAD parent=DOWNLOAD \
    priority=1 queue=PCQ-DOWNLOAD
add name=HIGH-DOWNLOAD packet-mark=HIGH-DOWNLOAD parent=DOWNLOAD priority=2 \
    queue=PCQ-DOWNLOAD
add name=NORMAL-DOWNLOAD packet-mark=NORMAL-DOWNLOAD parent=DOWNLOAD \
    priority=3 queue=PCQ-DOWNLOAD
add name=LOW-DOWNLOAD packet-mark=LOW-DOWNLOAD parent=DOWNLOAD priority=4 \
    queue=PCQ-DOWNLOAD
add name=SUPER-HIGH-UPLOAD packet-mark=SUPER-HIGH-UPLOAD parent=UPLOAD \
    priority=1 queue=PCQ-UPLOAD
add name=HIGH-UPLOAD packet-mark=HIGH-UPLOAD parent=UPLOAD priority=2 queue=\
    PCQ-UPLOAD
add name=NORMAL-UPLOAD packet-mark=NORMAL-UPLOAD parent=UPLOAD priority=3 \
    queue=PCQ-UPLOAD
add name=LOW-UPLOAD packet-mark=LOW-UPLOAD parent=UPLOAD priority=4 queue=\
    PCQ-UPLOAD


/ip firewall mangle
add action=accept chain=forward comment="############## LOW #############" \
    disabled=yes
add action=mark-connection chain=forward comment=ALL-TRAFFIC \
    new-connection-mark=LOW passthrough=yes
add action=mark-packet chain=forward comment=LOW-DOWNLOAD connection-mark=LOW \
    dst-address-list=LAN new-packet-mark=LOW-DOWNLOAD passthrough=yes \
    src-address-list=!LAN-EXCEPTION
add action=mark-packet chain=prerouting comment=LOW-UPLOAD connection-mark=\
    LOW dst-address-list=!LAN-EXCEPTION new-packet-mark=LOW-UPLOAD \
    passthrough=yes src-address-list=LAN
add action=accept chain=forward comment="############## END LOW #########" \
    disabled=yes
add action=accept chain=forward comment="############## NORMAL #########" \
    disabled=yes
add action=mark-connection chain=forward comment=HTTP layer7-protocol=HTTP \
    new-connection-mark=NORMAL passthrough=yes protocol=tcp
add action=mark-connection chain=forward comment=HTTPS new-connection-mark=\
    NORMAL passthrough=yes port=443 protocol=tcp
add action=mark-connection chain=forward comment=Proxy new-connection-mark=\
    NORMAL passthrough=yes port=3128,8080 protocol=tcp
add action=mark-connection chain=forward comment=FTP new-connection-mark=\
    NORMAL passthrough=yes port=20,21 protocol=tcp
add action=mark-connection chain=forward comment=SFTP new-connection-mark=\
    NORMAL packet-size=1300-1600 passthrough=yes port=22 protocol=tcp
add action=mark-connection chain=forward comment=SMTP new-connection-mark=\
    NORMAL passthrough=yes port=25 protocol=tcp
add action=mark-connection chain=forward comment=SMTPS new-connection-mark=\
    NORMAL passthrough=yes port=465 protocol=tcp
add action=mark-connection chain=forward comment=IMAP new-connection-mark=\
    NORMAL passthrough=yes port=143 protocol=tcp
add action=mark-connection chain=forward comment=POP3 new-connection-mark=\
    NORMAL passthrough=yes port=110 protocol=tcp
add action=mark-connection chain=forward comment=POP3S new-connection-mark=\
    NORMAL passthrough=yes port=995 protocol=tcp
add action=mark-connection chain=forward comment=IMAPS new-connection-mark=\
    NORMAL passthrough=yes port=993 protocol=tcp
add action=mark-connection chain=forward comment=GIF_FILE layer7-protocol=\
    GIF_FILE new-connection-mark=NORMAL passthrough=yes
add action=mark-connection chain=forward comment=PNG_FILE layer7-protocol=\
    PNG_FILE new-connection-mark=NORMAL passthrough=yes
add action=mark-connection chain=forward comment=JPG_FILE layer7-protocol=\
    JPG_FILE new-connection-mark=NORMAL passthrough=yes
add action=mark-connection chain=forward comment="100Kb Connections" \
    connection-bytes=0-100000 new-connection-mark=NORMAL passthrough=yes \
    protocol=tcp
add action=mark-packet chain=forward comment=NORMAL-DOWNLOAD connection-mark=\
    NORMAL dst-address-list=LAN new-packet-mark=NORMAL-DOWNLOAD passthrough=\
    yes src-address-list=!LAN-EXCEPTION
add action=mark-packet chain=prerouting comment=NORMAL-UPLOAD \
    connection-mark=NORMAL dst-address-list=!LAN-EXCEPTION new-packet-mark=\
    NORMAL-UPLOAD passthrough=yes src-address-list=LAN
add action=accept chain=forward comment=\
    "############## END NORMAL ############" disabled=yes
add action=accept chain=forward comment="############## HIGH ############" \
    disabled=yes
add action=mark-connection chain=forward comment=ICQ new-connection-mark=HIGH \
    passthrough=yes port=5190 protocol=tcp
add action=mark-connection chain=forward comment=Jabber new-connection-mark=\
    HIGH passthrough=yes port=5222,5223 protocol=tcp
add action=mark-connection chain=forward comment=IRC new-connection-mark=HIGH \
    passthrough=yes port=6667-6669 protocol=tcp
add action=mark-connection chain=forward comment=SSH new-connection-mark=HIGH \
    packet-size=0-1400 passthrough=yes port=22 protocol=tcp
add action=mark-connection chain=forward comment=TELNET new-connection-mark=\
    HIGH passthrough=yes port=23 protocol=tcp
add action=mark-connection chain=forward comment=SNMP new-connection-mark=\
    HIGH passthrough=yes port=161-162 protocol=tcp
add action=mark-connection chain=forward comment=PPTP new-connection-mark=\
    HIGH passthrough=yes port=1723 protocol=tcp
add action=mark-connection chain=forward comment=L2TP new-connection-mark=\
    HIGH passthrough=yes port=1701 protocol=udp
add action=mark-connection chain=forward comment=GRE new-connection-mark=HIGH \
    passthrough=yes protocol=gre
add action=mark-connection chain=forward comment="50Kb Connections" \
    connection-bytes=0-50000 new-connection-mark=HIGH passthrough=yes \
    protocol=tcp
add action=mark-packet chain=forward comment=HIGH-DOWNLOAD connection-mark=\
    HIGH dst-address-list=LAN new-packet-mark=HIGH-DOWNLOAD passthrough=yes \
    src-address-list=!LAN-EXCEPTION
add action=mark-packet chain=prerouting comment=HIGH-UPLOAD connection-mark=\
    HIGH dst-address-list=!LAN-EXCEPTION new-packet-mark=HIGH-UPLOAD \
    passthrough=yes src-address-list=LAN
add action=accept chain=forward comment="############## END HIGH ##########" \
    disabled=yes
add action=accept chain=forward comment=\
    "############## SUPER-HIGH ##########" disabled=yes
add action=mark-connection chain=forward comment=CounterStrike \
    new-connection-mark=SUPER-HIGH passthrough=yes port=\
    27005,27014-27025,27035,52046-52048,52146 protocol=udp
add action=mark-connection chain=forward comment=DNS new-connection-mark=\
    SUPER-HIGH passthrough=yes port=53 protocol=tcp src-port=53
add action=mark-connection chain=forward comment=DNS new-connection-mark=\
    SUPER-HIGH passthrough=yes port=53 protocol=tcp
add action=mark-connection chain=forward comment=DNS new-connection-mark=\
    SUPER-HIGH passthrough=yes port=53 protocol=udp
add action=mark-connection chain=forward comment=NNTP new-connection-mark=\
    SUPER-HIGH passthrough=yes port=119 protocol=tcp
add action=mark-connection chain=forward comment=Winbox new-connection-mark=\
    SUPER-HIGH passthrough=yes port=8291 protocol=tcp
add action=mark-connection chain=forward comment=ntp new-connection-mark=\
    SUPER-HIGH passthrough=yes port=123 protocol=udp
add action=mark-connection chain=forward comment=VNC new-connection-mark=\
    SUPER-HIGH passthrough=yes port=5900-5901 protocol=tcp
add action=mark-connection chain=forward comment=RDP new-connection-mark=\
    SUPER-HIGH passthrough=yes port=3389 protocol=tcp
add action=mark-connection chain=forward comment=PING new-connection-mark=\
    SUPER-HIGH passthrough=yes protocol=icmp
add action=mark-connection chain=forward comment="5Kb Connections" \
    connection-bytes=0-5000 new-connection-mark=SUPER-HIGH passthrough=yes \
    protocol=tcp
add action=mark-packet chain=forward comment=SUPER-HIGH-DOWNLOAD \
    connection-mark=SUPER-HIGH dst-address-list=LAN new-packet-mark=\
    SUPER-HIGH-DOWNLOAD passthrough=yes src-address-list=!LAN-EXCEPTION
add action=mark-packet chain=prerouting comment=SUPER-HIGH-UPLOAD \
    connection-mark=SUPER-HIGH dst-address-list=!LAN-EXCEPTION \
    new-packet-mark=SUPER-HIGH-UPLOAD passthrough=yes src-address-list=LAN
add action=accept chain=forward comment=\
    "############## END SUPER-HIGH ##########" disabled=yes

Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Chupaka
Сообщения: 2152
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение Chupaka » 18 сен 2019, 00:40

Limit-at — это скорость, до достижения которой не будет применяться никаких ограничений. Её либо не указывайте, либо значения должны быть достаточно малы. У вас получилось, что если все будут качать по 80 Мбит/с, то очереди работать не будут.

Аватара пользователя
r136a8
Сообщения: 164
Зарегистрирован: 04 дек 2017, 00:01

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение r136a8 » 18 сен 2019, 01:01

Chupaka писал(а):
18 сен 2019, 00:40
Limit-at — это скорость, до достижения которой не будет применяться никаких ограничений. Её либо не указывайте, либо значения должны быть достаточно малы. У вас получилось, что если все будут качать по 80 Мбит/с, то очереди работать не будут.
так если вовсе ничего не указывать то получается значение "ulimited"?
Если поставить к примеру по 10Mb (тем у которых высокий приоритет тоже указывать?) и если кто-то достигнет этой скорости и у него будет более низкий приоритет он будет понижен при условии использования 10Mb (в данный момент) у пользователей с высоким приоритетом, а если пользователь с высоким приоритетом простаивает (нет загрузки в 10Mb) то пользователь с низким приоритетом сможет приодалеть отметку 10Mb, правильно?
Для parent записи значение Limit-at укзывать?

Аватара пользователя
Chupaka
Сообщения: 2152
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение Chupaka » 19 сен 2019, 18:32

Если ничего - то это, по сути, 0/0.
Т.е. до достижения этой скорости никакие ограничения не работают, пакеты пролетают очередь, не задерживаясь. А уж потом, при увеличении потребления, пользователь с бОльшим приоритетом имеет больше шансов достичь скорости своего max-limit.

Аватара пользователя
r136a8
Сообщения: 164
Зарегистрирован: 04 дек 2017, 00:01

Re: Приоритет трафика/скорости определенному пользователю (Queues)

Сообщение r136a8 » 19 сен 2019, 22:44

Chupaka писал(а):
19 сен 2019, 18:32
Если ничего - то это, по сути, 0/0.
Т.е. до достижения этой скорости никакие ограничения не работают, пакеты пролетают очередь, не задерживаясь. А уж потом, при увеличении потребления, пользователь с бОльшим приоритетом имеет больше шансов достичь скорости своего max-limit.
А для parent записи приоритет нужно указывать(какой)?

Ответить