Zebedee через Mikrotik

Базовая функциональность RouterOS
mkapustin
Сообщения: 22
Зарегистрирован: 03 дек 2018, 16:18

Zebedee через Mikrotik

Сообщение mkapustin »

Добрый день. Я сам чайник в Mikrotik, но была поставлена зада и с ней нужно разбираться, так что если кто сможет, то подскажите пожалуйста.

Задача такая: Есть локальная сеть с адресами 192.168.1.0-192.168.1.255. Доступ в интернет организован через Mikrotik к которому подключен модем ByFly ZTE. (адрес микротика 192.168.1.2) Есть в сети комп, на нем поднято VPN соединение (192.168.1.215 VPN) на который сделан белый DNS имя (...hldns.ru) по которому мы получаем свой IP в интернете. На данном компе стоит прога работающая на FireBird.
Необходимо наладить удаленный доступ к программе на FireBird из интернета. Выбор пал на Zebedee, но я не могу попасть в сеть через Mikrotik. Мой DNS не пингуется на удаленном компе.
Подскажите как можно настроить или где посмотреть.

Аватара пользователя
Chupaka
Сообщения: 2470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Zebedee через Mikrotik

Сообщение Chupaka »

Добрый.

Что-то не совсем понял, не пингуется именно DNS или не пингуется доменное имя ...hldns.ru?

Что за VPN поднят? Сторонний какой-то?

mkapustin
Сообщения: 22
Зарегистрирован: 03 дек 2018, 16:18

Re: Zebedee через Mikrotik

Сообщение mkapustin »

VPN через PPTP соединение. не пингуется доменное имя.
Но когда я подключаюсь к интернету через wi-fi на микротике, делаю перенаправление портов - все работает. А из внешней сети Интернет (дома) ничего нету.

Аватара пользователя
Chupaka
Сообщения: 2470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Zebedee через Mikrotik

Сообщение Chupaka »

Судя по всему, файрвол мешает пингу каким-то образом. Надо смотреть ваши настройки.

mkapustin
Сообщения: 22
Зарегистрирован: 03 дек 2018, 16:18

Re: Zebedee через Mikrotik

Сообщение mkapustin »

А если Вам backup настроек скинуть, сможете посмотреть? И куда тогда скинуть?

Аватара пользователя
Chupaka
Сообщения: 2470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Zebedee через Mikrotik

Сообщение Chupaka »

Нет, не смогу. Backup - это двоичный файл. Надо "/export hide-sensitive" делать в Терминале

mkapustin
Сообщения: 22
Зарегистрирован: 03 дек 2018, 16:18

Re: Zebedee через Mikrotik

Сообщение mkapustin »

Вот сообщение из терминала

Код: Выделить всё

# mar/19/2020 16:15:44 by RouterOS 6.40.4
# software id = GXSL-D1BV
#
# model = 951G-2HnD
# serial number = 8A700879824B
/interface wireless
set [ find default-name=wlan1 ] disabled=no mode=ap-bridge name=VMRZ ssid=VMRZ tx-power-mode=all-rates-fixed
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment=LAN
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=ByFly use-peer-dns=yes [email protected]
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik
/ip firewall layer7-protocol
add name=torrent regexp="^.*peer_id.*\$"
/ip pool
add name=VPNPool ranges=192.168.1.201-192.168.1.215
add name=dhcp_pool1 ranges=192.168.0.1,192.168.0.3-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=VMRZ name=dhcp1
/ppp profile
add dns-server=8.8.8.8,8.8.4.4 local-address=192.168.1.2 name=VPN remote-address=VPNPool
/queue simple
add max-limit=32k/32k name=users-udp packet-marks=users-udp target=""
/system logging action
set 0 memory-lines=1
/interface pptp-server server
set enabled=yes
/ip address
add address=192.168.1.2/24 interface=ether2 network=192.168.1.0
add address=192.168.0.2/24 interface=VMRZ network=192.168.0.0
/ip dhcp-server network
add address=192.168.0.0/24 gateway=192.168.0.2
/ip firewall address-list
add address=vmrz.hldns.ru list=zebedee
/ip firewall filter
add action=accept chain=input comment="accept establish" connection-state=established
add action=accept chain=input comment="accept related" connection-state=related
add action=drop chain=input comment="drop invalid" connection-state=invalid
add action=accept chain=input comment="accept ICMP" protocol=icmp
add action=accept chain=input dst-port=11965 in-interface=ether1 protocol=tcp
add action=accept chain=input in-interface=ByFly
add action=accept chain=forward connection-state=established
add action=accept chain=forward connection-state=related
add action=drop chain=forward dst-address-list=users in-interface=ether1 src-address-list=garbage
add action=add-dst-to-address-list address-list=garbage address-list-timeout=1w chain=forward layer7-protocol=torrent out-interface=ether1 protocol=tcp src-address-list=users
add action=add-src-to-address-list address-list=garbage address-list-timeout=1h chain=forward connection-bytes=5000000-0 dst-address-list=users in-interface=ether1 protocol=tcp
add action=drop chain=forward comment="invalid connections" connection-state=invalid
add action=drop chain=input in-interface=!ether2
add action=drop chain=forward dst-address-list=garbage out-interface=ether1 src-address-list=users
add action=accept chain=forward in-interface=ether2 src-address=192.168.1.0/24
add action=accept chain=input in-interface=ether2 src-address=192.168.1.0/24
/ip firewall mangle
add action=mark-packet chain=forward dst-address-list=users in-interface=ether1 new-packet-mark=users-udp passthrough=yes protocol=udp
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ByFly
add action=netmap chain=dstnat comment=Zebedee dst-port=11965 in-interface=ether1 protocol=tcp to-addresses=192.168.1.215 to-ports=11965
/ip route
add distance=1 gateway=192.168.1.1
/ip service
set www port=11965
/ppp secret
add name=tmp profile=VPN service=pptp
add name=server-p profile=VPN service=pptp
add name=kassa profile=VPN service=pptp
add name=tmp2 profile=VPN service=pptp
add name=tmp3 profile=VPN service=pptp
add name=Server-F profile=VPN service=pptp
add name=Server-H profile=VPN service=pptp
add name=tmp4 profile=VPN service=pptp
/system clock
set time-zone-name=Europe/Minsk
/tool e-mail
set from=""

mkapustin
Сообщения: 22
Зарегистрирован: 03 дек 2018, 16:18

Re: Zebedee через Mikrotik

Сообщение mkapustin »

Может чем поможете

Аватара пользователя
Chupaka
Сообщения: 2470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Zebedee через Mikrotik

Сообщение Chupaka »

Так, я что-то вообще потерялся. Комп поднимает VPN из локальной сети роутера на сам роутер, или куда? Вы нарисуйте схему, может, чтоб понятнее стало...

mkapustin
Сообщения: 22
Зарегистрирован: 03 дек 2018, 16:18

Re: Zebedee через Mikrotik

Сообщение mkapustin »

да. В сети интернет раздается через дополнительный прокси-сервер, где установлены разные ограничения и скорость раздается всем одинаковая. Но есть компы, которым нужен выход напрямую, минуя прокси, т.к. через прокси нельзя зайти на некоторые сайты и проги некоторые не работают: налоговая, ЭСФЧ и т.д.
Но мне нужно сейчас настроить подключение по удаленке к базе. Может нужен еще какой-то VPN или еще что-то я не знаю. Я в этой сфере не компетентен, так что приму любые предложения и помощь.
Спасибо.