Вывод списка sstp подключений

Базовая функциональность RouterOS
sektor1100
Сообщения: 2
Зарегистрирован: 27 апр 2020, 14:22

Вывод списка sstp подключений

Сообщение sektor1100 »

Всем привет!
При вводе команды /ppp active print мы получаем вывод состоящий из нескольких столбцов таких как NAME, SERVICE, Address и тд. Может ли микротик сделать вывод например только имен?
Используя команду :put [/ppp active get [find name=user1] name ] я получу вывод одной строкой user1, а теперь, как сделать так чтобы вышел список абсолютно всех пользователей и может ли микротик так сделать вообще?
При попытке ввода такой команды :put [/ppp active get [find name!=all] name ] (где ALL это не существующее имя) получаю ошибку: invalid internal item number

Аватара пользователя
Chupaka
Сообщения: 2584
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Вывод списка sstp подключений

Сообщение Chupaka »

Приветствую.

Честно говоря, я не вижу связи между названием темы и содержанием вашего сообщения, но вам определённо нужен простой цикл :)

Код: Выделить всё

/ppp active
:foreach i in=[find name!="ALL"] do={
	:put [get $i name];
}

sektor1100
Сообщения: 2
Зарегистрирован: 27 апр 2020, 14:22

Re: Вывод списка sstp подключений

Сообщение sektor1100 »

Благодарю за ответ.
Да, на самом деле мой вопрос можно было отнести к "общей" теме использования функции GET на микроте, но так как у меня возникла проблема именно с выдергиванием учеток ppp, то решил конкретизировать название темы )

Благодарю, завтра попробую использовать данный цикл не посредственно на микроте, а на данный момент я просто написал не большой скрипт на питоне и выдернул все учетки тем самым решив свою проблему )))

Аватара пользователя
Chupaka
Сообщения: 2584
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Вывод списка sstp подключений

Сообщение Chupaka »

Ну, если вам надо было просто содержимое одного столбца - то сейчас, наверное, в любом текстовом редакторе есть блочное выделение: выделили всё содержимое колонки, скопировали - и вставили в новый документ только список имён :)