Два провайдера и реализация одновременного опроса двух каналов

Базовая функциональность RouterOS
Foxter
Сообщения: 1
Зарегистрирован: 18 фев 2021, 14:18

Два провайдера и реализация одновременного опроса двух каналов

Сообщение Foxter »

Добрый день коллеги. Вопрос может быть идиотским, но я так и не могу понять причину.

Есть две железки (хотя не в них суть) CCR-1009 и RB2011 на которых висит по два провайдера, схему настраивал сам лет так 6 назад. Отбросим описание, стенд из одного маршрутизатора CCR-1036 без каких-либо настроек:

/ip address
add address=xxx.47.177.6/24 interface=ether2 network=xxx.47.177.0
add address=xxx.143.125.70/24 interface=ether3 network=xxx.143.125.0
add address=192.168.99.1/24 interface=ether4 network=192.168.99.0

/ip route
add comment=ISP1 distance=1 gateway=xxx.47.177.1
add comment=ISP2 distance=2 gateway=xxx.143.125.1

/ip dns
set servers=8.8.8.8

На указанных выше железках я могу спокойно опрашивать с самого маршрутизатора любой из каналов не прибегая к маркировке соединений, пакетов, маршрутов итд.

[[email protected]] > ping ya.ru interface=ether2
SEQ HOST SIZE TTL TIME STATUS
0 87.250.250.242 56 57 8ms
1 87.250.250.242 56 57 7ms
2 87.250.250.242 56 57 7ms
3 87.250.250.242 56 57 8ms
sent=4 received=4 packet-loss=0% min-rtt=7ms avg-rtt=7ms max-rtt=8ms

[[email protected]] > ping ya.ru interface=ether3
SEQ HOST SIZE TTL TIME STATUS
0 87.250.250.242 56 57 8ms
1 87.250.250.242 56 57 7ms
2 87.250.250.242 56 57 5ms
3 87.250.250.242 56 57 9ms
sent=4 received=4 packet-loss=0% min-rtt=7ms avg-rtt=8ms max-rtt=9ms

Настраивая новый CCR-1036 столкнулся с тем, что при добавлении второго маршрута по умолчанию, он как обычно становится не активным, как и на указанных выше железках, но тем ни менее я мог принудительно с самого маршрутизатора опросить как один, так и второй канал, теперь нет. Я понимаю, что такое поведение не нормально, но оно отжило много лет и прекрасно работает и по сей день с актуальной версией прошивки, скрипты переключалки довел до идеальной работы с учетом всех подводных камней. Если несколько раз поменять у маршрутов дистанцию и сбросить текущие соединения, то старая схема работает, но костыльно. Интересно не почему не работает текущая схема, она в теории и не должна работать, а почему работает старая и не на одной железке. Сразу хочу отметить что таблица NAT, Mangle да и сам Firewall пустая (все правила на старых железках отключил для теста)
Аватара пользователя
Chupaka
Сообщения: 3062
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Два провайдера и реализация одновременного опроса двух каналов

Сообщение Chupaka »

Здравствуйте.

Если честно, я не очень понимаю подкапотный механизм работы команды "ping УУУ interface=ХХХ" (уж слишком много шероховатостей там возможно), поэтому могу предположить, что правила NAT всё же как-то помогают работоспособности.

Но из текста непонятно, что именно вы делаете. Переносите конфиг на новый роутер с такой же версией прошивки - и там он не работает, хотя на нескольких других роутерах такой же конфиг нормально функционирует?..