СМС Скрипт для мониторинга главного линка [решено]

Базовая функциональность RouterOS
nevolex
Сообщения: 39
Зарегистрирован: 04 фев 2021, 14:34

СМС Скрипт для мониторинга главного линка [решено]

Сообщение nevolex »

Всем привет,

какое-то время назад у меня была идея сделать смс скрипт кторый бы мне отправлял смс если главный провайдер отваливался

Модем у меня на другом роутере, который работает как pass-through и пробрасывает прямой публичный айпи прямо в таблицу основного роутера, все впринципе как и должно быть (тоесть есть главный линк (роутер 1 )и запасной линк через мобильного оператора (роутер 2 тоесть модем))

Проблема в том, что второй роутер не видит прямой маршрут до шлюза основго провайдера и идет через дефолтный маршрут первого роутера тоесть если главный провайдер падает то он это не видит так как все еще 10.10.0.1 есть

Я патался утсаноить в netwatch какой-нибудь 8.8.8.8 модем это пингует (интервал 1 минута), выключаю главный линк он фейловер на мобильного сразу и смс не прихоит как так все работает уже через 2 секунды


netwatch я делал пинг моего выделанного ip первого провайдера и все работало - нет выделанного ip первого провайдера - значит первый проваейдер down

сейчас у меня ip меняется и так больше не рабоает


срипт у меня был такой на down и такой же на up
:local CurDate ([:pick [/system clock get date] 4 6] . "/" . [:pick [/system clock get date] 0 3] . "/" . [:pick [/system clock get date] 7 11])
:local CurTime [/system clock get time]
:local HostName "Primary ISP link"
:local HostIP "121.99.24x.xx"

:log info "$HostName $HostIP is DOWN"

/tool sms send lte1 "+6xxxxxxxxxxx" message="$HostName is DOWN at $CurDate $CurTime"
а в низу таблицы маршрутизации главного роутера и "модема"

скажите пожайлста, сталкивался ли кто-нибудь с таким
спасибо
routing_table.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Последний раз редактировалось nevolex 19 фев 2021, 11:35, всего редактировалось 1 раз.
Аватара пользователя
Chupaka
Сообщения: 3062
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: СМС Скрипт для мониторинга главного линка

Сообщение Chupaka »

Приветствую.
nevolex писал(а): 18 фев 2021, 22:28 Я патался утсаноить в netwatch какой-нибудь 8.8.8.8 модем это пингует (интервал 1 минута), выключаю главный линк он фейловер на мобильного сразу и смс не прихоит как так все работает уже через 2 секунды
Дабы исключить 8.8.8.8 из фейловера - можно его гвоздями прибить к основному каналу (вы не упомянули, что он из себя представляет, так что использую шлюз со скриншота):

Код: Выделить всё

/ip route add dst-address=8.8.8.8 gateway=121.99.224.1
/ip route add dst-address=8.8.8.8 type=unreachable distance=200
nevolex
Сообщения: 39
Зарегистрирован: 04 фев 2021, 14:34

Re: СМС Скрипт для мониторинга главного линка

Сообщение nevolex »

Спасибо Chupaka, буду тестить :)
nevolex
Сообщения: 39
Зарегистрирован: 04 фев 2021, 14:34

Re: СМС Скрипт для мониторинга главного линка

Сообщение nevolex »

Работает ! :)