Медленный интернет через Mikrotik

Базовая функциональность RouterOS
drongo
Сообщения: 45
Зарегистрирован: 27 ноя 2020, 12:33

Медленный интернет через Mikrotik

Сообщение drongo »

Добрый день. Ситуация следующая. Есть 3011 Mikrotik. Есть локалка и интернет от белтелекома. Нужно дать доступ юзерам локалки в интернет. Интернет приходит витухой через поновский модем.
Что было сделано:

Шнурок от модема втыкнут в первый порт Микротика. (Модем соединение не поднимает. в модем просто приходит оптика, а выходит витуха). Первый порт микротика переведен в wan. Создано PPPoE подключение. (ip адрес белый). Объединены два порта 9 и 10 в бридж как для локалной сети. Бриджу дан ip адрес из моей локальной сети, он же адрес микротика 192.168.3.254. Юзеры должны бегать в интернет через Mikrotik. Все настроено, но интернет работает как бы с задержкой, как будто что-то его тормозит.
Интерфейсы

Код: Выделить всё

/interface list member
add interface=ByFly-Internet list=WAN
add interface=Internet list=WAN
add interface=Local_Bridge list=LAN
Правила Firewall

Код: Выделить всё

add action=accept chain=input comment="Input Internet establ and relat" \ connection-state=established,related in-interface=ByFly-Internet
    
add action=accept chain=input comment="Input from Internet establ and relat" \ connection-state=established,related
    
add action=drop chain=input comment="Drop invalid from Internet" \   connection-state=invalid in-interface=ByFly-Internet
add action=drop chain=input comment="Drop invalid from Internet" \    connection-state=invalid

add action=accept chain=input comment="Access to config from Local" \   in-interface=Local_Bridge log-prefix=main src-address=192.168.3.0/24

add action=add-src-to-address-list address-list=BlackList address-list-timeout=\    10h chain=input comment="Block Ip port scanning" connection-state=new \  dst-port=20,110,161,443,445,3128,3306,3333,3389,7547,8291,8080-8082 log=yes \    log-prefix="block list" protocol=tcp

add action=drop chain=input comment="Drop All from Internet" in-interface=\   ByFly-Internet log-prefix=dropallint

/ip firewall nat
add action=masquerade chain=srcnat log-prefix=nat out-interface=ByFly-Internet \    src-address=192.168.3.0/24
Пользователи имеют статику, шлюзом и DNS сервером у них прописан адрес микротика 192.168.3.254. На самом микротике DNS сервера выставились автоматом от БТК.

При таких настройках интернет работает медленнее. В сети еще есть прокси-сервер. Через него интернет работает быстрее. Все клиенты ломятся на комп в сети, на этом компе тоже настроен шлюз и dns адрес микротика 192.168.3.254.

В чем может быть проблема?
Аватара пользователя
Chupaka
Сообщения: 3260
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Медленный интернет через Mikrotik

Сообщение Chupaka »

Здравствуйте.
drongo писал(а): 19 авг 2021, 09:02 Первый порт микротика переведен в wan.
Что имеется в виду? QuickSet?
drongo писал(а): 19 авг 2021, 09:02 Все настроено, но интернет работает как бы с задержкой, как будто что-то его тормозит.
В чём это проявляется? Если в браузере открыть Инструменты разработчика - там водопад в Network что показывает? В какой момент задержки возникают?
drongo писал(а): 19 авг 2021, 09:02 В сети еще есть прокси-сервер. Через него интернет работает быстрее. Все клиенты ломятся на комп в сети, на этом компе тоже настроен шлюз и dns адрес микротика 192.168.3.254.
Т.е. "клиент - микротик - интернет" тормозит, а "клиент - прокси - микротик - интернет" - нет?
drongo
Сообщения: 45
Зарегистрирован: 27 ноя 2020, 12:33

Re: Медленный интернет через Mikrotik

Сообщение drongo »

Chupaka писал(а): 19 авг 2021, 14:09 Что имеется в виду? QuickSet?
Имеется в виду что на вкладке Interface List порту номер 1 выставлен WAN, А бриджу выставлен LAN. В первый порт приходит шнурок от модема.
Chupaka писал(а): 19 авг 2021, 14:09 В чём это проявляется? Если в браузере открыть Инструменты разработчика - там водопад в Network что показывает? В какой момент задержки возникают?
не совсем понял про водопад. Задержки возникают сразу же. Т.е. пытаешься какой-то сайт открыть, на вкладке в браузере название сайта есть, а страница пустая и грузится. Секунды через 5-7 может открыться, но загрузка все равно продолжается. Если же через прокси, то все летает.
Chupaka писал(а): 19 авг 2021, 14:09 Т.е. "клиент - микротик - интернет" тормозит, а "клиент - прокси - микротик - интернет" - нет?
именно так
Аватара пользователя
Chupaka
Сообщения: 3260
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Медленный интернет через Mikrotik

Сообщение Chupaka »

drongo писал(а): 19 авг 2021, 16:04 Имеется в виду что на вкладке Interface List порту номер 1 выставлен WAN, А бриджу выставлен LAN. В первый порт приходит шнурок от модема.
В приведённых вами правилах я не нашёл использования in/out-interface-list, поэтому это, возможно, ни на что не влияет.
drongo писал(а): 19 авг 2021, 16:04 не совсем понял про водопад. Задержки возникают сразу же. Т.е. пытаешься какой-то сайт открыть, на вкладке в браузере название сайта есть, а страница пустая и грузится. Секунды через 5-7 может открыться, но загрузка все равно продолжается. Если же через прокси, то все летает.
И что при этом водопад показывает? Файлы сайта долго грузятся, или загрузка замирает в каком-то состоянии?
Screenshot 2021-08-20 at 16.31.42.png
У вас нет необходимых прав для просмотра вложений в этом сообщении.
drongo
Сообщения: 45
Зарегистрирован: 27 ноя 2020, 12:33

Re: Медленный интернет через Mikrotik

Сообщение drongo »

Добрый день.
Вот скрины при открытии сайта напрямую через Mikrotik и через прокси.
Напрямую
mikr2.JPG
mikr4.JPG
Через прокси
mikr3.JPG
Долго загружаются скрипты и картинки
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
Chupaka
Сообщения: 3260
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Медленный интернет через Mikrotik

Сообщение Chupaka »

Так, мне похожую картину в Firefox буквально на прошлой неделе показывали. Починилось отключением DNS-over-HTTPS в Firefox. Проверьте?
drongo
Сообщения: 45
Зарегистрирован: 27 ноя 2020, 12:33

Re: Медленный интернет через Mikrotik

Сообщение drongo »

Chupaka писал(а): 23 авг 2021, 12:46 Так, мне похожую картину в Firefox буквально на прошлой неделе показывали. Починилось отключением DNS-over-HTTPS в Firefox. Проверьте?
Браузер значения не имеет. Отключена эта опция в Firefox
Аватара пользователя
Chupaka
Сообщения: 3260
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Медленный интернет через Mikrotik

Сообщение Chupaka »

Ну, можете попробовать ещё MSS понизить: https://wiki.mikrotik.com/wiki/Manual:I ... Change_MSS
drongo
Сообщения: 45
Зарегистрирован: 27 ноя 2020, 12:33

Re: Медленный интернет через Mikrotik

Сообщение drongo »

Не получилось

add out-interface=Local_Bridge protocol=tcp tcp-flags=syn action=change-mss new-mss=1300 chain=forward tcp-mss=1301-65535

Local_Bridge - это моя локалка
Аватара пользователя
kardash
Сообщения: 168
Зарегистрирован: 27 апр 2017, 22:08
Откуда: Минск

Re: Медленный интернет через Mikrotik

Сообщение kardash »

fast track connection в filter rule если это правило удалено или выключено сайты вяловато начинают открываться... Правило существует в настройках по умолчанию.... При конфигурации с нуля - его нет
Мой блог по MikroTik: https://www.netflow.by/blog/tag/MikroTik 8-)