перестал открыватся локальный сайт по локальному IP

Базовая функциональность RouterOS
skif42ru
Сообщения: 3
Зарегистрирован: 06 янв 2023, 14:55

перестал открыватся локальный сайт по локальному IP

Сообщение skif42ru »

Доброго времени!
Перестал открываться локальный сайт по локальному ip. С внешки по белому IP после проброса порта открывается и по доменному имени открывется.
Железка RBD52G-5HacD2HnD
RouterOS 6.49.7
Локальная сеть х.х.х.х/24
Сервер с сайтом на х.х.х.126 (dhcp - привязан маком) сайт работает по https
Мой ПК х.х.х.106 (statics)
Пинги идут, по ssh на сервер подключаюсь.
Где перестало работать не могу понять.
Правила проброса отключил, не помогло.
До этого на этом IP стояла малинка с FlightAware по http и была доступна из локалки как по локальному так и по внешнему IP,
но без доменого имени.
Тут поставил ПК и накатил issabel4 + по случаю за 60 руб. купил доменное имя и прописал его в issabel4.
С вечера вроде все работало, а вот на утро доступ из локалки пропал.
Посмотрите на конфиг, может чего не того накрутил?

Код: Выделить всё

/ip firewall filter
Добавить IP по определенному размеру пакета
add action=add-src-to-address-list address-list=allow-ip address-list-timeout=1h chain=input packet-size=XXXX protocol=icmp
add action=accept chain=input dst-port=8291 protocol=tcp src-address-list=allow-ip

Чтобы фаервол пропускал IPTV
add action=accept chain=input comment="Allow IGMP" in-interface=ether1 protocol=igmp
add action=accept chain=forward comment="IPTV UDP forwarding" dst-port=1234 protocol=udp

разрешаем входящие и исходящие пакеты IPsec
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec

Опция IPv4 FastTrack используется для автоматической маркировки соединений
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related

разрешаем established, related и untracked,
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked

отбросить все недействительные (Invalid) пакеты
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid

запрещает транзит только новым соединениям, только с внешнего списка интерфейсов, кроме соединений прошедших через DNAT.
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN

Разрешаем ICMP
add action=accept chain=input protocol=icmp

Разрешаем все уже установленные подключения
add action=accept chain=input connection-state=established

Разрешаем все зависимые подключения
add action=accept chain=input connection-state=related

блокирует входящие подключения для всех, кроме интерфейса LAN
add action=drop chain=input in-interface-list=!LAN

правило, которое разрешает все действия Address List
add action=accept chain=input comment="Allow Address List" src-address-list=allow-ip




/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat comment=Web dst-port=80 in-interface=ether1 log=yes protocol=tcp to-addresses=х.х.х.126 to-ports=80
add action=dst-nat chain=dstnat comment=Web dst-port=443 in-interface=ether1 log=yes protocol=tcp to-addresses=х.х.х.126 to-ports=443
Последний раз редактировалось skif42ru 06 янв 2023, 17:45, всего редактировалось 1 раз.
Аватара пользователя
Chupaka
Сообщения: 3856
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: перестал открыватся локальный сайт по локальному IP

Сообщение Chupaka »

Приветствую.

Взаимодействие между хостами в одной подсети (например, между 10.5.1.106/24 и 10.5.1.126/24) происходит напрямую, без участия роутера. Максимум, если трафик идёт между разными портами бриджа - может влиять фильтр бриджа. Так что для начала опишите, что значит "Перестал открываться локальный сайт". Таймаут при подключении? Другая какая-то ошибка? Локально вы обращаетесь по IP или через доменное имя?
skif42ru
Сообщения: 3
Зарегистрирован: 06 янв 2023, 14:55

Re: перестал открыватся локальный сайт по локальному IP

Сообщение skif42ru »

Пардон не описал схему, я и сервер на одном порту через тупой гигабитный тп-линк свич.
Таймаут
Как только не пробовал, и по имени и по локальному ip и по внешнему ip
с мобилки через 4g и по имени и по ip сайт открывается.
skif42ru
Сообщения: 3
Зарегистрирован: 06 янв 2023, 14:55

Re: перестал открыватся локальный сайт по локальному IP

Сообщение skif42ru »

Отбой.
issabel4 какогото меня в бан отправила.
зашел с телефона, отключил бан.
день потерял)))