Маршрутизация между двумя роутерами с разными подсетями

RIP, OSFP, BGP, MPLS/VPLS
hitec
Сообщения: 8
Зарегистрирован: 11 июн 2024, 12:23

Маршрутизация между двумя роутерами с разными подсетями

Сообщение hitec »

Добрый день.
Подскажите как решить следующую задачу:
На mikrotik1 Ether1 = WAN, Ether2-EtherN собраны в bridge1 и развернута подсеть 192.168.0.1/24. Сам роутер 192.168.0.1
Есть mikrotik2 у которого Ether1-Ether5 собраны в bridge2, а Ether6-Ether10 собраны в bridge3. bridge2 получает IP =192.168.0.100 от mikrotik1

mikrotik1.bridge1.ether5 и mikrotik2.bridge2.ether1 соединены патчкордом, и все устройства подключенные к mikrotik2.Ether1-Ether5 получают адреса из подсети 192.168.0.1/24 роутера mikrotik1.

Так же на mikrotik2.bridge3 (Ether6-Ether10 ) развернута отдельная подсеть 192.168.1.1/24 со своим dhcp сервером.
Необходимо некоторым клиентам из mikrotik1 (192.168.0.1/24) обращаться к некоторым узлам в mikrotik2 (192.168.1.1/24).
Из интерфейса winbox на mikrotik2, соседняя подсеть mikrotik1 (192.168.0.1/24) пигуется, а вот если делать пинг с устройство подключенных к mikrotik2 соседняя подсеть не видна. Как обеспечить прохождении пакетов клиентов из разных под сетей.
Так же из подсети 192.168.0.1/24 проходит ping на 192.168.1.1 но не на 192.168.1.1/24, а из подсети 192.168.1.1/24 проходит ping на 192.168.0.1 но не на 192.168.0.1/24
Аватара пользователя
Chupaka
Сообщения: 3977
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Маршрутизация между двумя роутерами с разными подсетями

Сообщение Chupaka »

Здравствуйте.
mikrotik1 ничего не знает про 192.168.1.1/24, так что вам просто надо прописать маршрут на нём к 192.168.1.1/24 через 192.168.0.100 (mikrotik2).
hitec
Сообщения: 8
Зарегистрирован: 11 июн 2024, 12:23

Re: Маршрутизация между двумя роутерами с разными подсетями

Сообщение hitec »

Да верно, маршрут на 192.168.1.1/24 через bridge2 (192.168.0.100) я прописал первым делом. Без него ping в 192.168.1.1/24 не проходил. как только добавил появился ping только на 192.168.1.1, а вот до хостов в подсети 192.168.1.1/24 pingа нет.

Мне нужно: 192.168.0.xxx <-> 192.168.0.1 (mikrotik1.bridge1) <-пачкорд-> 192.168.0.100 (mikrotik2.bridge2) <-> 192.168.1.1 (mikrotik2.bridge3) <-> 192.168.1.xxx

Сейчас ping идет до: 192.168.0.xxx <-> 192.168.0.1 (mikrotik1.bridge1) <-> 192.168.0.100 (mikrotik2.bridge2) <-> 192.168.1.1 (mikrotik2.bridge3) <-ХХХ-> далее не идет, хотя автоматические маршруты между бриджами bridge2 и bridge3 mikrotik2 создал сам.
Правил на firewall у mikrotik2 нет никаких, NAT пустой
hitec
Сообщения: 8
Зарегистрирован: 11 июн 2024, 12:23

Re: Маршрутизация между двумя роутерами с разными подсетями

Сообщение hitec »

/interface bridge
add name=bridge1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip pool
add name=pool1 ranges=192.168.0.11-192.168.0.99
/ip dhcp-server
add address-pool=pool1 interface=bridge1 name=dhcpserver1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/ip address
add address=192.168.0.1/24 interface=bridge1 network=192.168.0.0
/ip dhcp-server lease
add address=192.168.0.100 client-id=1:4c:5e:c:99:2b:4c mac-address=\
4C:5E:0C:99:2B:4C server=dhcpserver1
/ip dhcp-server network
add address=192.168.0.0/24 dns-server=192.168.0.1 gateway=192.168.0.1
/ip route
add disabled=no distance=1 dst-address=192.168.1.1/24 gateway=192.168.0.100 \
pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10

-----------------------



/interface bridge
add name=bridge2
add name=bridge3
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=pool1 ranges=192.168.1.11-192.168.1.99
/ip dhcp-server
add address-pool=pool1 interface=bridge3 name=dhcpserver3
/port
set 0 name=serial0
/interface bridge port
add bridge=bridge2 interface=ether1
add bridge=bridge2 interface=ether2
add bridge=bridge2 interface=ether3
add bridge=bridge2 interface=ether4
add bridge=bridge2 interface=ether5
add bridge=bridge2 interface=ether6
add bridge=bridge2 interface=ether7
add bridge=bridge2 interface=ether8
add bridge=bridge3 interface=ether9
add bridge=bridge3 interface=ether10
/ip address
add address=192.168.1.1/24 interface=bridge3 network=192.168.1.0
/ip dhcp-client
add interface=bridge2
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=192.168.1.1 gateway=192.168.1.1
Аватара пользователя
Chupaka
Сообщения: 3977
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Маршрутизация между двумя роутерами с разными подсетями

Сообщение Chupaka »

Проверьте файрвол на конечной машине, тот же Брандмауэр Шindoшc любит закрывать доступ из других подсетей.

Ну и трассировку в обе стороны навстречу друг другу сделайте, на всякий случай...

Если всё плохо - ставьте пинг и на mikrotik2 смотрите через Torch или Packet Sniffer, что куда летит.
hitec
Сообщения: 8
Зарегистрирован: 11 июн 2024, 12:23

Re: Маршрутизация между двумя роутерами с разными подсетями

Сообщение hitec »

Вы были правы, проблема в брандмауэре windows, ответ на ping разрешен только с локальной сети! Как только включить разрешение ответ на Ping из любой подсети, стало ясно что две подсети видят друг друга с теми параметрами которые изначально настроил.
Спасибо!