После апгрейда не поднимается линк с джунипером.

RIP, OSFP, BGP, MPLS/VPLS
Ответить
solegs
Сообщения: 4
Зарегистрирован: 04 окт 2018, 16:33

После апгрейда не поднимается линк с джунипером.

Сообщение solegs » 04 окт 2018, 18:07

Всем доброго!
Есть микротик CCR1016-12S-1S+ , RouterOS 6.34.2
Есть джунипер EX4200, JunOS 12.3R3.4
Они соединены двумя пачкордами, порты аггрегированы и настроены для работы по LACP:
-- на микротике :

Код: Выделить всё

/interface bonding export verbose 
# oct/04/2018 17:43:24 by RouterOS 6.34.2
# software id = 5N56-GKK8
#
/interface bonding
add arp=enabled arp-interval=100ms arp-ip-targets="" arp-timeout=auto disabled=no down-delay=0ms !forced-mac-address lacp-rate=1sec \
    link-monitoring=mii mii-interval=100ms min-links=0 mode=802.3ad mtu=1500 name=bonding1 primary=none slaves=sfp2,sfp3 \
    transmit-hash-policy=layer-2-and-3 up-delay=0ms
    
 /interface ether print detail   
Flags: X - disabled, R - running, S - slave 
...
 1 RS name="sfp2" default-name="sfp2" mtu=1500 l2mtu=1580 mac-address=4C:5E:0C:56:6E:54 orig-mac-address=4C:5E:0C:56:6E:54 arp=enabled 
      auto-negotiation=no advertise=10M-full,100M-full,1000M-full full-duplex=yes tx-flow-control=off rx-flow-control=off speed=1Gbps 
      master-port=none bandwidth=unlimited/unlimited sfp-rate-select=high 

 2 RS name="sfp3" default-name="sfp3" mtu=1500 l2mtu=1580 mac-address=4C:5E:0C:56:6E:55 orig-mac-address=4C:5E:0C:56:6E:55 arp=enabled 
      auto-negotiation=no advertise=10M-full,100M-full,1000M-full full-duplex=yes tx-flow-control=off rx-flow-control=off speed=1Gbps 
      master-port=none bandwidth=unlimited/unlimited sfp-rate-select=high 
...

-- на джунипере :

Код: Выделить всё

[email protected]> show lacp interfaces ae2
Aggregated interface: ae2
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      ge-0/0/23      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      ge-0/0/23    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
      ge-1/0/23      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      ge-1/0/23    Partner    No    No   Yes  Yes  Yes   Yes     Fast    Active
    LACP protocol:        Receive State  Transmit State          Mux State
      ge-0/0/23                 Current   Fast periodic Collecting distributing
      ge-1/0/23                 Current   Fast periodic Collecting distributing

{master:0}
[email protected]> show configuration interfaces ge-0/0/23
description ae2_to_mikrotik;
ether-options {
    802.3ad ae2;
}

{master:0}
[email protected]> show configuration interfaces ge-1/0/23
description ae2_to_mikrotik;
ether-options {
    802.3ad ae2;
}

{master:0}
[email protected]> show configuration interfaces ae2
aggregated-ether-options {
    minimum-links 1;
    lacp {
        active;
        periodic fast;
    }
}
unit 0 {
    family ethernet-switching {
        port-mode access;
        vlan {
            members 62;
        }
    }
}
В этой версии RouterOS (6.34.2) всё работает отлично.

Но стоит обновить прошивку на любую другую версию поновее, как джунипер перестаёт видеть порты микротика, LACP расыпается и никак не удаётся его снова поднять/собрать

-- на джунипере:

Код: Выделить всё

{master:0}
[email protected]> show lacp interfaces ae2
Aggregated interface: ae2
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      ge-0/0/23      Actor    No   Yes    No   No   No   Yes     Fast    Active
      ge-0/0/23    Partner    No   Yes    No   No   No   Yes     Fast   Passive
      ge-1/0/23      Actor    No   Yes    No   No   No   Yes     Fast    Active
      ge-1/0/23    Partner    No   Yes    No   No   No   Yes     Fast   Passive
    LACP protocol:        Receive State  Transmit State          Mux State
      ge-0/0/23           Port disabled     No periodic           Detached
      ge-1/0/23           Port disabled     No periodic           Detached
      
{master:0}
[email protected]> show interfaces ge-0/0/23
Physical interface: ge-0/0/23, Enabled, Physical link is Down
  Interface index: 167, SNMP ifIndex: 550
  Description: ae2_to_mikrotik
  Link-level type: Ethernet, MTU: 1514, Speed: 1000mbps, Duplex: Auto, BPDU Error: None, MAC-REWRITE Error: None,
  Loopback: Disabled, Source filtering: Disabled, Flow control: Disabled, Auto-negotiation: Enabled,
  Remote fault: Online, Media type: Copper
  Device flags   : Present Running Down
  Interface flags: Hardware-Down SNMP-Traps Internal: 0x0
  Link flags     : None
  CoS queues     : 8 supported, 8 maximum usable queues
  Current address: 78:fe:3d:d4:99:45, Hardware address: 78:fe:3d:d4:99:5a
  Last flapped   : 2018-10-04 17:56:25 GMT-3 (00:00:14 ago)
  Input rate     : 0 bps (0 pps)
  Output rate    : 0 bps (0 pps)
  Active alarms  : LINK
  Active defects : LINK
  Interface transmit statistics: Disabled

  Logical interface ge-0/0/23.0 (Index 90) (SNMP ifIndex 606)
    Flags: Device-Down SNMP-Traps 0x0 Encapsulation: ENET2
    Protocol aenet, AE bundle: ae2.0

При этом на микротике никаких сообщений об ошибке нет, состояние интерфейсов поднятое, словно всё норм...

Пробовал разные версии RouterOS - такая проблема с любой, начиная от 6.34.3 и до 6.43.2 .

Подскажите, пожалуйста, в чём может быть причина?
Последний раз редактировалось solegs 05 окт 2018, 13:01, всего редактировалось 1 раз.

Аватара пользователя
Chupaka
Сообщения: 1326
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Не поднимается аггрегированный порт после апгрейда

Сообщение Chupaka » 04 окт 2018, 18:49

Ну, не поднимается явно потому, что "Physical link is Down" и "Interface flags: Hardware-Down". Если LACP разобрать - что-нибудь меняется?

Ещё настораживает "Media type: Copper"...

solegs
Сообщения: 4
Зарегистрирован: 04 окт 2018, 16:33

Re: Не поднимается аггрегированный порт после апгрейда

Сообщение solegs » 04 окт 2018, 18:56

Chupaka писал(а):
04 окт 2018, 18:49
Ну, не поднимается явно потому, что "Physical link is Down" и "Interface flags: Hardware-Down". Если LACP разобрать - что-нибудь меняется?

Ещё настораживает "Media type: Copper"...
Так об этом и речь - он становится "Physical link is Down" только после прошивки на версию новее. Руками-ногами ничего не трогается. После возврата к версии 6.34.2 линк поднимается сам. В том-то и вопрос - почему это происходит и как это победить?

LACP разбирали-собирали, и на микротике, и на джунипере. Не помогло.

А чем настораживает использование меди? SFP для меди есть в природе и успешно используются.

Аватара пользователя
Chupaka
Сообщения: 1326
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Не поднимается аггрегированный порт после апгрейда

Сообщение Chupaka » 04 окт 2018, 18:59

Тогда речь уже о том, что просто линк не поднимается :)

Да, я привык уже к кабелям Direct-Attach, медные SFP вылетели из головы.

Пробовали? https://forum.mikrotik.com/viewtopic.php?t=123091

solegs
Сообщения: 4
Зарегистрирован: 04 окт 2018, 16:33

Re: После апгрейда не поднимается линк с джунипером.

Сообщение solegs » 05 окт 2018, 13:00

Chupaka писал(а):
04 окт 2018, 18:59
Тогда речь уже о том, что просто линк не поднимается :)
...
Пробовали? https://forum.mikrotik.com/viewtopic.php?t=123091
Разобрал всю аггрегацию и на микротике, и на джунипере. Перепробовал поочерёдно все режимы по скорости, дуплексу, mdi (mdi - это только на джунипере). Пофиг. Джунипер не видит, что к двум его портам подключено что-то, ну никак.

Но стоит только откатить прошивку на версию 6.34.2, как всё поднимается...

П.С.
Изменил название темы на более подходящее...

Аватара пользователя
Chupaka
Сообщения: 1326
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: После апгрейда не поднимается линк с джунипером.

Сообщение Chupaka » 05 окт 2018, 13:08

Предлагаю обратиться на [email protected] с supout'ами в рабочем и нерабочем состоянии (вдруг там подскажут чего) - и попробовать проверить, если есть под рукой, работу с оптическими SFP-модулями.

solegs
Сообщения: 4
Зарегистрирован: 04 окт 2018, 16:33

Re: После апгрейда не поднимается линк с джунипером.

Сообщение solegs » 08 окт 2018, 11:52

Выяснилось, что именно в этих двух интерфейсах Микротика sfp2 и sfp3 стоят sfp-трансиверы от Cisco. Видимо, дело в этом. Так как в третьем интерфейсе sfp1 стоит другой медный трансивер - от Микротика, этот интерфейс так же подключён к этому же джуниперу и с ним таких проблем нет вообще.
Бум искать замену...

Аватара пользователя
Chupaka
Сообщения: 1326
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: После апгрейда не поднимается линк с джунипером.

Сообщение Chupaka » 08 окт 2018, 13:11

[email protected] спрашивали? Вдруг чего насоветуют

timonsterrr
Сообщения: 66
Зарегистрирован: 05 мар 2017, 17:33

Re: После апгрейда не поднимается линк с джунипером.

Сообщение timonsterrr » 03 дек 2018, 12:38

Столкнулся с похожей темой. на свитче crs317 после обновления до 6.43.4 не поднимался LACP интерфейс с мегафоном (у них жунипер стоит) При том если разбираешь LACP то свитч уходит в "валгаллу" только перезагрузка по питанию возвращала его в строй. Откатил обратно на 6.42.9 LACP не поднимался. (lacp собран из sfpplus7 и sfpplus10) И пока не дернешь руками сами физические интерфейсы в порядке - сначала 7 и затем 10 lacp не поднимается. Писали в суппорт микрота по данному вопросу они попросили супаут - выслали им супаут и на этом все...ни ответа ни привета...спрашиваю у них что по данному тикету, есть ли решения - просто тупо молчат.

Ответить