Два PPPOE интернета на одну сеть.

RIP, OSFP, BGP, MPLS/VPLS
alex911k
Сообщения: 16
Зарегистрирован: 07 ноя 2017, 09:47

Два PPPOE интернета на одну сеть.

Сообщение alex911k » 28 окт 2018, 11:33

Есть два PPPOE интернета. Надо настроить раздачу интернета так, чтобы одному адрес-листу инет раздавался от одного интернета, а второму адрес-листу от другого интернета. Как лучше всего это реализовать? Оба адрес-листа будут находится в одной сети.

Аватара пользователя
Sir_Prikol
Сообщения: 160
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Два PPPOE интернета на одну сеть.

Сообщение Sir_Prikol » 28 окт 2018, 12:42

Только манглами и маршруты по умолчанию убрать и руками их настроить.
При этом отмаркировать маршруты
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Chupaka
Сообщения: 1339
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Два PPPOE интернета на одну сеть.

Сообщение Chupaka » 28 окт 2018, 13:00

Да, стандартный Policy Routing: создаём два маркированных дефолтных маршрута со шлюзами pppoe-out1 и pppoe-out2, в Mangle Prerouting маркируем пакеты по адрес-листам.

alex911k
Сообщения: 16
Зарегистрирован: 07 ноя 2017, 09:47

Re: Два PPPOE интернета на одну сеть.

Сообщение alex911k » 12 ноя 2018, 10:16

Если я правильно понял то в маршрутах делаем
/ip route
add distance=1 gateway=byfly2 routing-mark=mark_inet2
add distance=1 gateway=byfly1

Маркируем трафик от адресс-листа inet2
/ip firewall mangle
add action=mark-routing chain=prerouting disabled=yes new-routing-mark=mark_inet2 passthrough=no src-address-list=inet2

В правилах ната
/ip firewall nat
add action=masquerade chain=srcnat comment=inet1 ipsec-policy=out,none out-interface=byfly1 src-address-list=!inet2
add action=masquerade chain=srcnat comment=inet2 disabled=yes ipsec-policy=out,none out-interface=byfly2 src-address-list=inet2

Аватара пользователя
Chupaka
Сообщения: 1339
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Два PPPOE интернета на одну сеть.

Сообщение Chupaka » 12 ноя 2018, 11:08

Да, именно так. Только src-address-list в правилах NAT лучше убрать. Оно ничем не помогает, а в дальнейшем может и помешать.

alex911k
Сообщения: 16
Зарегистрирован: 07 ноя 2017, 09:47

Re: Два PPPOE интернета на одну сеть.

Сообщение alex911k » 19 ноя 2018, 13:14

В такой конфигурации интернет работает только через byfly1. На компьютерах из списка inet2 пингуются ресурсы в интернете. Трассировка проходит по нужному маршруту, но странички загружаются через раз или не загружаются вовсе. Подолгу грузятся и открываются не полностью. Подозреваю что дело в MTU, но пока не понял как это побороть.


alex911k
Сообщения: 16
Зарегистрирован: 07 ноя 2017, 09:47

Re: Два PPPOE интернета на одну сеть.

Сообщение alex911k » 19 ноя 2018, 14:03

Добавил вот такое правило. Но это не помогло.
/ip firewall mangle
add out-interface =byfly2 protocol = tcp tcp-flags = syn action = change-mss new-mss = 1300 chain = forward tcp-mss = 1301-65535

Аватара пользователя
Chupaka
Сообщения: 1339
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Два PPPOE интернета на одну сеть.

Сообщение Chupaka » 19 ноя 2018, 15:27

А дело точно не в DNS? Какая ошибка браузером показывается?

А то, может, в правило mangle для маркировки роутинга надо добавить dst-address-type=!local ?

alex911k
Сообщения: 16
Зарегистрирован: 07 ноя 2017, 09:47

Re: Два PPPOE интернета на одну сеть.

Сообщение alex911k » 23 ноя 2018, 13:15

DNS работает. Адреса резолвятся. Сайты когда не открываются ругаются на time-out.

Ответить