Глюки после обновления на 6.43.7

RIP, OSFP, BGP, MPLS/VPLS
Аватара пользователя
Chupaka
Сообщения: 1757
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Глюки после обновления на 6.43.7

Сообщение Chupaka » 10 дек 2018, 14:55

Кажется, понял: в output будет показывать результат из первоначального routing decision, после чего навешивается routing mark на пакет - и происходит routing adjustment, результат которого будет виден уже в postrouting.

https://wiki.mikrotik.com/wiki/Manual:P ... ng_Diagram

Аватара пользователя
Chupaka
Сообщения: 1757
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Глюки после обновления на 6.43.7

Сообщение Chupaka » 10 дек 2018, 14:58

Так, с этими "UPD" не успеваю отвечать, а сообщение уже изменяются :)

Что там с дистансами? Поподробнее. О какой таблице речь? Маркированной или main?

З.Ы. ARP-check на PPPoE и PING, когда указан интерфейс, а не IP, никакой смысловой нагрузки не несут и только глаза мозолят, по идее.

Аватара пользователя
Sir_Prikol
Сообщения: 265
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Глюки после обновления на 6.43.7

Сообщение Sir_Prikol » 10 дек 2018, 15:21

С дистансами (в первом сообщении) такая фигня творится
Сейчас у всех дистанс 1 в таблице майн (чек по пингу)
И дистанс 1,2,3,4 (по разным интерфейсам) в таблице майн (чек по арпу)

всеё на 0.0.0.0/0

Когда пытаюсь принудительно дать в пингах нужную таблицу маршрутизации - всё, полностью падают все интерфейсы
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Sir_Prikol
Сообщения: 265
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Глюки после обновления на 6.43.7

Сообщение Sir_Prikol » 10 дек 2018, 15:29

Могу доступ дать, ибо я уже ниего не понимаю :)
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Sir_Prikol
Сообщения: 265
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Глюки после обновления на 6.43.7

Сообщение Sir_Prikol » 10 дек 2018, 16:19

Разобрал всё, сделал с нуля по минимому, без всяких route rules
Поднял только на 2-х pppoe интерфейсах - в ответ тишина, эффект тот-же, балансировка работает, dst-nat только на одном интерфейсе

Код: Выделить всё


/ip firewall mangle
add action=mark-connection chain=input disabled=no in-interface=00.pppoe-ISP01 new-connection-mark=conn_isp1 passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=00.pppoe-ISP02 new-connection-mark=conn_isp2 passthrough=yes

add action=mark-routing chain=output connection-mark=conn_isp1 disabled=no new-routing-mark=to_isp1 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp2 disabled=no new-routing-mark=to_isp2 passthrough=yes

add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=WiFi+LAN new-connection-mark=conn_isp1 passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=WiFi+LAN new-connection-mark=conn_isp2 passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1

add action=mark-routing chain=prerouting connection-mark=conn_isp1 disabled=no in-interface=WiFi+LAN new-routing-mark=to_isp1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=conn_isp2 disabled=no in-interface=WiFi+LAN new-routing-mark=to_isp2 passthrough=yes

add action=accept chain=prerouting disabled=no in-interface=00.pppoe-ISP01
add action=accept chain=prerouting disabled=no in-interface=00.pppoe-ISP02

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=00.pppoe-ISP01 routing-mark=to_isp1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=00.pppoe-ISP02 routing-mark=to_isp2 scope=30 target-scope=10

add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=00.pppoe-ISP01 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=00.pppoe-ISP02 scope=30 target-scope=10

Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Chupaka
Сообщения: 1757
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Глюки после обновления на 6.43.7

Сообщение Chupaka » 10 дек 2018, 16:46

Телеграм @Chupaka - я бы глянул, когда мимо проходил =)

Аватара пользователя
Sir_Prikol
Сообщения: 265
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Глюки после обновления на 6.43.7

Сообщение Sir_Prikol » 10 дек 2018, 21:29

Так, после 2-х часов возни напрямую на рутере параллельно с г-ном Чупакой проблема была решена следующим образом (как оно до этого работало, совсем уже не понятно):

1. Заменениы соединения с related на new в правилах prerouting
2. Добавлены новые правила с маркировкой no-mark
3. Переименованы маркировки и приведены в более нормальный вид
4. Исключена из маркировок локальная сеть

В результате мангл теперь выглядит так:

Код: Выделить всё

/ip firewall mangle
add action=mark-connection chain=input comment=PCC connection-state=new in-interface=00.pppoe-ISP01 log-prefix=pppoe1 new-connection-mark=conn_isp_01 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=00.pppoe-ISP02 log-prefix=pppoe2 new-connection-mark=conn_isp_02 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=03.ISP_03 new-connection-mark=conn_isp_03 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface="04.ISP_04(SXT)" new-connection-mark=conn_backup passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP01 log-prefix=pppoe1 new-connection-mark=conn_isp_01 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP02 log-prefix=pppoe2 new-connection-mark=conn_isp_02 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=03.ISP_03 new-connection-mark=conn_isp_03 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface="04.ISP_04(SXT)" new-connection-mark=conn_backup passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_01 log-prefix=pppoe1 new-routing-mark=route_isp_01 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_02 log-prefix=pppoe2 new-routing-mark=route_isp_02 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_03 new-routing-mark=route_isp_03 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_backup new-routing-mark=route_backup passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=conn_isp_01 passthrough=yes per-connection-classifier=both-addresses:3/0 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=conn_isp_02 passthrough=yes per-connection-classifier=both-addresses:3/1 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=conn_isp_03 passthrough=yes per-connection-classifier=both-addresses:3/2 src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_01 new-routing-mark=IT39_1 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_02 new-routing-mark=IT39_2 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_03 new-routing-mark=IT39_3 passthrough=yes src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark new-connection-mark=oTher passthrough=yes
Спасибо за потраченное время.
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Chupaka
Сообщения: 1757
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Глюки после обновления на 6.43.7

Сообщение Chupaka » 10 дек 2018, 23:30

Всегда рад помочь =)

Там бы ещё routing-marks (route_isp_/IT39_) привести к единообразию и убрать костыль для них из Routing Rules :) Но это уже так, для свободной минутки

Ответить