Mikrotik+vpn+sip односторонняя связь

RIP, OSFP, BGP, MPLS/VPLS
Аватара пользователя
Chupaka
Сообщения: 1560
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение Chupaka » 18 янв 2019, 10:51

Хотя я писал что все разрешил.
А я вот что-то этого не вижу... У вас разрешён весь icmp (поэтому пинги ходят), а вот в forward разрешено только ходить в pppoe и обратно (как established), а вот между LAN и pptp-9/5 (и, соответственно, vpn-9/5 и LAN_OFFIS на втором роутере) - получается, запрещено?..

gnusik
Сообщения: 11
Зарегистрирован: 15 янв 2019, 16:56

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение gnusik » 18 янв 2019, 11:33

Добавил новые правила все ровно связь в одну сторону.

microtik 10
add chain=forward action=accept in-interface=LAN out-interface=pptp-9/5
add chain=forward action=accept in-interface=pptp-9/5 out-interface=LAN

microtik 12
add chain=forward action=accept in-interface=LAN-OFFIS out-interface=pptp-9/5
add chain=forward action=accept in-interface=pptp-9/5 out-interface=LAN-OFFIS

на 10
add chain=forward action=accept in-interface=pptp-9/5 out-interface=LAN В это правиле не видно, что ходят пакеты.
на 12 пакеты ходят в двух правилах

Аватара пользователя
Chupaka
Сообщения: 1560
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение Chupaka » 18 янв 2019, 13:54

Если не видно, что ходят пакеты - надо смотреть, где эти пакеты теряются или почему не туда летят, куда надо. Policy Routing не используется?

gnusik
Сообщения: 11
Зарегистрирован: 15 янв 2019, 16:56

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение gnusik » 18 янв 2019, 15:12

Policy Routing не используется точно.
Как найти где они потерялись?
Я так понял они не приходят в 10 подсесть.

Аватара пользователя
Chupaka
Сообщения: 1560
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение Chupaka » 18 янв 2019, 15:37

Torch'ем посмотрите, может, прилетают ли пакеты из pptp. А потом уже думать, куда пропадают. Например, /ip firewall filter add chain=forward action=passthrough log=yes src-address=YYY dst-address=XXX - и в логе будет видно, через какой интерфейс пакеты уходят

Аватара пользователя
Sir_Prikol
Сообщения: 214
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение Sir_Prikol » 19 янв 2019, 12:00

Совсем бредовая идея, но иногда у SIP бывает проблема с размером пакета, они не пролезают через pptp. Может ещё в эту сторону покрутить? Повторюсь, такие случаи редки, но по UDP бывает шлёт с превышением.
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

gnusik
Сообщения: 11
Зарегистрирован: 15 янв 2019, 16:56

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение gnusik » 21 янв 2019, 10:09

Вот такая картина наблюдается в логах.
из 10 в 12 подсеть все бегает.
а из 12 в 10 вообще пусто.
Вложения
12.png
12.png (81.29 КБ) 98 просмотров
10.png
10.png (200.44 КБ) 98 просмотров

gnusik
Сообщения: 11
Зарегистрирован: 15 янв 2019, 16:56

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение gnusik » 21 янв 2019, 13:14

Видно что пакеты ходят только в одну сторону и только UDP 5060 проходит туда и обратно.
Правда этого на картинке не видно.

Аватара пользователя
Chupaka
Сообщения: 1560
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Mikrotik+vpn+sip односторонняя связь

Сообщение Chupaka » 22 янв 2019, 00:23

Смотрите то, что я выше написал. Вы говорите, что пакеты на одном роутере есть, а на другом нет — но они же не теряются внутри тоннеля. Что-то на одном из роутеров не то.

Ответить