Страница 1 из 1

Маленькая скорость соединения к SFTP

Добавлено: 05 фев 2019, 13:38
navigan
Общая обстановка:
> CRS109-8G-1S-2HnD
> Парк компьютеров 70 шт. Одна сеть. DHCP.
> Часто используем сторонние сервисы VPN, FTP, SFTP, SSH соединения.

1.Проблема в том, когда работают юзеры по VPN (Windscribe) скорость соединения маленькая.
2.Так же при загрузке или аплоде на сервак через SFTP (FTP) скорость 40-300 кб\сек.
(скорость дома - 2-3 мбит\сек
Грузим Filezilla
Возможно есть ошибки в конфиге?

Код: Выделить всё

> " jan/31/2019 11:21:46 by RouterOS 6.43.8
> # model = CRS109-8G-1S-2HnD
> /interface bridge
> add fast-forward=no mtu=1500 name=LAN
> /interface ethernet
> set [ find default-name=ether2 ] name=LAN1
> set [ find default-name=ether3 ] name=LAN2
> set [ find default-name=ether4 ] name=LAN3
> set [ find default-name=ether5 ] name=LAN4
> set [ find default-name=ether1 ] name=WAN
> /interface pppoe-client
> add ac-name=XXXXXXXXXXXXX add-default-route=yes disabled=no 
> interface=WAN max-mru=1492 max-mtu=1480 mrru=1600 name="pppoe-out1" 
> password=******** use-peer-dns=yes user=**********
> /interface wireless security-profiles
> set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk 
> eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik 
> wpa-pre-shared-key=**************** wpa2-pre-shared-key=\
>     ***************
> add authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys name=WLAN- 
> **********   supplicant-identity=****** 
> wpa-pre-shared-key=******************** wpa2-pre-shared-key=\
>     ************************
> /interface wireless
> set [ find default-name=wlan1 ] band=2ghz-b/g/n 
> channel-width=20/40mhz-Ce disabled=no frequency=2422 
> mode=station-bridge name=WLAN security-profile=WLAN- 
> **********   ssid=******
> add disabled=no mac-address=********** master-interface=WLAN 
> name=wlan1 security-profile=WLAN-**********
> /ip pool
> add name=dhcp_pool0 ranges=192.168.X.X-192.168.X.X
> /ip dhcp-server
> add address-pool=dhcp_pool0 disabled=no interface=LAN lease-time=1d1m 
> name=dhcp1
> /queue simple
> add max-limit=40M/40M name=******** target=192.168.X.X/32 
> time=0s-1d,sun,mon,tue,wed,thu,fri,sat
> /interface bridge port
> add bridge=LAN interface=LAN1
> add bridge=LAN interface=WLAN
> add bridge=LAN disabled=yes interface=WAN
> add bridge=LAN interface=LAN2
> add bridge=LAN interface=LAN3
> add bridge=LAN interface=LAN4
> add bridge=LAN interface=wlan1
> add bridge=LAN interface=ether6
> /ip address
> add address=192.168.X.X/24 interface=LAN network=192.168.X.X
> add address=192.168.X.X/24 disabled=yes interface=WAN network=192.168.X.X
> /ip arp
> add address=192.168.X.X interface=LAN mac-address=***********
> /ip dhcp-server lease
> add address=192.168.X.X client-id=******* mac-address=********** 
> server=dhcp1
> add address=192.168.X.X mac-address= **********   server=dhcp1
> add address=192.168.X.X mac-address= **********   server=dhcp1
> /ip dhcp-server network
> add address=192.168.X.X/24 gateway=192.168.X.X
> /ip dns
> set servers=8.8.8.8,8.8.4.4
> /ip firewall address-list
> add address=X comment="X" list=BlackList
> /ip firewall filter
> add action=drop chain=input connection-state=invalid 
> in-interface="pppoe-out1"
> /ip firewall nat
> add action=masquerade chain=srcnat disabled=yes out-interface=WAN
> add action=masquerade chain=srcnat out-interface="pppoe-out1"
> /ip firewall raw
> add action=drop chain=prerouting src-address-list=BlackList
> /ip service
> set telnet disabled=yes
> set ftp disabled=yes
> set ssh disabled=yes
> /ipv6 firewall filter
> add action=accept chain=input disabled=yes in-interface=sfp1
> /lcd
> set default-screen=informative-slideshow "

Re: Маленькая скорость соединения к SFTP

Добавлено: 06 фев 2019, 17:15
Chupaka
А если добавить правило для MSS, что-нибудь меняется?

Код: Выделить всё

/ip firewall mangle 
add out-interface=pppoe-out1 protocol=tcp tcp-flags=syn action=change-mss new-mss=1300 chain=forward tcp-mss=1301-65535
https://wiki.mikrotik.com/wiki/Manual:I ... Change_MSS

Re: Маленькая скорость соединения к SFTP

Добавлено: 06 фев 2019, 18:38
navigan
Chupaka писал(а):
06 фев 2019, 17:15
А если добавить правило для MSS, что-нибудь меняется?

Код: Выделить всё

/ip firewall mangle 
add out-interface=pppoe-out1 protocol=tcp tcp-flags=syn action=change-mss new-mss=1300 chain=forward tcp-mss=1301-65535
https://wiki.mikrotik.com/wiki/Manual:I ... Change_MSS
Спасибо за совет, сегодня попробую. Отпишусь

Re: Маленькая скорость соединения к SFTP

Добавлено: 07 фев 2019, 10:38
navigan
navigan писал(а):
06 фев 2019, 18:38
Chupaka писал(а):
06 фев 2019, 17:15
А если добавить правило для MSS, что-нибудь меняется?

Код: Выделить всё

/ip firewall mangle 
add out-interface=pppoe-out1 protocol=tcp tcp-flags=syn action=change-mss new-mss=1300 chain=forward tcp-mss=1301-65535
https://wiki.mikrotik.com/wiki/Manual:I ... Change_MSS
Спасибо за совет, сегодня попробую. Отпишусь
Скорость возросла, но не стабильна. Раз через раз выдаёт то 500Kb\sec то 1,2Mbit. Наблюдаем в течении дня, так как сервер в америке. Попробую установить закономерность или какую-то логику в таких скачках.

Re: Маленькая скорость соединения к SFTP

Добавлено: 07 фев 2019, 11:14
Chupaka
А speedtest.net что в тот же момент показывает? И на близкие, и на американские серверы.

Re: Маленькая скорость соединения к SFTP

Добавлено: 07 фев 2019, 15:34
navigan
Chupaka писал(а):
07 фев 2019, 11:14
А speedtest.net что в тот же момент показывает? И на близкие, и на американские серверы.
Без VPN всё шикарно и стабильно. Закрались подозрения, что дело в провайдере Velcom. Тут оборуование ещё АтлантТелекома стоит старое. С недавних пор хозяйство Велкома. На следующей неделе затянем МТС 250мбит. Посмотрим что изменится. Дома проверял соединение - та же история. К слову сказать - дома тоже Велком (бывш. Атлант). ПРоверим альтернативного провайдера. Если проблема будет решена - значит нюансы очевидны.

Re: Маленькая скорость соединения к SFTP

Добавлено: 13 фев 2019, 09:45
freac
У меня очень похожая ситуация, после внесения правила в Манглу немного улучшилась, но все равно не достаточно сильно.
Подозреваю (именно в моем случае) проблема в параметрах MTU но не могу подобрать необходимое значение.
Провайдер деловая сеть.

Re: Маленькая скорость соединения к SFTP

Добавлено: 15 фев 2019, 11:13
navigan
freac писал(а):
13 фев 2019, 09:45
У меня очень похожая ситуация, после внесения правила в Манглу немного улучшилась, но все равно не достаточно сильно.
Подозреваю (именно в моем случае) проблема в параметрах MTU но не могу подобрать необходимое значение.
Провайдер деловая сеть.
О, да. Это целая беда. Мы ещё ждём второго провайдера. Будем сравнивать "жэстачайшэ". Но вроде пока терпимо, хотя понятно, что это не норма. :cry: :cry: :cry:

Re: Маленькая скорость соединения к SFTP

Добавлено: 15 фев 2019, 11:20
freac
navigan писал(а):
15 фев 2019, 11:13
freac писал(а):
13 фев 2019, 09:45
У меня очень похожая ситуация, после внесения правила в Манглу немного улучшилась, но все равно не достаточно сильно.
Подозреваю (именно в моем случае) проблема в параметрах MTU но не могу подобрать необходимое значение.
Провайдер деловая сеть.
О, да. Это целая беда. Мы ещё ждём второго провайдера. Будем сравнивать "жэстачайшэ". Но вроде пока терпимо, хотя понятно, что это не норма. :cry: :cry: :cry:
У меня исправилась ситуация но проблема была не в провайдере у нас, а на стороне провайдера заграницей.
К сожалению моя квалификация и уровень знаний не дает определить что именно исправил у себя провайдер и у меня появилось стабильное и быстрое соединение :( .

Re: Маленькая скорость соединения к SFTP

Добавлено: 15 фев 2019, 11:23
navigan
freac писал(а):
15 фев 2019, 11:20
navigan писал(а):
15 фев 2019, 11:13
freac писал(а):
13 фев 2019, 09:45
У меня очень похожая ситуация, после внесения правила в Манглу немного улучшилась, но все равно не достаточно сильно.
Подозреваю (именно в моем случае) проблема в параметрах MTU но не могу подобрать необходимое значение.
Провайдер деловая сеть.
О, да. Это целая беда. Мы ещё ждём второго провайдера. Будем сравнивать "жэстачайшэ". Но вроде пока терпимо, хотя понятно, что это не норма. :cry: :cry: :cry:
У меня исправилась ситуация но проблема была не в провайдере у нас, а на стороне провайдера заграницей.
К сожалению моя квалификация и уровень знаний не дает определить что именно исправил у себя провайдер и у меня появилось стабильное и быстрое соединение :( .
Сервера меняли. Вроде результата не было. Пока грешу на провайдера) появится альтернативный источник интернета - ситуация должна проясниться. Обязательно отпишу. :geek: