Bonding (странное поведение)

RIP, OSFP, BGP, MPLS/VPLS
Ответить
Аватара пользователя
Sir_Prikol
Сообщения: 269
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Bonding (странное поведение)

Сообщение Sir_Prikol » 06 мар 2019, 00:31

Доброй ночи!
Имеем следующую конфу:

CRS326-24G-2S+ и RB3011
Сейчас они соединены посредством оптики - работает шикарно
Решил проэкспериментировать
Сделал объединение портов (4 интерфейса CRS и 4 интерфейса RB3011) и получил странный глюк
Слетела маршрутизация в сторону свитча, все устройства за свитчом и сам свитч - стали не доступны из локальной сети.
Что сделано, оба bonding интерфейса находятся в бриджах, каждый на своей железке
Крутил в разные стороны параметры proxy-arp, arp...
Менял MTU и L2 MTU - результат нулевой
Потушил bonding - сразу опять всё взлетело, при этом по мак адресам я спокойно попадал на все устройства за свитчом

Как вишенка на торте, когда я пытался объединить в bonding ethernet и sfp - то оно вообще не поднималось, была потеря по пингам (порядка 60%) но маршрутизация при этом работала.

В какую сторону копать? :)
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Chupaka
Сообщения: 1800
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Bonding (странное поведение)

Сообщение Chupaka » 06 мар 2019, 11:49

Как слетела маршрутизация, если там бридж? 🙈

В каком режиме бондинг? Есть ли VLAN'ы? Трафик по интерфейсу нулевой? А то, может, вы там петлю устроили :)

Аватара пользователя
Sir_Prikol
Сообщения: 269
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Bonding (странное поведение)

Сообщение Sir_Prikol » 06 мар 2019, 16:13

:)

Bonding - round robin, петли нет, ни в логах, ни где, маршрутизаторы друг друга видят все, проблема только в том, что пропадает доступ из локалки до свитча

То есть, часть домашних устройств работают до свитча, через один порт рутера (до этого работали через 5 и свитч), а остальные через свитч, при этом, и сйчас такая-же конфа, 5ггц вайфай воткнут в 6-ой порт, 11 порт (sfp) соединён с CRS326 - проблем нет, как только делаю выход через bonding интерфейс - всё, доступ только с маршрутизатора, из локалки - шиш

Я вот думаю, а может где-то используется правило листов интерфейса, что-то я только об этом подумал, во время написания данного текста
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Sir_Prikol
Сообщения: 269
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Bonding (странное поведение)

Сообщение Sir_Prikol » 06 мар 2019, 16:17

UPD - точно, я так и думал, у меня в правилах фаера используются листы, добавил данный интерфейс (хотя не понимаю зачем, оно-же в бридже), ночью проверю.
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Аватара пользователя
Sir_Prikol
Сообщения: 269
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР
Контактная информация:

Re: Bonding (странное поведение)

Сообщение Sir_Prikol » 07 мар 2019, 01:10

В общем перекрутил все возможные вариант, дошёл до абсурда - начал всего с 2-х интерфейсоф
Так вот, RB+RB - работает идеально, RB + Switch - не работает, я так и не понял почему, уже долез до презентации MUM - но и там тишина.
Дома:
Uplink - RB3011UiAS (2-ISP(ethernet)белый IP),RB SXT LTE 3-7 (резерв yota (белый IP),Wireless Wire Dish (RBLHGG-60adkit) Uplink белый IP.
2 x RB2011UiAS-2HnD, 2 x RBmAP2nD, 1 x RBwAPG-5HacT2HnD
Хочу uplink - RB1100AHx4 или CCR1036-12G-4S

Ответить