Перенаправление подключений

RIP, OSFP, BGP, MPLS/VPLS
AlAbrus
Сообщения: 2
Зарегистрирован: 14 июн 2019, 11:23

Перенаправление подключений

Сообщение AlAbrus »

Доброе время суток, ;)
имеется три web сервера в глобальной сети
1.1.2.1
1.1.3.1
1.1.4.1

Miktotik внешний Ip 1.1.10.1
внутренний 10.0.0.1

необходимо чтоб из внутренней сети 10.0.0/24 подключения
к 10.0.0.1:80 перенаправлялись на 1.1.2.1:80,
к 10.0.0.1:88 перенаправлялись на 1.1.3.1:80,
к 10.0.0.1:8080 перенаправлялись на 1.1.4.1:80

DNS не предлагать
как реализовать данную "хотелку"? :ugeek:
спасибо

Аватара пользователя
Chupaka
Сообщения: 2584
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Хочется странного

Сообщение Chupaka »

Доброго. Это реализуется обычным dst-nat'ом:

Код: Выделить всё

/ip firewall nat
add chain=dstnat dst-address=10.0.0.1 protocol=tcp dst-port=80 action=dst-nat to-addresses=1.1.2.1 to-ports=80
add chain=dstnat dst-address=10.0.0.1 protocol=tcp dst-port=88 action=dst-nat to-addresses=1.1.3.1 to-ports=80
add chain=dstnat dst-address=10.0.0.1 protocol=tcp dst-port=8080 action=dst-nat to-addresses=1.1.4.1 to-ports=80

Аватара пользователя
Chupaka
Сообщения: 2584
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Перенаправление подключений

Сообщение Chupaka »

На всякий случай переименовал топик, а то "Хочется странного" - не всегда понятно :)

AlAbrus
Сообщения: 2
Зарегистрирован: 14 июн 2019, 11:23

Re: Перенаправление подключений

Сообщение AlAbrus »

Спасибо! за оперативный ответ.
В моем варианте намудрил с портами.
проверил на стенде - заработало. 8-)

aspok
Сообщения: 4
Зарегистрирован: 02 мар 2020, 22:48

Re: Перенаправление подключений

Сообщение aspok »

Добрый день, а если наоборот.

Есть отдельный сервер с базой данных Postgresql со своим статическим IP 2.2.2.2., работает на 5432 порту.
Есть Mikrotik с внешним IP 1.1.1.1. и внутренней сетью 192.168.0.0/24. Клиенты из локальной сети коннектятся к внешнему 2.2.2.2.
Для теста на компьютере в локальной сети с IP 192.168.0.132. поднята копия Postgresql сервера со стандартным портом 5432.
Вопрос: можно ли перенаправить все запросы по 5432 порты на 2.2.2.2. на внутренний IP 192.168.0.132.?

Пробовал так, запросы как шли, так и идут на 2.2.2.2.

/ip firewall nat

add action=dst-nat chain=dstnat dst-address=2.2.2.2 dst-port=5432 protocol=tcp to-addresses=192.168.0.132

add action=masquerade chain=srcnat dst-address=192.168.0.132 dst-port=5432 protocol=tcp src-address=192.168.0.0/24

Аватара пользователя
Chupaka
Сообщения: 2584
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Перенаправление подключений

Сообщение Chupaka »

Добрый. Именно так, как вы написали, и надо делать. Правила пакетики отсчитывают? Другие правила не могут мешать?

aspok
Сообщения: 4
Зарегистрирован: 02 мар 2020, 22:48

Re: Перенаправление подключений

Сообщение aspok »

По нулям.
Сверху стоит ещё одно правило маскарадинга:
/ip firewall nat add chain=srcnat action=masquerade out-interface=ether1
Это не может быть проблемой?

aspok
Сообщения: 4
Зарегистрирован: 02 мар 2020, 22:48

Re: Перенаправление подключений

Сообщение aspok »

forward забыл открыть, по умолчанию блочится всё.

Аватара пользователя
Chupaka
Сообщения: 2584
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Перенаправление подключений

Сообщение Chupaka »

Хм... DST-NAT работает до forward. Если он пакеты не ловит - значит, роутер их почему-то не видит. Надо разбираться, почему. Например, банальная опечатка в адресе...

aspok
Сообщения: 4
Зарегистрирован: 02 мар 2020, 22:48

Re: Перенаправление подключений

Сообщение aspok »

Спасибо! Разобрался.