MikroTikk BGP Auto fail-over.

RIP, OSFP, BGP, MPLS/VPLS
Ответить
laxmi
Сообщения: 4
Зарегистрирован: 04 июл 2019, 15:35

MikroTikk BGP Auto fail-over.

Сообщение laxmi » 05 июл 2019, 13:52

Good day..!!

2 ILL link and 1 IX LINk is configured in the BGP .from IX i am receiving 50k routes and from 2 ILL upstream i am receiving default route only .

according to me ,I want to manage the outbound traffic through the PBR but when i am configuring the PBR its working but in that case the outbound traffic is not going through the IX link which prefixes are already present in the routing table .But to avoid this problem i am using IP routing rules but in that case the traffic is going through the IX link but the traffic is not going through the iLL link which i have configured in PBR ,instead its going over another ILL link which is not configured in PBR.

Аватара пользователя
Chupaka
Сообщения: 2152
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: MikroTikk BGP Auto fail-over.

Сообщение Chupaka » 05 июл 2019, 17:47

What I do in that case:

+ in Routing FIlters, mark IX BGP routes with routing-mark=IX;
+ use Route Rules to lookup IX routes first; for example, if your routing marks for ILL are ISP1 and ISP2, do something like this:

Код: Выделить всё

/ip route rule
add routing-mark=ISP1 action=lookup table=IX
add routing-mark=ISP2 action=lookup table=IX

Ответить