iBGP проблема с коннектом

RIP, OSFP, BGP, MPLS/VPLS
timonsterrr
Сообщения: 49
Зарегистрирован: 05 мар 2017, 17:33

iBGP проблема с коннектом

Сообщение timonsterrr » 20 сен 2017, 09:15

Всех привествую. Решил настроить ibgp в сети. И столкнулся с пробелемой, что коннект не переходит в состояние estableshed
Дано:
R1 - это основной бордер. У него есть 2 сесии eBGP и я добавил на нем инстанс для ibg (AS 65530) IP в траснп сети: 10.120.254.1 looback 10.255.0.1
R2 - это ibg роутер. он должен установить сессию с R1 на нем дефолт инстанс с AS65530 IP в траснп сети 10.120.254.4 loopback 10.255.0.252
R3 - это ibg роутер. он должен установить сессию с R1 на нем дефолт инстанс с AS65530 IP в траснп сети 10.120.254.2 loopback 10.255.0.253
Между ними есть транспортная сеть (10.120.254.0/24 ) (Такая сеть была выбрана из-за проблемы с зеркалированием на сорм на аггрегирующем свитче)

сейчас пытаюсь установить сессию между R1 и R2 вот конфиги:
R2:

Код: Выделить всё

routing bgp instance print 
Flags: * - default, X - disabled 
 0 *  name="default" as=65530 router-id=10.255.0.252 redistribute-connected=no 
      redistribute-static=no redistribute-rip=no redistribute-ospf=no 
      redistribute-other-bgp=no out-filter="" client-to-client-reflection=yes 
      ignore-as-path-len=no routing-table="" 
      
routing bgp peer print detail 
Flags: X - disabled, E - established 
 0   name="BGP-R1" instance=default remote-address=10.120.254.1 remote-as=65530 
     tcp-md5-key="" nexthop-choice=default multihop=no route-reflect=no 
     hold-time=3m ttl=default in-filter=bgp-in-r1 out-filter=bgp-out-r1 
     address-families=ip update-source=loopback0 default-originate=never 
     remove-private-as=no as-override=no passive=no use-bfd=no 



конфиг БГП R1:

Код: Выделить всё

routing bgp instance print 
Flags: * - default, X - disabled 
 0 *  name="default" as=65530 router-id=10.255.0.252 redistribute-connected=no 
      redistribute-static=no redistribute-rip=no redistribute-ospf=no 
      redistribute-other-bgp=no out-filter="" client-to-client-reflection=yes 
      ignore-as-path-len=no routing-table="" 

routing bgp instance print 
Flags: * - default, X - disabled 
 0 *  name="default" as=65530 router-id=10.255.0.252 redistribute-connected=no 
      redistribute-static=no redistribute-rip=no redistribute-ospf=no 
      redistribute-other-bgp=no out-filter="" client-to-client-reflection=yes 
      ignore-as-path-len=no routing-table="" 

peer:
      name="Internal-peer-R2" instance=bgp-internal remote-address=10.120.254.4 
     remote-as=65530 tcp-md5-key="" nexthop-choice=default multihop=no 
     route-reflect=no hold-time=3m ttl=default in-filter=bgp-internal-in 
     out-filter=bgp-internal-out address-families=ip update-source=loopback0 
     default-originate=never remove-private-as=no as-override=no passive=no 
     use-bfd=no 

      
Сессия не устанавливается. В логах с обеих сторон сообщения что connection terminated
Есть мысли что не так в моем конфиге?

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: iBGP проблема с коннектом

Сообщение Chupaka » 20 сен 2017, 10:02

Только connection termonated - и больше никаких сообщений?
Можно посмотреть с детальным логом:
/system logging add topics=bgp action=memory

Также проверить, что фильтр файрвола ничего не запрещает (bgp работает по протоколу tcp, порт 179)

UPD: так у вас у обоих роутеров одинаковый router-id - видимо, из-за этого и конфликт

timonsterrr
Сообщения: 49
Зарегистрирован: 05 мар 2017, 17:33

Re: iBGP проблема с коннектом

Сообщение timonsterrr » 20 сен 2017, 10:51

Решил вопрос отключением опции - update source на none


Но теперь другая беда с роутером. На нем в данный момент нет ни одного правила файрвол и он не отвечает на пинги и другие ип запросы (настраиваю его с ноля)

При том транспортный интерфейс подключенный к коммутатору тоже не пингуется (между коммутатором и роутером поднят оспф) с самого коммутатора роутер пигуется. А с компа подключенного к коммутатору - нет. Маршрут к лупбэк и транспортному адресу присутствует. (ccr1036 модель роутера)

timonsterrr
Сообщения: 49
Зарегистрирован: 05 мар 2017, 17:33

Re: iBGP проблема с коннектом

Сообщение timonsterrr » 20 сен 2017, 11:37

Все, разобрался....Что то я пока настраивал все...запарил с обратными маршрутами)

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: iBGP проблема с коннектом

Сообщение Chupaka » 20 сен 2017, 11:50

timonsterrr писал(а):
20 сен 2017, 10:51
Решил вопрос отключением опции - update source на none
Не высмотрел эту опцию %) /routing bgp export её бы лучше указал
Если update-source ставите в loopback, то и настраивать надо сессию между loopback-адресами, а не адресами транспортной сети

timonsterrr
Сообщения: 49
Зарегистрирован: 05 мар 2017, 17:33

Re: iBGP проблема с коннектом

Сообщение timonsterrr » 20 сен 2017, 11:58

Chupaka писал(а):
20 сен 2017, 11:50
timonsterrr писал(а):
20 сен 2017, 10:51
Решил вопрос отключением опции - update source на none
Не высмотрел эту опцию %) /routing bgp export её бы лучше указал
Если update-source ставите в loopback, то и настраивать надо сессию между loopback-адресами, а не адресами транспортной сети
Понял вас. Попробую так сделать. Спасибо

timonsterrr
Сообщения: 49
Зарегистрирован: 05 мар 2017, 17:33

Re: iBGP проблема с коннектом

Сообщение timonsterrr » 21 сен 2017, 06:01

Что то не могу я победить эту схему... В общем сессия установилась, все нормально. А вот инет как то странно работает. Пинги все есть, а сайты открываются через раз...либо открываются кусками, либо очень медленно либо вообще не открываются

timonsterrr
Сообщения: 49
Зарегистрирован: 05 мар 2017, 17:33

Re: iBGP проблема с коннектом

Сообщение timonsterrr » 21 сен 2017, 06:07

Пытаюсь сделать как описано здесь https://mum.mikrotik.com//presentations/US13/kevin.pdf (но, это просто презентация и всего конфига там нет.)

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: iBGP проблема с коннектом

Сообщение Chupaka » 21 сен 2017, 08:49

Пинги большими пакетами (1500 байт?) нормально ходят? Вообще не открываются - с какой ошибкой?

timonsterrr
Сообщения: 49
Зарегистрирован: 05 мар 2017, 17:33

Re: iBGP проблема с коннектом

Сообщение timonsterrr » 21 сен 2017, 10:57

Chupaka писал(а):
21 сен 2017, 08:49
Пинги большими пакетами (1500 байт?) нормально ходят? Вообще не открываются - с какой ошибкой?
Сейчас пока что воспроизвести не могу, помню точного номера ошибки. Роутер пока отключил. Пинги с мту 1500 ходят нормально и до БГП хоста и ниже в трафик сети (с роутера R3)

Просто у меня схема сети в данный момент следующего вида:
Изображение (https://cloud.mail.ru/public/4QD4/8kNrZ8jso)

не могу понять как избавиться от дефолт маршрута на свитче аггрегации к роутерам...ибо весь исходящий трафик идет через один роутер, а возвращается через другой

Хотя по сути, если мы между CE и PE поднимем BGP по лупбэк интерфесам то на CE дефолт маршрут можно указать на лупбэк роутера с кем бгп, а обратные маршруты PE получат по бгп. и не важен будет роут свитча

Ответить