Два провайдера маркировка

RIP, OSFP, BGP, MPLS/VPLS
bassz
Сообщения: 9
Зарегистрирован: 23 ноя 2018, 20:04

Два провайдера маркировка

Сообщение bassz »

Есть два провайдера с белыми Ip приходят в один Mikrotik
маркировка сделана и вроде все работает как задумано
/ip route
add distance=1 gateway=1xx.xx.xx.1 routing-mark=ISP1-route
add distance=2 gateway=8x.xx.xx.xx7 routing-mark=ISP2-route
add distance=1 gateway=1xx.xx.xx.1
add distance=3 gateway=ISP2-bel


/ip firewall mangle
add action=mark-connection chain=input comment=MTS in-interface=ISP1-mts new-connection-mark=ISP1-conn passthrough=yes
add action=mark-routing chain=output comment=MTS connection-mark=ISP1-conn new-routing-mark=ISP1-route passthrough=no
add action=mark-connection chain=input comment=BEL in-interface=ISP2-bel new-connection-mark=ISP2-conn passthrough=yes
add action=mark-routing chain=output comment=BEL connection-mark=ISP2-conn new-routing-mark=ISP2-route passthrough=no
add action=mark-connection chain=forward comment=MTS in-interface=ISP1-mts new-connection-mark=ISP1-conn-f passthrough=no
add action=mark-routing chain=prerouting comment=MTS dst-address-list=!VPN new-routing-mark=ISP1-route passthrough=yes src-address-list=internet_MTS
add action=mark-connection chain=forward comment=BEL in-interface=ISP2-bel new-connection-mark=ISP2-conn-f passthrough=no
add action=mark-routing chain=prerouting comment=BEL dst-address-list=!VPN new-routing-mark=ISP2-route passthrough=yes src-address-list=internet_BEL
не получается подключится к из удаленной площадки сразу двумя L2tp на разных провайдеров на центральный Mikrotik
два vpn не хотят одновременно работать
на один внешний IP два vpn подключается и по отдельности работают как нужно
тоесть один l2tp подключился а второй висит в состоянии connecting
чтото с mangle наверно намутил
Аватара пользователя
Chupaka
Сообщения: 2951
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Два провайдера маркировка

Сообщение Chupaka »

У вас простой l2tp или l2tp over ipsec? И какая версия RouterOS?
bassz
Сообщения: 9
Зарегистрирован: 23 ноя 2018, 20:04

Re: Два провайдера маркировка

Сообщение bassz »

и так и так пробовал

тут основная задача настроить отказоустойчивую связь
вот думаю может на двух mikrotik настроить только как разрулить ?

Еще настраивал по https://wiki.mikrotik.com/wiki/Manual:PCC
пока не смог добиться что-бы хоть запинговались удаленная площадка через vpn
Аватара пользователя
Chupaka
Сообщения: 2951
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Два провайдера маркировка

Сообщение Chupaka »

Запинговалась при попытке поднять одновременно два VPN? В какой момент пинг пропадает? И почему вы отвечаете только на нечётные вопросы?
bassz
Сообщения: 9
Зарегистрирован: 23 ноя 2018, 20:04

Re: Два провайдера маркировка

Сообщение bassz »

Вроде на все отвечаю
простой l2tp двумя тунелями подключается
второй клиент двумя l2tp over ipsec нет, подключается только 1 канал
хотя сейчас вот проверил и простой l2tp только одним каналом подключается или первым или вторым
выключаешь первый подключается вторым, выключаешь второй подключается первым
после перезагрузки клиентского роутера подключается двумя l2tp over ipsec
Аватара пользователя
Chupaka
Сообщения: 2951
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Два провайдера маркировка

Сообщение Chupaka »

Chupaka писал(а): 12 окт 2020, 15:44 какая версия RouterOS?
Я вот на этот ответа не нашёл.

Т.е. клиентский роутер не может подключиться сразу двумя, перезагружаешь его - и уже нормально подключается?..
bassz
Сообщения: 9
Зарегистрирован: 23 ноя 2018, 20:04

Re: Два провайдера маркировка

Сообщение bassz »

6.47 На клиенте и на сервере
Т.е. клиентский роутер не может подключиться сразу двумя, перезагружаешь его - и уже нормально подключается?..
да сейчас перезагрузил двумя каналами подключился

делаешm disable соединениям на клиенте
по порядку включаешь, и подключается только один канал

на сервере видно активный peer от рабочего канала и появляется и пропадает тот который не может создать канал

хотя еще раз перезагрузил и только один канал подключился и больше перезагрузки не помогают
Последний раз редактировалось bassz 20 окт 2020, 15:25, всего редактировалось 1 раз.
Аватара пользователя
Chupaka
Сообщения: 2951
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Два провайдера маркировка

Сообщение Chupaka »

What's new in 6.47.2 (2020-Aug-13 06:39):

*) l2tp - fixed multiple tunnel establishment from the same remote IP address (introduced in v6.47);
Предлагаю обновиться.
bassz
Сообщения: 9
Зарегистрирован: 23 ноя 2018, 20:04

Re: Два провайдера маркировка

Сообщение bassz »

Спасибо вроде помогло
понаблюдаю