Два провайдера с ECMP балансировкой. Настройка Cloud DDNS

RIP, OSFP, BGP, MPLS/VPLS
Diana
Сообщения: 9
Зарегистрирован: 20 ноя 2020, 18:41

Два провайдера с ECMP балансировкой. Настройка Cloud DDNS

Сообщение Diana »

Всем привет.
Прошу помощи у гуру, поскольку я только начинаю познавать этот прекрасный, по моему мнению, роутер.
Есть в наличии два провайдера с своими роутерами (доступ к которым закрыт , по требованию настроили DMZ и всё).
Оба провайдера с белыми IP:
1-й динамический.
2-й статический.
В микротик получается:
wan1 - 192.168.1.2
wan2 - 192.168.2.2
Настроила ECMP балансировку по этой инструкции https://wifisystem.ru/docs/2isp/.
Все работает отлично.
Поскольку айпи одного из провайдеров динамический, есть необходимость активации Cloud DDNS. Не важно через какого провайдера пройдет подключение при работе обоих каналов, важно чтоб при падении одного, можно было зайти по DDNS через второй.
В моменте DDNS работает не понятно как, при отключении второго интерфейса (провайдера) - подключается, в остальных возможных вариантах событий, нет.
Подскажите где я ошиблась, что сделала не так, или чего не доделала? (желательно в примерах поскольку я новенькая в данном русле)
Прилагаю настройки своего роутера:

Код: Выделить всё

# apr/19/2021 13:45:08 by RouterOS 6.48.2
# software id = F0BU-XW92
#
# model = 2011UiAS-2HnD
# serial number = 614A056xxxxx
/interface bridge
add name=Lan
/interface ethernet
set [ find default-name=ether1 ] comment=Orange
set [ find default-name=ether2 ] comment=Starnet
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
    country=mxxxxxxx disabled=no frequency=auto frequency-mode=superchannel \
    mode=ap-bridge ssid=<<Orage+Starnet>> wireless-protocol=802.11 wps-mode=\
    disabled
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=\
    xxxxx wpa2-pre-shared-key=xxxxx
add authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys name=profile \
    supplicant-identity=MikroTik wpa-pre-shared-key=xxxxx \
    wpa2-pre-shared-key=xxxxx
/interface wireless
add disabled=no mac-address=E6:8D:8C:1E:C4:8C master-interface=wlan1 name=\
    wlan2 security-profile=profile ssid=<<Shara>> wps-mode=disabled
/ip pool
add name=dhcp ranges=0.0.0.1-0.0.0.254
add name=dhcp_pool1 ranges=192.168.0.2-192.168.0.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=Lan name=dhcp1
/interface bridge filter
add action=drop chain=forward in-interface=wlan2
add action=drop chain=forward out-interface=wlan2
/interface bridge port
add bridge=Lan interface=ether3
add bridge=Lan interface=ether4
add bridge=Lan interface=ether5
add bridge=Lan interface=ether6
add bridge=Lan interface=ether7
add bridge=Lan interface=ether8
add bridge=Lan interface=ether9
add bridge=Lan interface=ether10
add bridge=Lan interface=wlan1
add bridge=Lan interface=wlan2
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface detect-internet
set detect-interface-list=WAN lan-interface-list=LAN wan-interface-list=WAN
/interface list member
add interface=ether1 list=WAN
add interface=Lan list=LAN
add interface=ether2 list=WAN
/ip address
add address=192.168.1.2/24 interface=ether1 network=192.168.1.0
add address=192.168.0.1/24 interface=Lan network=192.168.0.0
add address=192.168.2.2/24 interface=ether2 network=192.168.2.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=1m
/ip dhcp-client
add interface=ether1
/ip dhcp-server lease
add address=192.168.0.150 mac-address=00:22:19:24:0C:63 server=dhcp1 \
    use-src-mac=yes
/ip dhcp-server network
add address=0.0.0.0/24 gateway=0.0.0.0 netmask=24
add address=192.168.0.0/24 gateway=192.168.0.1
/ip dns
set allow-remote-requests=yes servers="192.168.1.1,192.168.2.1,192.168.0.1,195\
    .22.225.2,217.12.120.2,89.28.1.1,87.248.160.5,8.8.8.8,8.8.4.4"
/ip dns static
add address=192.168.0.199 comment=esxig5 name=hpg7.roon
add address=192.168.0.197 name=vcsa.roon
add address=192.168.0.200 name=hpg6.roon
add address=192.168.0.195 name=Shefu.roon.com
add address=192.168.0.150 name=MediaServer.roon
/ip firewall filter
add action=accept chain=input protocol=icmp
add action=accept chain=input connection-state=established
add action=accept chain=input connection-state=related
add action=drop chain=input in-interface-list=!LAN
/ip firewall mangle
add action=mark-connection chain=input in-interface=ether1 \
    new-connection-mark=cin_ether1
add action=mark-connection chain=input in-interface=ether2 \
    new-connection-mark=cin_ether2
add action=mark-routing chain=output connection-mark=cin_ether1 \
    new-routing-mark=rout_ether1 passthrough=no
add action=mark-routing chain=output connection-mark=cin_ether2 \
    new-routing-mark=rout_ether2 passthrough=no
add action=mark-routing chain=prerouting new-routing-mark=mixed src-address=\
    192.168.0.0/24
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=WAN
add action=masquerade chain=srcnat src-address=192.168.0.0/24
add action=netmap chain=dstnat comment=HPG6 dst-port=3400 in-interface-list=\
    WAN protocol=tcp to-addresses=192.168.0.200 to-ports=3400
add action=netmap chain=dstnat comment="Vector 0 Eu Perfect" dst-port=3313 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.13 to-ports=\
    3389
add action=netmap chain=dstnat comment="HP G5" dst-port=3325 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.25 to-ports=\
    3325
add action=netmap chain=dstnat comment="Vector_6 " dst-port=3328 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.28 to-ports=\
    3328
add action=netmap chain=dstnat comment="Indicator_1,    Vector 1 " dst-port=\
    3330 in-interface-list=WAN protocol=tcp to-addresses=192.168.0.30 \
    to-ports=3330
add action=netmap chain=dstnat comment="Clon Mare" dst-port=3311 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.221 to-ports=\
    3311
add action=netmap chain=dstnat comment=Servacioc dst-port=3310 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.100 to-ports=\
    3310
add action=netmap chain=dstnat comment="Server G7" dst-port=3499 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.199 to-ports=\
    3499
add action=netmap chain=dstnat comment="Server G6     Ilo2 Admin" dst-port=\
    3401 in-interface-list=WAN protocol=tcp to-addresses=192.168.0.201 \
    to-ports=8080
add action=netmap chain=dstnat comment="Market2,  Vector_3,   Bot 3" \
    dst-port=3402 in-interface-list=WAN protocol=tcp to-addresses=\
    192.168.0.202 to-ports=3402
add action=netmap chain=dstnat comment=\
    "Dorvei 1, Vector_4                         " dst-port=3403 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.203 to-ports=\
    3403
add action=netmap chain=dstnat comment="Dorvey 2, Vector_5 " dst-port=3404 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.204 to-ports=\
    3404
add action=netmap chain=dstnat comment="Mic, orange Denver" dst-port=3433 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.233 to-ports=\
    3433
add action=netmap chain=dstnat comment="Win10  Mare" dst-port=3410 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.10 to-ports=\
    3389
add action=netmap chain=dstnat comment=\
    "AMPGlobalClearing, Aligator Shadou Defender)) Admin 2018Aligator1976" \
    dst-port=3454 in-interface-list=WAN protocol=tcp to-addresses=\
    192.168.0.234 to-ports=3454
add action=netmap chain=dstnat comment="ILo2    Admin ----" dst-port=3434 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.251 to-ports=\
    8080
add action=netmap chain=dstnat comment=Registrator dst-port=3600 \
    in-interface-list=WAN log=yes protocol=tcp to-addresses=192.168.0.12 \
    to-ports=3600
add action=netmap chain=dstnat comment=DNS dst-port=3405 in-interface-list=\
    WAN protocol=tcp to-addresses=192.168.0.205 to-ports=3405
add action=netmap chain=dstnat comment=Media dst-port=3415 in-interface-list=\
    WAN protocol=tcp to-addresses=192.168.0.15 to-ports=3415
add action=netmap chain=dstnat comment=Shefu dst-port=3420 in-interface-list=\
    WAN protocol=tcp to-addresses=192.168.0.20 to-ports=3420
add action=netmap chain=dstnat comment=TelegramTools dst-port=3421 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.21 to-ports=\
    3421
add action=netmap chain=dstnat comment="5500 Lan" dst-port=5500 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.0/24 to-ports=\
    5500
add action=netmap chain=dstnat comment="5501 Lan" dst-port=5501 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.0/24 to-ports=\
    5501
add action=netmap chain=dstnat comment=AvtoReger dst-port=3422 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.22 to-ports=\
    3422
add action=netmap chain=dstnat comment=Market1 dst-port=3308 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.8 to-ports=3308
add action=netmap chain=dstnat comment=G6Virt dst-port=3435 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.35 to-ports=\
    3389
add action=dst-nat chain=dstnat comment="DMZ 192.168.0.195" \
    in-interface-list=WAN to-addresses=192.168.0.200
add action=netmap chain=dstnat comment=Veeam dst-port=2500 in-interface-list=\
    WAN protocol=tcp to-addresses=192.168.0.195 to-ports=2500
add action=netmap chain=dstnat comment=Veeam2 dst-port=10001 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.195 to-ports=\
    10001
add action=netmap chain=dstnat comment=veeam3 dst-port=9395 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.195 to-ports=\
    9395
add action=netmap chain=dstnat comment=veeam4 dst-port=6183 \
    in-interface-list=WAN protocol=tcp to-addresses=192.168.0.195 to-ports=\
    6183
add action=netmap chain=dstnat comment=RAT_AvtoReger dst-port=2401 \
    in-interface-list=all protocol=tcp to-addresses=192.168.0.13 to-ports=\
    2401
/ip route
add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=\
    rout_ether1
add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=\
    rout_ether2
add distance=1 gateway=192.168.1.1,192.168.2.1 routing-mark=mixed
add distance=1 gateway=192.168.1.1
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=Lan type=internal
add interface=ether1 type=external
/lcd interface pages
set 0 interfaces="sfp1,ether1,ether2,ether3,ether4,ether5,ether6,ether7,ether8\
    ,ether9,ether10"
/system clock
set time-zone-name=Europe/xxxxxxxx
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Аватара пользователя
Chupaka
Сообщения: 3172
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Два провайдера с ECMP балансировкой. Настройка Cloud DDNS

Сообщение Chupaka »

Здравствуйте. По ссылке инструкция с кучей пунктов, но слова ECMP я поиском не нашёл.

В целом, у вас в таблице main я вижу лишь один маршрут по умолчанию, через шлюз 192.168.1.1 - больше роутер никуда не выйдет, если этот шлюз отвалится.