MPLS/VPLS over PPTP

RIP, OSFP, BGP, MPLS/VPLS
Аватара пользователя
Sir_Prikol
Сообщения: 423
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

MPLS/VPLS over PPTP

Сообщение Sir_Prikol »

Доброго времени суток

ROS 6.48.4 stable

Пытаюсь перетащить туннели с EoIP на vpls
R1 loopback - 198.18.12.1
R2 loopback - 198.18.28.1

MPLS висит мёртво, в /mpls ldp neighbor видны оба роутера и сети, тут проблем нет
Проблема в том, что не поднимается VPLS туннель

сама конфа

R1

Код: Выделить всё

/mpls ldp
set enabled=yes loop-detect=yes lsr-id=198.18.12.1 transport-address=198.18.12.1 use-explicit-null=yes
/mpls ldp interface
add interface=Br-Loopback
add interface=xx.PPTP_HOME_01

/interface vpls
add disabled=no l2mtu=1500 mac-address=02:77:5D:D9:A7:A9 name=vpls1 remote-peer=198.18.28.1 vpls-id=1:10


R2

Код: Выделить всё

/mpls ldp
set enabled=yes loop-detect=yes lsr-id=198.18.28.1 transport-address=198.18.28.1 use-explicit-null=yes
/mpls ldp interface
add interface=TO_NODE
add interface=Br-Loopback

/interface vpls
add disabled=no l2mtu=1500 mac-address=02:EC:DF:3D:1C:2F name=vpls1 remote-peer=198.18.12.1 vpls-id=1:10

В какую сторону копать?
Дома: CCR2004 (7-ISP(GPON)белый IP)
Аватара пользователя
Chupaka
Сообщения: 3260
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: MPLS/VPLS over PPTP

Сообщение Chupaka »

Доброго.

И в логах ничего? Попробовать debug включить, что ли...
Аватара пользователя
Sir_Prikol
Сообщения: 423
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: MPLS/VPLS over PPTP

Сообщение Sir_Prikol »

В том то и дело, в логах тишина, стандартно только keepalive пакеты и всё

Я уже и не знаю на что грешить, фаер потушен с обоих сторон (чисто во время теста)

Чую - надо лабу собирать. Завтра куплю пару хаплайтов, соберу лабу и посмотрю
Дома: CCR2004 (7-ISP(GPON)белый IP)
Аватара пользователя
Sir_Prikol
Сообщения: 423
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: MPLS/VPLS over PPTP

Сообщение Sir_Prikol »

Так, собрал лабу из 3-х микротиков, по середине только свитч.

Опытным путём выяснилось, что VPLS поднимается на ip адреса pptp клиент/сервер, а вот на лупбеки не хочет, хоть убейся.

R-0

Код: Выделить всё

/interface pptp-server
add name=xx.R-1 user=R-1
add name=xx.R-2 user=R-2
/interface l2tp-server
add name=zz.R-1 user=R-1
add name=zz.R-2 user=R-2
/interface bridge
add admin-mac=4C:5E:0C:57:FD:7E auto-mac=no name=Br-Local protocol-mode=none
add name=Br-Loopback protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] comment=IPoE
set [ find default-name=ether2 ] comment=PPPoE
/interface pppoe-client
add add-default-route=yes comment=KTK interface=ether2 name=xx.KTK use-peer-dns=yes user=45598673
/interface vpls
add arp=proxy-arp disabled=no l2mtu=1500 mac-address=02:1F:03:F2:0D:63 name=vpls1 remote-peer=192.168.188.1 vpls-id=1:1
add arp=proxy-arp disabled=no l2mtu=1500 mac-address=02:86:41:AD:16:B9 name=vpls2 remote-peer=192.168.189.1 vpls-id=1:2
/interface list
add name=WAN
add name=LAN
add name=IPoE
add name=PPPoE
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk,wpa2-eap group-ciphers=tkip,aes-ccm mode=dynamic-keys name=KTK supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm
add authentication-types=wpa-psk,wpa2-psk group-ciphers=tkip,aes-ccm mode=dynamic-keys name=wlan1-DSL-2750U-repeater supplicant-identity=MikroTik unicast-ciphers=tkip,aes-ccm
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX country=no_country_set disabled=no frequency=auto frequency-mode=superchannel mode=ap-bridge multicast-helper=full \
    security-profile=KTK ssid=KTK-MGMT
/ip pool
add name=dhcp_pool0 ranges=192.168.27.2-192.168.27.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=Br-Local name=dhcp1
/port
set 0 baud-rate=9600 data-bits=8 flow-control=none name=usb1 parity=none stop-bits=1
set 1 baud-rate=9600 data-bits=8 flow-control=none name=usb2 parity=none stop-bits=1
/ppp profile
set *0 only-one=yes use-ipv6=no use-mpls=yes
add change-tcp-mss=no name=MPLS use-compression=no use-encryption=no use-ipv6=no use-mpls=yes use-upnp=yes
/routing bgp instance
set default as=65402
/interface bridge port
add bridge=Br-Local interface=ether3
add bridge=Br-Local interface=ether4
add bridge=Br-Local interface=ether5
add bridge=Br-Local interface=wlan1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface l2tp-server server
set allow-fast-path=yes default-profile=MPLS enabled=yes max-mru=1600 max-mtu=1600 mrru=1600
/interface list member
add interface=Br-Local list=LAN
add comment=IPoE interface=ether1 list=WAN
add interface=xx.KTK list=PPPoE
add interface=ether1 list=IPoE
/interface pptp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=default enabled=yes mrru=1600
/ip address
add address=192.168.27.1/24 interface=Br-Local network=192.168.27.0
add address=192.168.28.1/24 interface=Br-Loopback network=192.168.28.0
/ip dhcp-client
add comment=IPoE disabled=no interface=ether1
add add-default-route=no disabled=no interface=vpls1
add add-default-route=no disabled=no interface=vpls2
/ip dhcp-relay
add dhcp-server=100.100.100.254 local-address=100.100.100.100 name=relay1
/ip dhcp-server network
add address=192.168.27.0/24 dns-server=8.8.8.8,1.1.1.1 gateway=192.168.27.1
/ip dns
set servers=8.8.8.8,1.1.1.1
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=fasttrack-connection chain=forward comment="0.0. FastTrack" connection-state=established,related
add action=accept chain=forward connection-state=established,related
/ip firewall nat
add action=masquerade chain=srcnat comment=IPoE out-interface-list=IPoE
add action=masquerade chain=srcnat comment=PPPoE out-interface-list=PPPoE
/ip proxy
set port=8123
/ip route
add distance=1 dst-address=192.168.188.0/24 gateway=xx.R-1
add distance=1 dst-address=192.168.188.0/24 gateway=zz.R-1
add distance=1 dst-address=192.168.189.0/24 gateway=xx.R-2
add distance=1 dst-address=192.168.189.0/24 gateway=zz.R-2
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set distribute-for-default-route=yes enabled=yes loop-detect=yes lsr-id=192.168.28.1 transport-address=192.168.28.1 use-explicit-null=yes
/mpls ldp interface
add interface=Br-Loopback
add interface=xx.R-1
add interface=xx.R-2
add interface=zz.R-1
add interface=zz.R-2
/ppp aaa
set use-radius=yes
/ppp secret
add local-address=192.0.0.10 name=R-1 profile=MPLS remote-address=192.0.0.11
add local-address=192.0.0.10 name=R-2 profile=MPLS remote-address=192.0.0.12
/radius incoming
set accept=yes port=1700
/snmp
set trap-version=2
/system clock
set time-zone-name=Europe/Kaliningrad
/system identity
set name=KTK-MGMT
/system routerboard settings
set auto-upgrade=yes
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
/tool romon
set enabled=yes
R-1

Код: Выделить всё

/interface bridge
add name=Br-Loopback protocol-mode=none
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface vpls
add arp=proxy-arp disabled=no l2mtu=1500 mac-address=02:07:67:3E:60:DB name=vpls1 remote-peer=192.168.28.1 vpls-id=1:1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.190.2-192.168.190.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=vpls1 name=dhcp1
/ppp profile
add change-tcp-mss=yes name=MPLS use-ipv6=no use-mpls=yes
/interface pptp-client
add connect-to=100.64.0.99 disabled=no mrru=1600 name=pptp-out1 profile=MPLS user=R-1
/interface l2tp-client
add allow-fast-path=yes connect-to=100.64.0.99 max-mru=1600 max-mtu=1600 mrru=1600 name=l2tp-out1 profile=MPLS user=R-1
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip address
add address=192.168.188.1/24 interface=Br-Loopback network=192.168.188.0
add address=192.168.190.1/24 interface=vpls1 network=192.168.190.0
/ip dhcp-client
add disabled=no interface=ether1
/ip dhcp-server network
add address=192.168.190.0/24 gateway=192.168.190.1
/ip firewall nat
add action=masquerade chain=srcnat
/ip route
add distance=1 dst-address=192.168.28.0/24 gateway=pptp-out1
add distance=1 dst-address=192.168.28.0/24 gateway=l2tp-out1
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set distribute-for-default-route=yes enabled=yes loop-detect=yes lsr-id=192.168.188.1 transport-address=192.168.188.1 use-explicit-null=yes
/mpls ldp interface
add interface=Br-Loopback
add interface=pptp-out1
add interface=l2tp-out1
/system clock
set time-zone-name=Europe/Kaliningrad
/system identity
set name=R-1
/system routerboard settings
set auto-upgrade=yes
R-2

Код: Выделить всё

/interface bridge
add name=Br-Loopback
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface vpls
add arp=proxy-arp disabled=no l2mtu=1500 mac-address=02:3A:53:F1:DB:DE name=vpls1 remote-peer=192.168.28.1 vpls-id=1:2
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ppp profile
add change-tcp-mss=yes name=MPLS use-ipv6=no use-mpls=yes
/interface pptp-client
add connect-to=100.64.0.99 disabled=no mrru=1600 name=pptp-out1 profile=MPLS user=R-2
/interface l2tp-client
add allow-fast-path=yes connect-to=100.64.0.99 max-mru=1600 max-mtu=1600 mrru=1600 name=l2tp-out1 profile=MPLS user=R-2
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/ip address
add address=192.168.189.1/24 interface=Br-Loopback network=192.168.189.0
/ip dhcp-client
add disabled=no interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat
/ip route
add distance=1 dst-address=192.168.28.0/24 gateway=pptp-out1
add distance=1 dst-address=192.168.28.0/24 gateway=l2tp-out1
/mpls interface
set [ find default=yes ] mpls-mtu=1526
/mpls ldp
set distribute-for-default-route=yes enabled=yes loop-detect=yes lsr-id=192.168.189.1 transport-address=192.168.189.1 use-explicit-null=yes
/mpls ldp interface
add interface=Br-Loopback
add interface=pptp-out1
add interface=l2tp-out1
/system clock
set time-zone-name=Europe/Kaliningrad
/system identity
set name=R-2
/system package update
set channel=development
/system routerboard settings
set auto-upgrade=yes
При замене транспорта с лупбека на 192.0.0.11, 192.0.0.12 и 192.0.0.10 (соответственных каждому из участников) - VPLS работает на ура и стабильно.
Но, в душе понять не могу, почему он на лупбеки не поднимается, ведь видит все адреса как надо и трейс с одним хопом
Дома: CCR2004 (7-ISP(GPON)белый IP)