iptv через gre

RIP, OSFP, BGP, MPLS/VPLS
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

iptv через gre

Сообщение sugar »

Продолжаю воевать с iptv.
настроил gre туннели без ipsec
mtu 1476
в локальной сети коммутатора, т.е. без gre всё работает стабильно.
до двух облачных хостингов с подключением по gre туннелю пакеты плохо пролетают, картинка iptv сыпется, много битых пакетов.
на одном хостинге всё ок работает... вероятно виноват канал интернета, через который эти пакеты пролетают по пути до вдс.

использую igmp proxy.
попробовал с изменением на лету mss, правила вообще не отрабатывают, 0B в итоге.

Код: Выделить всё

/ip firewall mangle
add action=change-mss chain=forward new-mss=1300 out-interface=gre passthrough=yes protocol=tcp tcp-flags=syn tcp-mss=1420-65535
add action=change-mss chain=forward new-mss=1300 in-interface=gre passthrough=yes protocol=tcp tcp-flags=syn tcp-mss=1420-65535
пробовал разные mtu, с прописывание с обоих сторон туннеля gre. тоже никак на стабильность не влияет.

посоветуйте как наладить стабильность? чтобы не было привязки к каналу, чтобы всегда работало нормально.
Аватара пользователя
Chupaka
Сообщения: 3470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: iptv через gre

Сообщение Chupaka »

MSS, как вы сами и указываете, изменяется для protocol=tcp, а мультикаст - это немножко другой протокол, UDP. У него пакеты или пролезают в MTU, или не пролезают, если пролезают - менять ничего не надо.

По описанию немного похоже на изменение порядка следования пакетов. А нет возможности попробовать тоннель EoIP? Что-то смутно вспоминается, что там "из коробки" борются с out-of-order-пакетами. Ну, либо попробовать какой-нибудь тоннель поверх TCP (например, SSTP или OVPN over TCP) - там всё должно долетать, хоть и с бОльшим overhead'ом.
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

Re: iptv через gre

Сообщение sugar »

жаль, что линукс нативно не поддерживает eoip по стандарту микротика.
Аватара пользователя
Chupaka
Сообщения: 3470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: iptv через gre

Сообщение Chupaka »

И не будет... EoIP - проприетарный протокол, слегка ломающий стандарт GRE, такое в ядро брать не хотят
Аватара пользователя
Sir_Prikol
Сообщения: 535
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: iptv через gre

Сообщение Sir_Prikol »

Есть EoIP для дебиана, но со своими тараканами, ну там мак меняется после каждого старта (не получилось жёстко привязать), не получилось несколько туннелей поднять, маршрут автоматом не прописывает, руками дописывать, но в целом, EoIP под дебианом стабилен
Дома: CCR2004 (7-ISP(GPON)белый IP)
Аватара пользователя
Chupaka
Сообщения: 3470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: iptv через gre

Сообщение Chupaka »

Я имел в виду нативно, в ядре. А для userspace - есть даже несколько вариантов, как помню.
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

Re: iptv через gre

Сообщение sugar »

буду пробовать другие варианты, eoip не подходит из-за такой специфической поддержки под linux. :(
Аватара пользователя
Chupaka
Сообщения: 3470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: iptv через gre

Сообщение Chupaka »

Ну, TCP-тоннель - самый надёжный вариант для проверки.
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

Re: iptv через gre

Сообщение sugar »

sspt на CCR1036 смог обработать только 150мбит мультикаста :( этого не хватило и снова битые пакеты.
проц больше чем на 12% не загружается.
пока gre лучше на фоне слабого sstp
с gre загрузка проца 3% при передаче 300мбит мультикаста.
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

Re: iptv через gre

Сообщение sugar »

имеет смысл проверить быстродействие wireguard ?
Аватара пользователя
Chupaka
Сообщения: 3470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: iptv через gre

Сообщение Chupaka »

У CCR1036 проц не один, а 36 - посмотрите, есть ли ядра, загруженные на 100%, например. Tools -> Profile.

Wireguard доступен только в 7-й версии RouterOS - вы уже там?
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

Re: iptv через gre

Сообщение sugar »

ядер на 100% нет загруженных, на 70% были.

я уже в 7.1.3 stable именно из-за поддержки wireguard и поставил.
сегодня попробовал, не умеет wireguard передавать multicast :(

происходит следующее, запускаю vlc, igmp proxy на микротике видит пакет и начинает отдавать мультикаст. мультикаст долетает до внешнего интерфейса сервера (белый ип eth0) но его нет на wg0, т.е. физически трафик доходит до клиента, но оседает на внешнем физическом интерфейсе :(
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

Re: iptv через gre

Сообщение sugar »

запилил wireguard а внутри него gre и добыл таким образом multicast на сервак, но пакеты теряются :(
Аватара пользователя
Chupaka
Сообщения: 3470
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: iptv через gre

Сообщение Chupaka »

А, ну да, Wireguard работает исключительно поверх UDP
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

Re: iptv через gre

Сообщение sugar »

скорее всего никак не победить проблему с пакетами iptv :( или есть шанс ?
sugar
Сообщения: 23
Зарегистрирован: 27 дек 2021, 22:28

Re: iptv через gre

Сообщение sugar »

вобщем, дело было не в бобине..
пинг до сервера теряет ~1% пакетов. связь барахлит.