MultiWAN [РЕШЕНО]

RIP, OSFP, BGP, MPLS/VPLS
Аватара пользователя
Sir_Prikol
Сообщения: 548
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

MultiWAN [РЕШЕНО]

Сообщение Sir_Prikol »

Доброе.
ROS 6.48.6 LongTerm

Дано:
7 аплинков PPOE, настроено PCC - Всё работает как надо, пытаюсь добавить по той-же схеме 8-ой аплинк IPOE (важно) - 8-ой аплинк не работает параллельно. Только как файловер. Что-то я уже голову сломал, не выходит каменный цветок, хоть убей. Или у меня глаз замылился

NAT

Код: Выделить всё

/ip firewall nat
add action=src-nat chain=srcnat out-interface=00.pppoe-ISP01 to-addresses=1.1.1.1
add action=src-nat chain=srcnat out-interface=00.pppoe-ISP02 to-addresses=2.2.2.2
add action=src-nat chain=srcnat out-interface=00.pppoe-ISP03 to-addresses=3.3.3.3
add action=src-nat chain=srcnat out-interface=00.pppoe-ISP04 to-addresses=4.4.4.4
add action=src-nat chain=srcnat out-interface=00.pppoe-ISP05 to-addresses=5.5.5.5
add action=src-nat chain=srcnat out-interface=00.pppoe-ISP06 to-addresses=6.6.6.6
add action=src-nat chain=srcnat out-interface=00.pppoe-ISP07 to-addresses=7.7.7.7
add action=src-nat chain=srcnat out-interface=sfp-sfpplus8 to-addresses=8.8.8.8
MANGLE, задизейбленные правила специально, они исключены из общего PCC для отдельных туннелей

Код: Выделить всё

/ip firewall mangle

add action=mark-connection chain=input connection-state=new in-interface=00.pppoe-ISP01 new-connection-mark=conn_isp_01 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=00.pppoe-ISP02 new-connection-mark=conn_isp_02 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=00.pppoe-ISP03 new-connection-mark=conn_isp_03 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=00.pppoe-ISP04 new-connection-mark=conn_isp_04 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=00.pppoe-ISP05 new-connection-mark=conn_isp_05 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=00.pppoe-ISP06 new-connection-mark=conn_isp_06 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=00.pppoe-ISP07 new-connection-mark=conn_isp_07 passthrough=yes
add action=mark-connection chain=input connection-state=new in-interface=sfp-sfpplus8 new-connection-mark=conn_isp_08 passthrough=yes

add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP01 new-connection-mark=conn_isp_01 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP02 new-connection-mark=conn_isp_02 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP03 new-connection-mark=conn_isp_03 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP04 new-connection-mark=conn_isp_04 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP05 new-connection-mark=conn_isp_05 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP06 new-connection-mark=conn_isp_06 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=00.pppoe-ISP07 new-connection-mark=conn_isp_07 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new in-interface=sfp-sfpplus8 new-connection-mark=conn_isp_08 passthrough=yes

add action=mark-routing chain=output connection-mark=conn_isp_01 new-routing-mark=route_isp_01 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_02 new-routing-mark=route_isp_02 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_03 new-routing-mark=route_isp_03 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_04 new-routing-mark=route_isp_04 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_05 new-routing-mark=route_isp_05 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_06 new-routing-mark=route_isp_06 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_07 new-routing-mark=route_isp_07 passthrough=yes
add action=mark-routing chain=output connection-mark=conn_isp_08 new-routing-mark=route_isp_08 passthrough=yes

add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=conn_isp_01 passthrough=yes per-connection-classifier=both-addresses:5/0 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=conn_isp_02 passthrough=yes per-connection-classifier=both-addresses:5/1 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=conn_isp_03 passthrough=yes per-connection-classifier=both-addresses:5/2 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=conn_isp_04 passthrough=yes per-connection-classifier=both-addresses:5/3 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local new-connection-mark=conn_isp_05 passthrough=yes per-connection-classifier=both-addresses:8/5 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local new-connection-mark=conn_isp_06 passthrough=yes per-connection-classifier=both-addresses:8/6 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark disabled=yes dst-address-type=!local new-connection-mark=conn_isp_07 passthrough=yes per-connection-classifier=both-addresses:8/7 src-address-list=BOGONS
add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=conn_isp_08 passthrough=yes per-connection-classifier=both-addresses:5/4 src-address-list=BOGONS

add action=mark-routing chain=prerouting connection-mark=conn_isp_01 dst-address-type=!local new-routing-mark=route_isp_01 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_02 dst-address-type=!local new-routing-mark=route_isp_02 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_03 dst-address-type=!local new-routing-mark=route_isp_03 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_04 dst-address-type=!local new-routing-mark=route_isp_04 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_05 dst-address-type=!local new-routing-mark=route_isp_05 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_06 dst-address-type=!local new-routing-mark=route_isp_06 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_07 dst-address-type=!local new-routing-mark=route_isp_07 passthrough=yes src-address-list=BOGONS
add action=mark-routing chain=prerouting connection-mark=conn_isp_08 dst-address-type=!local new-routing-mark=route_isp_08 passthrough=yes src-address-list=BOGONS

add action=mark-connection chain=prerouting connection-mark=no-mark dst-address-type=!local new-connection-mark=oTher passthrough=yes
ROUTE

Код: Выделить всё

/ip route

add check-gateway=ping distance=1 gateway=00.pppoe-ISP01
add check-gateway=ping distance=1 gateway=00.pppoe-ISP02
add check-gateway=ping distance=1 gateway=00.pppoe-ISP03
add check-gateway=ping distance=1 gateway=00.pppoe-ISP04
add check-gateway=ping distance=1 gateway=00.pppoe-ISP05
add check-gateway=ping distance=1 gateway=00.pppoe-ISP06
add check-gateway=ping distance=1 gateway=00.pppoe-ISP07
add check-gateway=ping distance=1 gateway=8.8.8.1

add check-gateway=ping distance=1 gateway=00.pppoe-ISP01 routing-mark=route_isp_01
add check-gateway=ping distance=2 gateway=00.pppoe-ISP02 routing-mark=route_isp_01
add check-gateway=ping distance=3 gateway=00.pppoe-ISP03 routing-mark=route_isp_01
add check-gateway=ping distance=4 gateway=00.pppoe-ISP04 routing-mark=route_isp_01
add check-gateway=ping distance=5 gateway=00.pppoe-ISP05 routing-mark=route_isp_01
add check-gateway=ping distance=6 gateway=00.pppoe-ISP06 routing-mark=route_isp_01
add check-gateway=ping distance=7 gateway=00.pppoe-ISP07 routing-mark=route_isp_01
add check-gateway=ping distance=8 gateway=8.8.8.1 routing-mark=route_isp_01

add check-gateway=ping distance=1 gateway=00.pppoe-ISP02 routing-mark=route_isp_02
add check-gateway=ping distance=2 gateway=00.pppoe-ISP03 routing-mark=route_isp_02
add check-gateway=ping distance=3 gateway=00.pppoe-ISP04 routing-mark=route_isp_02
add check-gateway=ping distance=4 gateway=00.pppoe-ISP05 routing-mark=route_isp_02
add check-gateway=ping distance=5 gateway=00.pppoe-ISP06 routing-mark=route_isp_02
add check-gateway=ping distance=6 gateway=00.pppoe-ISP07 routing-mark=route_isp_02
add check-gateway=ping distance=7 gateway=8.8.8.1 routing-mark=route_isp_02
add check-gateway=ping distance=8 gateway=00.pppoe-ISP01 routing-mark=route_isp_02

add check-gateway=ping distance=1 gateway=00.pppoe-ISP03 routing-mark=route_isp_03
add check-gateway=ping distance=2 gateway=00.pppoe-ISP04 routing-mark=route_isp_03
add check-gateway=ping distance=3 gateway=00.pppoe-ISP05 routing-mark=route_isp_03
add check-gateway=ping distance=4 gateway=00.pppoe-ISP06 routing-mark=route_isp_03
add check-gateway=ping distance=5 gateway=00.pppoe-ISP07 routing-mark=route_isp_03
add check-gateway=ping distance=6 gateway=8.8.8.1 routing-mark=route_isp_03
add check-gateway=ping distance=7 gateway=00.pppoe-ISP01 routing-mark=route_isp_03
add check-gateway=ping distance=8 gateway=00.pppoe-ISP02 routing-mark=route_isp_03

add check-gateway=ping distance=1 gateway=00.pppoe-ISP04 routing-mark=route_isp_04
add check-gateway=ping distance=2 gateway=00.pppoe-ISP05 routing-mark=route_isp_04
add check-gateway=ping distance=3 gateway=00.pppoe-ISP06 routing-mark=route_isp_04
add check-gateway=ping distance=4 gateway=00.pppoe-ISP07 routing-mark=route_isp_04
add check-gateway=ping distance=5 gateway=8.8.8.1 routing-mark=route_isp_04
add check-gateway=ping distance=6 gateway=00.pppoe-ISP01 routing-mark=route_isp_04
add check-gateway=ping distance=7 gateway=00.pppoe-ISP02 routing-mark=route_isp_04
add check-gateway=ping distance=8 gateway=00.pppoe-ISP03 routing-mark=route_isp_04

add check-gateway=ping distance=1 gateway=00.pppoe-ISP05 routing-mark=route_isp_05
add check-gateway=ping distance=2 gateway=00.pppoe-ISP06 routing-mark=route_isp_05
add check-gateway=ping distance=3 gateway=00.pppoe-ISP07 routing-mark=route_isp_05
add check-gateway=ping distance=4 gateway=8.8.8.1 routing-mark=route_isp_05
add check-gateway=ping distance=5 gateway=00.pppoe-ISP01 routing-mark=route_isp_05
add check-gateway=ping distance=6 gateway=00.pppoe-ISP02 routing-mark=route_isp_05
add check-gateway=ping distance=7 gateway=00.pppoe-ISP03 routing-mark=route_isp_05
add check-gateway=ping distance=8 gateway=00.pppoe-ISP04 routing-mark=route_isp_05

add check-gateway=ping distance=1 gateway=00.pppoe-ISP06 routing-mark=route_isp_06
add check-gateway=ping distance=2 gateway=00.pppoe-ISP07 routing-mark=route_isp_06
add check-gateway=ping distance=3 gateway=8.8.8.1 routing-mark=route_isp_06
add check-gateway=ping distance=4 gateway=00.pppoe-ISP01 routing-mark=route_isp_06
add check-gateway=ping distance=5 gateway=00.pppoe-ISP02 routing-mark=route_isp_06
add check-gateway=ping distance=6 gateway=00.pppoe-ISP03 routing-mark=route_isp_06
add check-gateway=ping distance=7 gateway=00.pppoe-ISP04 routing-mark=route_isp_06
add check-gateway=ping distance=8 gateway=00.pppoe-ISP05 routing-mark=route_isp_06

add check-gateway=ping distance=1 gateway=00.pppoe-ISP07 routing-mark=route_isp_07
add check-gateway=ping distance=2 gateway=8.8.8.1 routing-mark=route_isp_07
add check-gateway=ping distance=3 gateway=00.pppoe-ISP01 routing-mark=route_isp_07
add check-gateway=ping distance=4 gateway=00.pppoe-ISP02 routing-mark=route_isp_07
add check-gateway=ping distance=5 gateway=00.pppoe-ISP03 routing-mark=route_isp_07
add check-gateway=ping distance=6 gateway=00.pppoe-ISP04 routing-mark=route_isp_07
add check-gateway=ping distance=7 gateway=00.pppoe-ISP05 routing-mark=route_isp_07
add check-gateway=ping distance=8 gateway=00.pppoe-ISP06 routing-mark=route_isp_07

add check-gateway=ping distance=1 gateway=8.8.8.1 routing-mark=route_isp_08
add check-gateway=ping distance=2 gateway=00.pppoe-ISP01 routing-mark=route_isp_08
add check-gateway=ping distance=3 gateway=00.pppoe-ISP02 routing-mark=route_isp_08
add check-gateway=ping distance=4 gateway=00.pppoe-ISP03 routing-mark=route_isp_08
add check-gateway=ping distance=5 gateway=00.pppoe-ISP04 routing-mark=route_isp_08
add check-gateway=ping distance=6 gateway=00.pppoe-ISP05 routing-mark=route_isp_08
add check-gateway=ping distance=7 gateway=00.pppoe-ISP06 routing-mark=route_isp_08
add check-gateway=ping distance=8 gateway=00.pppoe-ISP07 routing-mark=route_isp_08

Последний раз редактировалось Sir_Prikol 12 мар 2022, 23:40, всего редактировалось 1 раз.
Дома: CCR2004 (7-ISP(GPON)белый IP)
Аватара пользователя
Chupaka
Сообщения: 3526
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: MultiWAN

Сообщение Chupaka »

Приветствую.

Что значит "не работает параллельно. Только как файловер"? Маршрут через 8-й аплинк активный в таблице route_isp_08?
Аватара пользователя
Sir_Prikol
Сообщения: 548
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: MultiWAN

Сообщение Sir_Prikol »

"параллельно" это когда загрузка идёт по всем ифейсам сразу, при тех-же торрентах и так далее. Когда скачивание происходит не в один поток

Да, маршрут активный, но когда пытаюсь сделать пинг через этот ифейс - таймаут, когда отправляю через этот гейт любой ресурс - и пытаюсь на него попасть, через него не идёт, такое ощущение что его просто не видно, в то-же время, когда тушу все pppoe - сразу всё работает, весь трафф идёт через этот ифейс
Дома: CCR2004 (7-ISP(GPON)белый IP)
Аватара пользователя
Sir_Prikol
Сообщения: 548
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: MultiWAN [РЕШЕНО]

Сообщение Sir_Prikol »

Таки, после 5ти часовой возни выяснилось, что накосячил пров, спасибо Чупаке за наводку! Правила правильные, косяк был у прова
Дома: CCR2004 (7-ISP(GPON)белый IP)