VLAN - IPTV - UDP

RIP, OSFP, BGP, MPLS/VPLS
Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

VLAN - IPTV - UDP

Сообщение bear » 22 дек 2017, 22:03

Есть одна идея ... точне желание, подскажите пожалуйста, как бы это правильно реализовать.
Постараюсь коротко всё описать :-)

Дано:
1. Провайдер - даёт интеренет и ТВ по разным VLAN. Каналы через UDP (IP-адреса известны).
2. Mikrotik - RB2011UiAS-2HnD-IN (bugfix 6.38.7). В микротике два бриджа (bridge-local и IPTV), порты 1-7 идут в bridge-local, 8-10 в IPTV.
3. Приставка от провайдера (MAG 250). Приставка может держать одновременно два типа подключения - по кабелю и WiFi. Сейчас через LAN приходит ТВ, а через WiFi идёт доступ в интернет и к локальным ресурсам (подключение по wifi иногда тормозит, поэтому я и начал размышлять).

Пожелание:
1. Минимальное: приставка остаётся подключена к роутеру только по кабелю, но трафик с неё для ТВ-каналов заворачивается в VLAN для IPTV, а интернет и локалка идут через bridge-local.
2. Максиамльное: любое устройство в доме (вне зависимости от типа подключения) может смотреть ТВ-каналы через плэйлист провайдера.

Буду благодарен за любые идеи.
На выходных планирую экспериментировать :-)

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: VLAN - IPTV - UDP

Сообщение Chupaka » 24 дек 2017, 14:49

Просто настроить IGMP Proxy (требуется пакет multicast) для получения UDP-потока из одного влана в другой - не поможет?

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: VLAN - IPTV - UDP

Сообщение bear » 24 дек 2017, 16:25

Chupaka писал(а):
24 дек 2017, 14:49
Просто настроить IGMP Proxy (требуется пакет multicast) для получения UDP-потока из одного влана в другой - не поможет?
настраивал согласно этой инструкции, не получилось

уверен, что что-то где-то упускаю, но никак не могу понять что именно ... может NAT нужно настраивать ещё?

может я пошагово со скриншотами опишу всю ситуацию и покажу, что именно делаю?
а то уже сутки бьюсь и уже в шаге от того, чтобы сдаться

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: VLAN - IPTV - UDP

Сообщение bear » 24 дек 2017, 20:13

Решил всё таки всё показать в картинках, может кто-нибудь увидит мою ошибку и скажет, что я упускаю.

Конфигурация:
- два VLAN-a https://i62.servimg.com/u/f62/11/95/78/3110.jpg (IPTV80 для ТВ и INTERNET59 для интернета, висят на ether1)
- список интерфейсов https://i62.servimg.com/u/f62/11/95/78/3210.jpg
- два бриджа https://i62.servimg.com/u/f62/11/95/78/3310.jpg
- принадлежность интерфейсов к бриджам https://i62.servimg.com/u/f62/11/95/78/3410.jpg
- маскарад для интернета https://i62.servimg.com/u/f62/11/95/78/3510.jpg

Настройка IGMP Proxy, согласно этой инструкции:
- отключаю бридж IPTV, оставляю рабочим только VLAN IPTV80 для телевизора
- IGMP Proxy 1 https://i62.servimg.com/u/f62/11/95/78/3610.jpg
- IGMP Proxy 2 https://i62.servimg.com/u/f62/11/95/78/3710.jpg
- IGMP Proxy 3 https://i62.servimg.com/u/f62/11/95/78/3810.jpg
- IGMP Proxy 4 https://i62.servimg.com/u/f62/11/95/78/3910.jpg

Firewall:
/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=IPTV80 protocol=igmp
/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=IPTV80 protocol=udp
/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp

Всё :-)
После таких настроек не работает.
Последний раз редактировалось bear 29 дек 2017, 13:46, всего редактировалось 2 раза.

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: VLAN - IPTV - UDP

Сообщение Chupaka » 26 дек 2017, 15:05

Вы какие-то левые картинки показываете, с несохранёнными настройками. Покажите окно IGMP Proxy со списком интерфейсов

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: VLAN - IPTV - UDP

Сообщение bear » 26 дек 2017, 15:22

Chupaka писал(а):
26 дек 2017, 15:05
окно IGMP Proxy со списком интерфейсов
ага, забыл добавить

Изображение

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: VLAN - IPTV - UDP

Сообщение Chupaka » 26 дек 2017, 15:29

Ну вот, там русским по белому написано, что интерфейсы в состоянии Invalid ("I") :)

IP-адрес на мультикастовом вилане есть? Если нет - можно попробовать туда DHCP-клиент натравить, или же просто добавить статикой какой-нибудь левый адрес (если провайдеру всё равно, с какого адреса идут IGMP-запросы)

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: VLAN - IPTV - UDP

Сообщение bear » 26 дек 2017, 16:32

Chupaka писал(а):
26 дек 2017, 15:29
интерфейсы в состоянии Invalid ("I")
inactive
Chupaka писал(а):
26 дек 2017, 15:29
IP-адрес на мультикастовом вилане есть?
есть
приставка получает IP 20.24.20....
прописывал в Alternative Subnets 20.24.20.0/24 безрезультатно так же

Аватара пользователя
Chupaka
Сообщения: 990
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: VLAN - IPTV - UDP

Сообщение Chupaka » 26 дек 2017, 18:32

При чём здесь "приставка получает"? Я про роутер говорю. В IP -> Addresses есть адрес на интерфейсе IPTV80?

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: VLAN - IPTV - UDP

Сообщение bear » 26 дек 2017, 18:35

Chupaka писал(а):
26 дек 2017, 18:32
В IP -> Addresses есть адрес на интерфейсе IPTV80?
нет

Ответить