Не работает локальная сеть при подключении через L2TP VPN

RIP, OSFP, BGP, MPLS/VPLS
SectorRevin
Сообщения: 3
Зарегистрирован: 13 янв 2023, 10:58

Не работает локальная сеть при подключении через L2TP VPN

Сообщение SectorRevin »

Здравствуйте!
Сразу приношу извинения если такая тема есть и я её не увидел.

Имеется ПК в офисе с Linux Debian 9.0.1 на котором настроены общие папки. Адрес 192.168.0.249
Подключен через микротик RouterOS 6.49.3. На микротике настроен L2TP Server для возможности подключения к этим папкам при работе из дома. Пул адресов для VPN 192.168.10.100-192.168.10.150.
На всех ноутбуках работает исправно, подключается VPN и сразу можно входить на общую папку. Но есть 3 ноутбука на которых внезапно это перестало работать. При попытке открыть папку выдает ошибку 0x80070035 либо "Имя локального устройства уже используется подключение не восстановлено"
Исследуя неработающие ноутбуки выяснил что там где всё работает маршрутизация выглядит так: см.файл До Поломки. В нём я вижу что все адреса со статусом On-link при выходе с ip от VPN.
Там где подключение не работает выглядит так: см. файл После поломки. Тут я уже вижу что у меня маршрутизация ведёт в подсеть VPN но не в локалку.
На самих пк я прописывал команду:
route add -p 192.168.0.0 mask 255.255.255.0 192.168.10.1 metric 50
и начинает всё работать. Пинг проходит, общие папки открываются. Но работает ровно до перезагрузки. Потом снова болты, хоть и сохранена маршрутизация. Прописываю команду заново и опять работает.

Может быть надо прописать ещё правила маршрутизации на самом микротике? Или всё таки проблема в самих компах и микрот не при чём? Я уже не понимаю. Это моё первое знакомство с микротиком и подобными вещами, не судите строго :oops:
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
Chupaka
Сообщения: 3621
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Не работает локальная сеть при подключении через L2TP VPN

Сообщение Chupaka »

Здравствуйте.

Ну, главное отличие между скриншотами в том, что в первом случае у ВПН-клиента установлена галка "Использовать основной шлюз в удалённой сети" (т.е. весь трафик идёт в ВПН), а во втором случае - не установлена (и в ВПН идёт только трафик к автоматическому маршруту к подсети). А касательно маршрутов к подсети - вот тут я описывал: viewtopic.php?f=2&t=2639
SectorRevin
Сообщения: 3
Зарегистрирован: 13 янв 2023, 10:58

Re: Не работает локальная сеть при подключении через L2TP VPN

Сообщение SectorRevin »

Chupaka писал(а): 13 янв 2023, 17:20 Здравствуйте.

Ну, главное отличие между скриншотами в том, что в первом случае у ВПН-клиента установлена галка "Использовать основной шлюз в удалённой сети" (т.е. весь трафик идёт в ВПН), а во втором случае - не установлена (и в ВПН идёт только трафик к автоматическому маршруту к подсети). А касательно маршрутов к подсети - вот тут я описывал: viewtopic.php?f=2&t=2639
Ага, на один шаг стало понятнее в чем разница. Но в конечном итоге все равно не работает. Хоть ставлю я галочку «Использовать шлюз в удаленной сети», хоть убираю.
Аватара пользователя
Chupaka
Сообщения: 3621
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Не работает локальная сеть при подключении через L2TP VPN

Сообщение Chupaka »

Покажите маршруты с проставленной галкой.
Также, вы процитировали ссылку. Вы тот пост читали? Сделали, как надо? Не работает?
SectorRevin
Сообщения: 3
Зарегистрирован: 13 янв 2023, 10:58

Re: Не работает локальная сеть при подключении через L2TP VPN

Сообщение SectorRevin »

Chupaka писал(а): 16 янв 2023, 02:30 Покажите маршруты с проставленной галкой.
Поставил галочку и всё заработало!

Из Вашей темы ссылку на которую мне скинули посмотрел видео по маршрутизации и до меня дошло в чём причина! Сеть офиса у меня 192.168.0.0/24. А сеть VPN 192.168.10.0/24. Когда убираю галочку "Использовать шлюз в удалённой сети" то винда обнаружив такой айпишник ставит сама маску 255.255.255.0 и следовательно видит только сеть VPN а офисную нет. А когда галочка стоит то микротик то знает об офисной сети и отправляет трафик туда если требуется.
И на других неработающих ПК проверил галочка не стояла, установил и всё завелось.
На выходных буду менять сети на микротике, проверю как заработает, отпишусь.
Спасибо что на мысль натолкнули))) Тяжело быть тупеньким всё-таки)))))

Кстати дополнительно разобрался почему костыль с командой "route add...." работал до перезагрузки. Точнее даже до выключения VPN. Когда VPN отключаю то его сетевой интерфейс тоже отключается и становится неактивным. Активное подключение прописанное командой тоже переходит в состояние отключенного (даже если сохранено). И после того как VPN включаю обратно, подключение не заводится так как уже ушло в список неактивных. И поэтому надо было ввести команду ещё раз чтобы активировать его.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Аватара пользователя
Chupaka
Сообщения: 3621
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Не работает локальная сеть при подключении через L2TP VPN

Сообщение Chupaka »

О, всё сошлось, а то я уж подумал, в новой винде что-то намудрили :) После смены подсети на подходящую всё будет работать независимо от проставленной галки