routing filter v7 vs v6

RIP, OSFP, BGP, MPLS/VPLS
informix
Сообщения: 2
Зарегистрирован: 15 мар 2024, 05:32

routing filter v7 vs v6

Сообщение informix »

Запустил в работу CCR2004-16G-2S+ RouterOS 7.13.5

Вышестоящий провайдер отдает частичную таблицу (его клиенты + пиринги РФ + default) - всего ~30 тысяч префиксов.
Пытаюсь оставить из приходящих только default.

На 6-й версии делал так и все работало:
/routing filter
add action=accept chain=rf-ttk-in prefix=0.0.0.0/0
add action=discard chain=rf-ttk-in


На 7-й делаю так:
/routing filter rule
add chain=rt-ttk-in disabled=no rule="if (dst==0.0.0.0/0) {accept} else {reject}"


но в таблицу, кроме дефолтного, попадают еще около 350 префиксов /32

тогда добавляю accept-nlri:
/ip firewall address-list add address=0.0.0.0/0 list=DEFAULT
/routing bgp connection set 0 input.accept-nlri=DEFAULT


но как попадали в таблицу маршрутов эти /32, так и продолжают попадать.

В чем может быть дело?
Аватара пользователя
Chupaka
Сообщения: 3977
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: routing filter v7 vs v6

Сообщение Chupaka »

А если попробовать (dst-len==0)? :)

Вроде как баг с /32 существует: https://forum.mikrotik.com/viewtopic.ph ... 5#p1033615
informix
Сообщения: 2
Зарегистрирован: 15 мар 2024, 05:32

Re: routing filter v7 vs v6

Сообщение informix »

Chupaka писал(а): 26 мар 2024, 18:56 А если попробовать (dst-len==0)? :)

Вроде как баг с /32 существует: https://forum.mikrotik.com/viewtopic.ph ... 5#p1033615
Пробовал, без изменений - префиксы /32 пролезают. Никакого отличия от dst==0.0.0.0/0.
В таблице маршрутов они со статусом Inactive, но балласт этот вовсе не нужен - лучше бы их вообще бы там не было.