Маршрутизация на 6 белых IP

RIP, OSFP, BGP, MPLS/VPLS
pm18murdoc
Сообщения: 2
Зарегистрирован: 27 апр 2024, 13:51

Маршрутизация на 6 белых IP

Сообщение pm18murdoc »

Всем добра! Есть такая ситуация:
От провайдера приходит один порт на котором прописано 6 белых статических ip адреса с РАЗНЫХ подсетей и РАЗНЫМИ шлюзами.
Поднят VPN Wireguard сервер на 6 пользователей, ip на Wireguard клиентах соответственно 10.0.10.11-10.0.10.16. Так вот задача в том, что бы при подключении к Wireguard и получения ip 10.0.10.11 например, заставить ходить весь трафик через определенную внешнюю ип, а не через ту на которой стоит Distance 1. В общем что бы у каждого Wireguard клиента был свой внешний ИП Подскажите пожалуйста куда копать?
Аватара пользователя
Chupaka
Сообщения: 3977
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Маршрутизация на 6 белых IP

Сообщение Chupaka »

Разные шлюзы?.. Бардак какой-то %) Оно хоть статикой настраивается?

Я бы "в лоб" попробовал как-то так:

Код: Выделить всё

/routing/table
add fib name=wan1
add fib name=wan2
...
add fib name=wan6

/ip/route
add routing-table=wan1 gateway=GW1 pref-src=IP1
add routing-table=wan2 gateway=GW2 pref-src=IP2
...
add routing-table=wan6 gateway=GW6 pref-src=IP6

/ip/firewall/mangle
add chain=prerouting src-address=10.0.10.11 dst-address-type=!local action=mark-routing new-routing-mark=wan1
add chain=prerouting src-address=10.0.10.12 dst-address-type=!local action=mark-routing new-routing-mark=wan2
...
add chain=prerouting src-address=10.0.10.16 dst-address-type=!local action=mark-routing new-routing-mark=wan6

/ip/firewall/nat
add chain=srcnat out-interface=WAN action=masquerade
pm18murdoc
Сообщения: 2
Зарегистрирован: 27 апр 2024, 13:51

Re: Маршрутизация на 6 белых IP

Сообщение pm18murdoc »

Да, именно разные внешние ip с разных подсетей и соответственно разные шлюзы! Все статикой! Спасибо большое, буду пробовать!