wifi устройства со слабым сигналом - отказ в подключении

Wi-fi и всё с ним связанное
Ответить
Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

wifi устройства со слабым сигналом - отказ в подключении

Сообщение bear » 23 май 2016, 18:35

никак не могу найти, где я это видел ...

интересует настройка ограничивающая подключения к mikrotik по wifi устройств со слабым сигналом

это правильно делать в CAPsMAN-Access List или Wireless - Access List?
и рекомендуемые значения тоже подкиньте, если не сложно

Аватара пользователя
Chupaka
Сообщения: 1326
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: wifi устройства со слабым сигналом - отказ в подключении

Сообщение Chupaka » 24 май 2016, 14:09

CAPsMAN - это если точек много под его управлением, и надо сделать централизованно. если одна точка - то в Wireless

"рекомендуемые" значения - отойдите с телефоном на то расстояние, когда уже плохо ловит, посмотрите уровень сигнала на роутере - вот и какая-никакая граница :)

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: wifi устройства со слабым сигналом - отказ в подключении

Сообщение bear » 24 май 2016, 14:40

Chupaka писал(а):CAPsMAN - это если точек много под его управлением, и надо сделать централизованно. если одна точка - то в Wireless
можно ли не указывать MAC-адрес?
я правильно понимаю, что сначала нужно снять чекбокс "Default Authenticate" на вкладке Wireless?
Chupaka писал(а):"рекомендуемые" значения - отойдите с телефоном на то расстояние, когда уже плохо ловит, посмотрите уровень сигнала на роутере - вот и какая-никакая граница :)
я неправильно выразился
имелся в виду синтаксис этих ограничений

например, мне нужно, чтобы отбрасывались все, у кого сигнал менее -85
такая настройка будет верной?
Изображение

Аватара пользователя
Chupaka
Сообщения: 1326
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: wifi устройства со слабым сигналом - отказ в подключении

Сообщение Chupaka » 24 май 2016, 16:37

да. либо не отключать Default Authenticate, но добавить "-120..-85" - и снять им галку Authenticate

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: wifi устройства со слабым сигналом - отказ в подключении

Сообщение bear » 24 май 2016, 16:46

Chupaka писал(а):либо не отключать Default Authenticate, но добавить "-120..-85" - и снять им галку Authenticate
я тут набрёл на одну инструкцию, так там указано, что галочку надо обязательно снять, чтобы все беспроводные клиенты сначала фильтровались в Access List’е
насколько я понимаю, если её оставить, то правила в Access List будут игнорироваться?
у какого чекбокса всё таки приоритет? :-)

Аватара пользователя
Chupaka
Сообщения: 1326
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: wifi устройства со слабым сигналом - отказ в подключении

Сообщение Chupaka » 25 май 2016, 15:33

всяким инструкциям на просторах интернета я предпочитаю официальную документацию. а в ней чётко написано:
default-authentication (yes | no; Default: yes) - For AP mode, this is the value of authentication for clients that do not match any entry in the access-list. For station mode, this is the value of connect for APs that do not match any entry in the connect-list
т.е. аксес-листы просматриваются всегда. если в них попал клиент - они срабатывают, если нет - то используется default-значение

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: wifi устройства со слабым сигналом - отказ в подключении

Сообщение bear » 25 май 2016, 18:06

понял, спасибо

и последний (я надеюсь) вопрос на эту тему

обязательно ли прописывать ещё правило с отключением всех, у кого сигнал ниже требуемого?

пример из документации
/interface wireless access-list
add interface=wlan2 signal-range=-55
add authentication=no forwarding=no interface=wlan2 signal-range=..-56
может это правильно с точки зрения уменьшения нагрузки на роутер или ещё по какой причине?

Аватара пользователя
Chupaka
Сообщения: 1326
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: wifi устройства со слабым сигналом - отказ в подключении

Сообщение Chupaka » 26 май 2016, 14:21

да, действительно, век живи - век учись :) TL/DR: необходимо два правила

собственно, там и написано, почему так надо делать: если в момент подключения клиента не сработало ни одно правило и его подключило по дефолтным значениям - то до его отключения правила к нему применяться не будут.

т.е. если есть только правило для отключения слабого сигнала и клиент подключился с нормальным - то при опускании сигнала в зону действия правила оно не сработает. необходимо, чтобы в момент подключения клиент попал под какое-нибудь правило (например, которое подключает всех с хорошим сигналом) - тогда всё сработает, как и задумывалось

Аватара пользователя
bear
Сообщения: 109
Зарегистрирован: 03 мар 2016, 18:39

Re: wifi устройства со слабым сигналом - отказ в подключении

Сообщение bear » 26 май 2016, 14:53

вот теперь точно всё ясно :-)

Ответить