WiFi на Mikrotik RB952 Guest не получает IP на подключаемом устройстве

Wi-fi и всё с ним связанное
Ответить
hulk
Сообщения: 4
Зарегистрирован: 11 янв 2020, 18:33

WiFi на Mikrotik RB952 Guest не получает IP на подключаемом устройстве

Сообщение hulk »

Здравствуйте!
Подскажите пожалуйста, что может быть, если DHCP светится красным и не получает IP подключающийся девайс, в чем проблема на Mikrotik может быть?
Настройки проверил несколько раз.
Вложения
Новый точечный рисунок.jpg
Новый точечный рисунок.jpg (39.26 КБ) 372 просмотра

Аватара пользователя
Chupaka
Сообщения: 2417
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: WiFi на Mikrotik RB952 Guest не получает IP на подключаемом устройстве

Сообщение Chupaka »

Здравствуйте. А сами настройки где? :)
А если руками выставить настройки на клиенте - работает?
Адрес на bridge-guest есть? Интерфейс bridge-guest включен?

hulk
Сообщения: 4
Зарегистрирован: 11 янв 2020, 18:33

Re: WiFi на Mikrotik RB952 Guest не получает IP на подключаемом устройстве

Сообщение hulk »

RouterOS 6.46.1
# model = RB952Ui-5ac2nD
/caps-man channel
add band=2ghz-b/g/n extension-channel=XX frequency=2412,2437,2462,2427,2447 name=channel-2
add band=5ghz-a/n/ac frequency=5180,5240 name=channel-5
add band=2ghz-g/n frequency=2412 name=channel-2-1
add band=2ghz-g/n frequency=2462 name=channel-2-11
add band=2ghz-g/n frequency=2437 name=channel-2-6
/interface bridge
add arp=reply-only comment=guest name=bridge-guest
add admin-mac=C4:AD:***:A1 auto-mac=no comment=LAN name=bridge-lan
/interface ethernet
set [ find default-name=ether1 ] name=ether1-inet
/caps-man datapath
add bridge=bridge-lan client-to-client-forwarding=yes name=datapath
add bridge=bridge-guest client-to-client-forwarding=no name=datapath-guest
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=security-Work passphrase="*******"
add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm name=security-Guest passphrase=*******
/caps-man configuration
add channel=channel-2 comment=2.4 datapath=datapath mode=ap name=cfg2 rx-chains=0,1,2,3 security=security-Work ssid=\
Ch***Service tx-chains=0,1,2,3
add channel=channel-5 comment=5 datapath=datapath mode=ap name=cfg5 rx-chains=0,1,2,3 security=security-Work ssid=\
Ch***Service-5 tx-chains=0,1,2,3
add channel=channel-2 channel.tx-power=17 comment=Guest-2 datapath=datapath-guest hw-protection-mode=rts-cts mode=ap name=cfg2-guest \
rx-chains=0,1,2,3 security=security-Guest ssid=GuestCES tx-chains=0,1,2,3
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless channels
add band=2ghz-g/n extension-channel=Ce frequency=2412 list=1 name=ch1 width=20
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=CES supplicant-identity="" wpa2-pre-shared-key="*******"
add authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys name=GUEST supplicant-identity="" wpa2-pre-shared-key=*******
/interface wireless
# managed by CAPsMAN
# channel: 2412/20-Ce/gn(30dBm), SSID: Ch***Service, CAPsMAN forwarding
set [ find default-name=wlan1 ] antenna-gain=0 band=2ghz-b/g/n channel-width=20/40mhz-XX comment=wlan country=no_country_set \
distance=indoors frequency-mode=manual-txpower hw-protection-mode=rts-cts mode=ap-bridge security-profile=CES ssid=\
Ch***Service wireless-protocol=802.11 wps-mode=disabled
# managed by CAPsMAN
# channel: 5180/20-Ceee/ac(17dBm), SSID: Ch***Service-5, CAPsMAN forwarding
set [ find default-name=wlan2 ] antenna-gain=0 band=5ghz-a/n/ac comment=wlan-5 country=no_country_set distance=indoors \
frequency-mode=manual-txpower mode=ap-bridge security-profile=CES ssid=Ch***Service-5 wireless-protocol=802.11 wps-mode=\
disabled
add keepalive-frames=disabled mac-address=C6:AD:***:A6 master-interface=wlan1 multicast-buffering=disabled name=wlan3 \
security-profile=GUEST ssid=GuestCES wds-cost-range=0 wds-default-cost=0 wps-mode=disabled
/interface wireless manual-tx-power-table
# managed by CAPsMAN
# channel: 2412/20-Ce/gn(30dBm), SSID: Ch***Service, CAPsMAN forwarding
set wlan1 comment=wlan
# managed by CAPsMAN
# channel: 5180/20-Ceee/ac(17dBm), SSID: Ch***Service-5, CAPsMAN forwarding
set wlan2 comment=wlan-5
/interface wireless nstreme
# managed by CAPsMAN
# channel: 2412/20-Ce/gn(30dBm), SSID: Ch***Service, CAPsMAN forwarding
set wlan1 comment=wlan
# managed by CAPsMAN
# channel: 5180/20-Ceee/ac(17dBm), SSID: Che***Service-5, CAPsMAN forwarding
set wlan2 comment=wlan-5
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp ranges=192.168.81.10-192.168.81.200
add name=dhcp-guest ranges=192.168.34.100-192.168.34.150
/ip dhcp-server
add add-arp=yes address-pool=dhcp disabled=no interface=bridge-lan name=LAN
add add-arp=yes address-pool=dhcp-guest disabled=no interface=bridge-guest name=WiFi-Guest
/queue type
add kind=pcq name=pcq-download-3M pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=3M pcq-src-address6-mask=64
add kind=pcq name=pcq-upload-3M pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=3M pcq-src-address6-mask=64
/queue simple
add limit-at=10M/10M max-limit=10M/10M name=WiFi-Guest-3M queue=pcq-upload-3M/pcq-download-3M target=192.168.34.0/24
/caps-man access-list
add action=reject allow-signal-out-of-range=10s disabled=no mac-address=00:00:00:00:00:00 signal-range=-120..120 ssid-regexp=""
add action=accept allow-signal-out-of-range=10s disabled=no mac-address=00:00:00:00:00:00 signal-range=-80..120 ssid-regexp=""
/caps-man manager
set enabled=yes
/caps-man manager interface
add forbid=yes interface=ether1-inet
/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration=cfg2 name-format=identity slave-configurations=\
cfg2-guest
add action=create-dynamic-enabled hw-supported-modes=ac,an master-configuration=cfg5 name-format=identity
/interface bridge filter
# no interface
add action=drop chain=forward in-interface=*E
# no interface
add action=drop chain=forward out-interface=*E
# no interface
add action=drop chain=forward in-interface=*F
# no interface
add action=drop chain=forward out-interface=*F
/interface bridge port
add bridge=bridge-lan interface=ether2
add bridge=bridge-lan interface=ether3
add bridge=bridge-lan interface=ether4
add bridge=bridge-lan interface=ether5
add bridge=bridge-lan comment=wlan interface=wlan1
add bridge=bridge-lan comment=wlan-5 interface=wlan2
add bridge=bridge-guest comment=wlan-guest interface=wlan3
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add interface=bridge-lan list=LAN
add interface=ether1-inet list=WAN
/interface wireless cap
#
set discovery-interfaces=bridge-lan enabled=yes interfaces=wlan1,wlan2
/ip address
add address=192.168.81.1/24 comment=LAN interface=bridge-lan network=192.168.81.0
add address=192.168.34.1/24 comment=Guest interface=wlan3 network=192.168.34.0
/ip cloud
set update-time=no
/ip dhcp-client
add comment=INET disabled=no interface=ether1-inet
/ip dhcp-server network
add address=192.168.34.0/24 comment=Guest dns-server=8.8.8.8 gateway=192.168.34.1 netmask=24
add address=192.168.81.0/24 comment=LAN dns-server=8.8.8.8 gateway=192.168.81.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.81.1 comment=defconf name=router.lan

add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface-list=WAN

Аватара пользователя
Chupaka
Сообщения: 2417
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: WiFi на Mikrotik RB952 Guest не получает IP на подключаемом устройстве

Сообщение Chupaka »

Перенесите IP-адрес с wlan3 на bridge-guest.

У вас cfg2-guest навешен на какой-нибудь CAP-интерфейс? Этот интерфейс в бридже?

hulk
Сообщения: 4
Зарегистрирован: 11 янв 2020, 18:33

Re: WiFi на Mikrotik RB952 Guest не получает IP на подключаемом устройстве

Сообщение hulk »

Chupaka писал(а):
13 янв 2020, 20:10
Перенесите IP-адрес с wlan3 на bridge-guest.
Не понял как(
Chupaka писал(а):
13 янв 2020, 20:10
У вас cfg2-guest навешен на какой-нибудь CAP-интерфейс? Этот интерфейс в бридже?
(см. на скриншоте ниже пожалуйста) (я с Микротиком недавно подружился, только привыкаю)
Вложения
ces111.jpg
ces111.jpg (157.79 КБ) 339 просмотров

Аватара пользователя
Chupaka
Сообщения: 2417
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: WiFi на Mikrotik RB952 Guest не получает IP на подключаемом устройстве

Сообщение Chupaka »

hulk писал(а):
14 янв 2020, 11:03
Chupaka писал(а):
13 янв 2020, 20:10
Перенесите IP-адрес с wlan3 на bridge-guest.
Не понял как(
Открыть адрес в IP -> Address List и изменить у него интерфейс с wlan3 на bridge-guest.

hulk
Сообщения: 4
Зарегистрирован: 11 янв 2020, 18:33

Re: WiFi на Mikrotik RB952 Guest не получает IP на подключаемом устройстве

Сообщение hulk »

Chupaka писал(а):
15 янв 2020, 01:21
hulk писал(а):
14 янв 2020, 11:03
Chupaka писал(а):
13 янв 2020, 20:10
Перенесите IP-адрес с wlan3 на bridge-guest.
Не понял как(
Открыть адрес в IP -> Address List и изменить у него интерфейс с wlan3 на bridge-guest.
Вы оооочень помогли!!!!
Сменил на bridge-guest и все заработало!

Спасибо большущее!!!

Ответить