Проверка доступности порта

Автоматизация при помощи встроенного скриптового языка и RouterOS API
Ответить
shark_90
Сообщения: 2
Зарегистрирован: 24 янв 2019, 20:31

Проверка доступности порта

Сообщение shark_90 » 24 янв 2019, 20:37

Добрый день,
помогите новичку)
задача: написать скрипт на микротике который будет проверять доступность порта и записывать в файл 1 или 0.
Телнетом не получается(

Буду благодарен за любую подсказку))

Аватара пользователя
Chupaka
Сообщения: 1857
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Проверка доступности порта

Сообщение Chupaka » 25 янв 2019, 00:14

Добрый. Увы, средств для проверки открытости TCP-порта в RouterOS нет. А не проще, если этим будет заниматься непосредственно тот, кто будет читать 1 или 0 из файла?..

shark_90
Сообщения: 2
Зарегистрирован: 24 янв 2019, 20:31

Re: Проверка доступности порта

Сообщение shark_90 » 25 янв 2019, 09:21

Chupaka писал(а):
25 янв 2019, 00:14
Добрый. Увы, средств для проверки открытости TCP-порта в RouterOS нет. А не проще, если этим будет заниматься непосредственно тот, кто будет читать 1 или 0 из файла?..
Я пишу скрипт который будет обращаться к этому файлу и в зависимости от 0 или 1 будет выполнять дальше действия

Я нашел решение, проверка HTTP запросами

Код: Выделить всё

:local result [/tool fetch url=http://192.168.1.99:81/login.asp as-value output=user \ mode=http user=admin password=admin];

:if ($result->"status" = "finished") do={

 /file set status.txt contents=1;
}else{
/file set status.txt contents=0;
}

Аватара пользователя
Chupaka
Сообщения: 1857
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Проверка доступности порта

Сообщение Chupaka » 25 янв 2019, 09:50

Ну, какое ТЗ — такой и результат :) Про http-сервер речи не было, а как fetch использовать для обычного tcp-соединения — с наскоку не придумалось

Ответить