Помогите разобраться со скриптом?

Автоматизация при помощи встроенного скриптового языка и RouterOS API
Ronin
Сообщения: 13
Зарегистрирован: 03 июн 2019, 13:53

Re: Помогите разобраться со скриптом?

Сообщение Ronin » 06 июн 2019, 15:44

Да забыл еще вопросик такой, почему скрипт срабатывает именно только при входящем (download) объеме трафика, а по скрипту должно срабатывать когда исходящий (upload) + входящий (download)? Спрашиваю, потому что у меня спутниковый интернет и провайдер выделяет определенный дневной объем трафика в который входит и входящий и исходящий.

Аватара пользователя
Chupaka
Сообщения: 2094
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Помогите разобраться со скриптом?

Сообщение Chupaka » 06 июн 2019, 16:20

Вы так и не показали export ;)
Если ручками открываете очередь - там трафик в обе стороны показывается?

Ronin
Сообщения: 13
Зарегистрирован: 03 июн 2019, 13:53

Re: Помогите разобраться со скриптом?

Сообщение Ronin » 06 июн 2019, 17:51

Chupaka писал(а):
06 июн 2019, 16:20
Вы так и не показали export ;)
Если ручками открываете очередь - там трафик в обе стороны показывается?
Показываю export

Код: Выделить всё

# jun/06/2019 21:46:00 by RouterOS 6.44
# software id = XK0X-TSQ1
#
# model = RB941-2nD
# serial number = A1C30995CB8D
/queue simple
add max-limit=3M/12M name=ZTE priority=1/1 target=192.168.10.103/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
add max-limit=3M/4M name=Lena target=192.168.10.106/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
add max-limit=3M/4M name=Shamov target=192.168.10.108/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
add max-limit=3M/4M name="Home server" target=192.168.10.109/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
add max-limit=3M/4M name=Notbook target=192.168.10.110/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
add max-limit=3M/4M name="Samsung Tab S" target=192.168.10.111/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
add max-limit=3M/4M name=Batya target=192.168.10.112/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
add max-limit=3M/4M name=Mama target=192.168.10.116/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
add max-limit=3M/4M name=DNS-PC-26 target=192.168.10.115/32 time=\
    10h-4h,sun,mon,tue,wed,thu,fri,sat
Немного не понял про ручки????

Аватара пользователя
Chupaka
Сообщения: 2094
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Помогите разобраться со скриптом?

Сообщение Chupaka » 06 июн 2019, 18:32

Ручками - в смысле, в WinBox тыкнуть очередь и посмотреть вкладку Traffic.

После ":put $totaltraf;" добавьте какой-нибудь

Код: Выделить всё

:log info "$totaltraf = $upload + $download";
- что будет в лог выводить?

Ronin
Сообщения: 13
Зарегистрирован: 03 июн 2019, 13:53

Re: Помогите разобраться со скриптом?

Сообщение Ronin » 06 июн 2019, 19:03

Chupaka писал(а):
06 июн 2019, 18:32
Ручками - в смысле, в WinBox тыкнуть очередь и посмотреть вкладку Traffic.
Изображение

Ronin
Сообщения: 13
Зарегистрирован: 03 июн 2019, 13:53

Re: Помогите разобраться со скриптом?

Сообщение Ronin » 06 июн 2019, 19:04

Chupaka писал(а):
06 июн 2019, 18:32
После ":put $totaltraf;" добавьте какой-нибудь

Код: Выделить всё

:log info "$totaltraf = $upload + $download";
- что будет в лог выводить?
Изображение

Судя по логу исходящий трафик не плюсуется к входящему.

Аватара пользователя
Chupaka
Сообщения: 2094
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Помогите разобраться со скриптом?

Сообщение Chupaka » 07 июн 2019, 12:06

Судя по логу, исходящий трафик плюсуется к входящему. Не понимаю, где вы увидели обратное.

Ronin
Сообщения: 13
Зарегистрирован: 03 июн 2019, 13:53

Re: Помогите разобраться со скриптом?

Сообщение Ronin » 07 июн 2019, 13:17

Chupaka писал(а):
07 июн 2019, 12:06
Судя по логу, исходящий трафик плюсуется к входящему. Не понимаю, где вы увидели обратное.
Приветствую!!!
Да точно сейчас сложил считает, но!!! Входящий считает нормально, а вот исходящий не понятно, вот что показывает в Queue List
Изображение

А вот что в лог
Изображение

Там показыает в исходящем 44 мегабайта, а в лог если мы 4654549/1048576=4,4 мегабайта.

Аватара пользователя
Chupaka
Сообщения: 2094
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Помогите разобраться со скриптом?

Сообщение Chupaka » 07 июн 2019, 13:24

Ага, значит, не показалось :) Конечно же вместо

Код: Выделить всё

:set upload [:pick $alltraf 0 ([:find $alltraf "/"] - 1)];
должно быть

Код: Выделить всё

:set upload [:pick $alltraf 0 ([:find $alltraf "/"])];
, а то с "-1" оно последнюю цифру аплоада теряет :)

Ronin
Сообщения: 13
Зарегистрирован: 03 июн 2019, 13:53

Re: Помогите разобраться со скриптом?

Сообщение Ronin » 07 июн 2019, 16:46

Chupaka писал(а):
07 июн 2019, 13:24
Ага, значит, не показалось :) Конечно же вместо

Код: Выделить всё

:set upload [:pick $alltraf 0 ([:find $alltraf "/"] - 1)];
должно быть

Код: Выделить всё

:set upload [:pick $alltraf 0 ([:find $alltraf "/"])];
, а то с "-1" оно последнюю цифру аплоада теряет :)
Во все заработало как и положено! Ну дружище не знаю как тебя и благодарить, помог по полной!!! Огромнейшее спасибо! В три форума написал только в этом помогли! Может эта тема еще кому нибудь поможет, потому как читая форумы, встречал подобные вопросы которые были без ответа! Если что могу обращаться? А то я не силен в микротиках, а только учусь и то купил попробовать что за штука, а штука оказалась отличная и никаких отдельных серверов не надо ставить. Стоит и работает коробочка!

Ответить