Нужна помощь! Простой скрипт.

Автоматизация при помощи встроенного скриптового языка и RouterOS API
Ответить
mTeam
Сообщения: 2
Зарегистрирован: 27 ноя 2019, 09:34

Нужна помощь! Простой скрипт.

Сообщение mTeam » 27 ноя 2019, 09:49

Добрый день!
Подскажите как сделать чтоб при появлении в address-list определенного ip, включался-выключался определенный интерфейс или ip-адрес на интерфейсе? Типа:

:local interA [/ip firewall address-list find address="10.16.0.4"]
:if ($interA=10.16.0.4) do={
/ip address disable numbers=0
}

Заранее благодарен!

Аватара пользователя
Chupaka
Сообщения: 2177
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Нужна помощь! Простой скрипт.

Сообщение Chupaka » 27 ноя 2019, 13:10

Добрый. Если всё так просто — то можно в лоб:

Код: Выделить всё

:foreach i in=[/ip firewall address-list find address="10.16.0.4"] do={
/ip address disable [find interface="XXX"]
}
Конструкции вида /ip address disable numbers=0 в скриптах лучше не использовать, они для работы в интерактивном режиме: numbers зависят от вывода предыдущей команды print.

mTeam
Сообщения: 2
Зарегистрирован: 27 ноя 2019, 09:34

Re: Нужна помощь! Простой скрипт.

Сообщение mTeam » 06 дек 2019, 06:59

Спасибо, будем пробовать.

Ответить