Активация wlan, при пропадании связи до CAP'sMAN [РЕШЕНО]

Автоматизация при помощи встроенного скриптового языка и RouterOS API
Аватара пользователя
Sir_Prikol
Сообщения: 330
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Активация wlan, при пропадании связи до CAP'sMAN [РЕШЕНО]

Сообщение Sir_Prikol »

Добрый день,
Пытаюсь реализовать схему, при котороый скриптом будет выключаться cap на клиенте и включать существующий WiFi

проблема состоит в том, как определить, что CAP работает. Ибо сам iface wlan задизейблен в этот момент.

Пинг до основного менеджера точек - не предлагать, так как он может быть активен, но на нём потушена конфигурация для (к примеру) 5Ghz точек. И на основе какого-то параметра, на удалённой точке, надо поднять wlan ифейс, который не получил данные от основного CAP's man
Последний раз редактировалось Sir_Prikol 22 фев 2020, 14:05, всего редактировалось 1 раз.
Дома: RB4011 (6-ISP(GPON)белый IP)

Аватара пользователя
Chupaka
Сообщения: 2657
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Активация wlan, при пропадании связи до CAP'sMAN

Сообщение Chupaka »

Добрый.

Как-то не получается вот так "в лоб" определить статус подключения...

Попробовать включить local forwarding и посмотреть, как при этом выглядит ситуация без CAPsMAN'а - не предлагать? :)

Аватара пользователя
Sir_Prikol
Сообщения: 330
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: Активация wlan, при пропадании связи до CAP'sMAN

Сообщение Sir_Prikol »

Если я включу Local Forwarding, то у меня будетут недоступны пара серверов, которые подключены внутри сети. Поэтому и задумался на счёт скрипта

Пока, единственный вариант который мне пришёл в голову, создать скрипт на основном контроллере, который смотрит на статус CAP интерфейса (они все у меня статические), при изменении статуса - передать на удалённую точку команду запуска скрипта там, который выключит CAP и включит wlan, и второй скрипт, который будет проверят доступность основного контроллера и на основе этого выбирать состояние, или включить CAP или включить wlan
Дома: RB4011 (6-ISP(GPON)белый IP)

Аватара пользователя
Sir_Prikol
Сообщения: 330
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: Активация wlan, при пропадании связи до CAP'sMAN

Сообщение Sir_Prikol »

Единственное, я ещё не продумал как получить статус флага интрефейса
Дома: RB4011 (6-ISP(GPON)белый IP)

Аватара пользователя
Chupaka
Сообщения: 2657
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Активация wlan, при пропадании связи до CAP'sMAN

Сообщение Chupaka »

Немного половых извращений:

Код: Выделить всё

{
	/interface wireless print file=cap-status-chk.txt where name=wlan1;
	:delay 2s; # ждём, пока файл создастся - не мгновенно...
	:local a [/file get cap-status-chk.txt contents];
	/file remove cap-status-chk.txt;
	:if ($a ~ ";;; channel") do={
		:put "Managed by CAPsMAN";
	} else={
		:put "Not managed...";
	}
}

Аватара пользователя
Sir_Prikol
Сообщения: 330
Зарегистрирован: 14 апр 2018, 15:21
Откуда: СССР

Re: Активация wlan, при пропадании связи до CAP'sMAN

Сообщение Sir_Prikol »

А вот это великолепная штука! Спасибо, спасла меня почти на 100%, мелочь в виде возврата обратно на соединение caps man, простое переключение в шедуллере каждые 15 минут, если связи нет, на следующие 15 минут опять включается основной wlan.
Дома: RB4011 (6-ISP(GPON)белый IP)