Уведомление о подключении конкретного MAC-адреса

Автоматизация при помощи встроенного скриптового языка и RouterOS API
winhex
Сообщения: 4
Зарегистрирован: 28 окт 2019, 14:35
Откуда: Минск

Уведомление о подключении конкретного MAC-адреса

Сообщение winhex »

Добрый день! Необходимо настроить отсылку уведомления при подключении к сети конкретного mac (или можно hostname). Адрес он получает динамический.
Нашел вот такой скрипт для DHCP:

Код: Выделить всё

    :if ($leaseBound = 1) do={

    	/ip dhcp-server lease;

    	:foreach i in=[find dynamic=yes] do={

    		:local dhcpip 

    		:set dhcpip [ get $i address ];

    		:local clientid

    		:set clientid [get $i host-name];

     

    		:if ($leaseActIP = $dhcpip) do={

    			:local comment "New IP"

    			:set comment ( $comment . ": " .  $dhcpip . ": " . $clientid);

    			/log error $comment;

                                                   / tool e-mail send from="имя@yandex.ru" server=87.250.250.38 to= "имя@yandex.ru" body="IP: $leaseActIP; 

    Host: $clientid; 

    Mac: $leaseActMAC;

    SRV: $leaseServerName;" subject="Free Wi-Fi Connection"		
     

    		}

    	}

    }
Но он, как я понял, будет отсылать данные всех подключений, а как бы настроить уведомление по подключению конкретного mac?
winhex
Сообщения: 4
Зарегистрирован: 28 окт 2019, 14:35
Откуда: Минск

Re: Уведомление о подключении конкретного MAC-адреса

Сообщение winhex »

Сам спросил, сам отвечу :lol: :

Код: Выделить всё

:if ($leaseActMAC = "XX:XX:XX:XX:XX:XX") do={
:log info "IP: $leaseActIP, MAC: $leaseActMAC, Host: $"lease-hostname""
:tool e-mail send [email protected] subject="Хост подключился к сети" body="MAC: $leaseActMAC,
IP: $leaseActIP,
Host: $"lease-hostname",
$leaseBound"
}
Аватара пользователя
Chupaka
Сообщения: 3172
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Уведомление о подключении конкретного MAC-адреса

Сообщение Chupaka »

Добрый. Именно так :) А там и до отправки в Телеграм-бота недалеко...