help со скриптом для перезагрузки active connections

Автоматизация при помощи встроенного скриптового языка и RouterOS API
den_kedr
Сообщения: 1
Зарегистрирован: 10 авг 2021, 09:34

help со скриптом для перезагрузки active connections

Сообщение den_kedr »

Добрый день, у меня поднятый VPN 24/7 но провайдер любит по утрам что то делать и частенько VPN подзависает (сессия активная, но не подключается).
Хочу запустить настройку или скрипт которая будет каждый день в определенное время перезапускать активные сессии в PPP - active connections.
возможно ли такое вообще ?
Аватара пользователя
Chupaka
Сообщения: 3260
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: help со скриптом для перезагрузки active connections

Сообщение Chupaka »

Здравствуйте.

В лоб -

Код: Выделить всё

/system scheduler add name=reconnect start-date=aug/10/2021 start-time=10:00:00 interval=1d on-event="/ppp active remove [find]"
Что значит "сессия активная, но не подключается" - не совсем понял (сессия не подключается?), но в скрипт on-event можно добавить какой-нибудь пинг и поставить интервал, например, в 5 минут:

Код: Выделить всё

:if ([/ping 8.8.8.8 count=10] = 0) do={ /ppp active remove [find] }
Аватара пользователя
Gastello
Сообщения: 2
Зарегистрирован: 12 авг 2021, 15:35
Откуда: Русь

Re: help со скриптом для перезагрузки active connections

Сообщение Gastello »

Разрешите присоедениться ибо ситуация схожая. В датацентре есть глобальная стойка где все живут по RDP. В офисах стоят микротики, с поднятыми Впнами(исключительно для некоторого оборудования в том числе и принтеров). Периодически в разных офисах возникают потери пакетов у провайдера(Длится это секунд 5-15). После чего связь нормализуется. Однако Впн имея статус подключено не пропускает пакеты(интернет при этом работает). Помогает подключится к пользователю, подключится к микротику, disable впн на 5 сек и потом дать ему обратно enable. После чего все работает как надо. Думал это как-то через wathdog реализовать. Вроде как через Netwatch что-то подобное можно.
Я так понимаю скрипт :if ([/ping 8.8.8.8 count=10] = 0) do={ /ppp active remove [find] } сделает 10 запросов на айпишник, после чего потушит ВПН? Теоретически дописав
:sleep 10
do={ /ppp active enable [find] }
скрипт будет отрубать активный ВПН, ждать 10 секунд и снова его включать?
Аватара пользователя
Chupaka
Сообщения: 3260
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: help со скриптом для перезагрузки active connections

Сообщение Chupaka »

Нет, удаление из /ppp active всего просто разъединяет клиентов, а не выключает их - пересоединяться они начинают сразу. Если надо что-то выключить и лишь через некоторое время включить - это do={/interface disable l2tp-out1; :sleep 10s; /interface enable l2tp-out1;}
Аватара пользователя
Gastello
Сообщения: 2
Зарегистрирован: 12 авг 2021, 15:35
Откуда: Русь

Re: help со скриптом для перезагрузки active connections

Сообщение Gastello »

Благодарствую.