Создание эмулятора провайдеров для тестирования VPN

Базовая функциональность RouterOS
Ответить
Аватара пользователя
Gennadiy51
Сообщения: 7
Зарегистрирован: 17 авг 2016, 02:48

Создание эмулятора провайдеров для тестирования VPN

Сообщение Gennadiy51 » 07 июл 2018, 17:02

Приветствую самый доброжелательный форум!

Хочу у себя дома провести лабораторную работу по теме разных VPN, повторив все действия на этом ВЕБИНАРЕ по теме "Выбор VPN для использования в Mikrotik", https://www.youtube.com/watch?v=tILuQ8UjPRU&t=2457s.
Для этого у меня есть RB493G для эмуляции провайдеров и ещё я купил два роутера hAPac^2 и подключился ко второму провайдеру, что-бы после проверки VPN на эмуляторе, сразу проверять на вшивость моих провайдеров, т.е. блокируют ли они порты или протоколы VPN. Оба провайдера выдают мне два белых статических IPv4 адреса. Но загвоздка в том, что я не совсем понимаю как настроить эмулятор. Бьюсь над этим несколько дней, т.к. я не профессионал, а большой любитель Mikrotik.
Что я сделал:
1. RB493G настроил в режим моста.
2. Создал три моста и подключил к ним интерфейсы. Первый мост системный, второй и третий провайдеров.
/interface bridge
add fast-forward=no name=bridge1-System protocol-mode=none
add fast-forward=no name=bridge2-Starnet protocol-mode=none
add fast-forward=no name=bridge3-Arax protocol-mode=none
/interface bridge port
add bridge=bridge2-Starnet interface=ether2
add bridge=bridge2-Starnet interface=ether3
add bridge=bridge2-Starnet interface=ether4
add bridge=bridge2-Starnet interface=ether5
add bridge=bridge3-Arax interface=ether6
add bridge=bridge3-Arax interface=ether7
add bridge=bridge3-Arax interface=ether8
add bridge=bridge3-Arax interface=ether9
add bridge=bridge1-System interface=ether1
add bridge=bridge1-System interface=wlan1
add bridge=bridge1-System interface=wlan2
3. Присвоил им адреса.
/ip address
add address=192.168.10.1/24 interface=bridge1-System network=192.168.10.0
add address=89.28.XX.1/24 interface=bridge2-Starnet network=89.28.XX.0
add address=212.28.XX.1/24 interface=bridge3-Arax network=212.28.XX.0
4. Создал три DHCP сервера и массивы адресов для них.
/ip dhcp-server
add address-pool=pool-1 disabled=no interface=bridge1-System name=dhcp1
add address-pool=pool-2 disabled=no interface=bridge2-Starnet name=dhcp2
add address-pool=pool-3 disabled=no interface=bridge3-Arax name=dhcp3

Оба клиентские Микротики hAPac^2 подключаются к своим мостам (провайдерам) и получают от них адреса и "провайреры" пингуются, но вот клиентские Микротики между собой пинговать не удаётся. Не знаю как прописать маршруты между "провайдерами".
Помогите, пожалуйста.
RB493G, 2 x hAP ac^2, wAP ac, 2 x RB450G, hAP lite, X86 (Intel 566 MHz Slot1).

Аватара пользователя
Chupaka
Сообщения: 1034
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Создание эмулятора провайдеров для тестирования VPN

Сообщение Chupaka » 07 июл 2018, 17:16

И вам здравствовать!

Правила файрвола не могут запрещать такой пинг?

DHCP раздаёт шлюз по умолчанию? Что трассировка от одного клиентского к другому говорит?

Аватара пользователя
Gennadiy51
Сообщения: 7
Зарегистрирован: 17 авг 2016, 02:48

Re: Создание эмулятора провайдеров для тестирования VPN

Сообщение Gennadiy51 » 07 июл 2018, 20:01

Правил пока никаких нет.
Установил на обоих DHCP шлюзы по умолчанию и всё заработало!

Огромное спасибо!!!
RB493G, 2 x hAP ac^2, wAP ac, 2 x RB450G, hAP lite, X86 (Intel 566 MHz Slot1).

Ответить