Настройка перенаправления в VPN между подсетями

Базовая функциональность RouterOS
Ответить
Alex2019
Сообщения: 11
Зарегистрирован: 22 авг 2019, 15:17

Настройка перенаправления в VPN между подсетями

Сообщение Alex2019 » 09 сен 2019, 09:33

Добрый день! Имеется структура сети (см.рис.1). Сейчас настроен NAT для обращения к серверу 9.9.9.9 под IP 10.1.1.2 из подсети 10.170.0.1. Есть ещё необходимость от VPN клиента 10.190.0.2 имелась возможность подключение к 9.9.9.9 через модем 10.1.1.1 под адресом 10.1.1.2.

Такое правило на 10.170.0.1 прописано:
/ip firewall nat add action=src-nat chain=src-nat dst-address=9.9.9.9 in-interface=bridge1 to-addresses=10.1.1.2
/ip route add distance=1 dst-address=9.9.9.9 gateway=10.1.1.1 scope=30

Подскажите, пожалуйста, как проще это реализовать.

VPN настроен не через MikroTik, а через интернет-провайдера
Вложения
VPN.jpg
VPN.jpg (70.61 КБ) 132 просмотра

Аватара пользователя
Chupaka
Сообщения: 2042
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка перенаправления в VPN между подсетями

Сообщение Chupaka » 09 сен 2019, 15:15

Добрый.
Alex2019 писал(а):
09 сен 2019, 09:33
Подскажите, пожалуйста, как проще это реализовать.
Ну, либо создать ещё одно NAT-правило с интерфейсом VPN вместо bridge1, либо создать Interface List, добавить туда bridge1 и VPN - и использовать его в правиле in-interface-list= вместо in-interface=.

Alex2019
Сообщения: 11
Зарегистрирован: 22 авг 2019, 15:17

Re: Настройка перенаправления в VPN между подсетями

Сообщение Alex2019 » 09 сен 2019, 16:49

Chupaka писал(а):
09 сен 2019, 15:15
Добрый.
Alex2019 писал(а):
09 сен 2019, 09:33
Подскажите, пожалуйста, как проще это реализовать.
Ну, либо создать ещё одно NAT-правило с интерфейсом VPN вместо bridge1, либо создать Interface List, добавить туда bridge1 и VPN - и использовать его в правиле in-interface-list= вместо in-interface=.
Nat правило не прокатило((
На Микротике клиента маршрут на 10.1.1.1 прописал идти через СЕ, но tracert всё равно теряется, не знает куда идти

Аватара пользователя
Chupaka
Сообщения: 2042
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка перенаправления в VPN между подсетями

Сообщение Chupaka » 09 сен 2019, 17:39

Дайте побольше подробностей про "не знает куда идти"

Alex2019
Сообщения: 11
Зарегистрирован: 22 авг 2019, 15:17

Re: Настройка перенаправления в VPN между подсетями

Сообщение Alex2019 » 10 сен 2019, 09:40

Chupaka писал(а):
09 сен 2019, 17:39
Дайте побольше подробностей про "не знает куда идти"
Выбираю Tools-Traceroute на Микротике клиента и задаю адрес 10.1.1.1
Вот что выдает:
Вложения
Безымянный.jpg
Безымянный.jpg (121.25 КБ) 114 просмотров

Аватара пользователя
Chupaka
Сообщения: 2042
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка перенаправления в VPN между подсетями

Сообщение Chupaka » 11 сен 2019, 04:47

Может, маршрут неправильно прописали? Обычно "не знает, куда идти" — это No route to host, а не Timeout.

Alex2019
Сообщения: 11
Зарегистрирован: 22 авг 2019, 15:17

Re: Настройка перенаправления в VPN между подсетями

Сообщение Alex2019 » 12 сен 2019, 09:30

Chupaka писал(а):
11 сен 2019, 04:47
Может, маршрут неправильно прописали? Обычно "не знает, куда идти" — это No route to host, а не Timeout.
/ip route add distance=1 dst-address=10.1.1.1 gateway=1.1.1.1
Это у клиента на микротике прописан маршрут на 10.1.1.1 через СЕ. Но пакеты не идут.

Аватара пользователя
Chupaka
Сообщения: 2042
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка перенаправления в VPN между подсетями

Сообщение Chupaka » 12 сен 2019, 14:51

Правила файрвола не могут мешать?..

Alex2019
Сообщения: 11
Зарегистрирован: 22 авг 2019, 15:17

Re: Настройка перенаправления в VPN между подсетями

Сообщение Alex2019 » 13 сен 2019, 08:35

Chupaka писал(а):
12 сен 2019, 14:51
Правила файрвола не могут мешать?..
Полностью всё отключил везде

Аватара пользователя
Chupaka
Сообщения: 2042
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: Настройка перенаправления в VPN между подсетями

Сообщение Chupaka » 13 сен 2019, 15:11

Я бы тогда взял в руки Tools -> Torch или Packet Sniffer и смотрел, куда пакеты летят и где теряются.

Ответить