OpenVPN клиент

Базовая функциональность RouterOS
Ответить
kedrovnik
Сообщения: 2
Зарегистрирован: 23 мар 2020, 17:27

OpenVPN клиент

Сообщение kedrovnik »

Всем доброго дня. Подскажите пожалуйста, как правильно завернуть весь трафик через VPN?
Имеется Mikrotik mAP lite RBmAPL-2nD.
На мобильнике раздаю интернет через wifi. На микротике wlan1 настроен как station который ловит розданный с телефона интернет.
На wlan1 настроен dhcp-клиент.
Порт ethernet и виртуальный wlan2 собраны в мост на который навешен dhcp-сервер.
Настроен маскарадинг на wlan1
Настроен mangle для корректировки TTL, чтобы провайдер не "спалил" раздачу, которая на тарифе не разрешена.

В такой конфигурации интернет на wlan2 и ether1 есть, mangle для корректировки TTL работает исправно.

Но возникла потребность в "белом" IP адресе (беру его от домашнего провайдера, подняв у себя дома OpenVPN сервер).

Настраиваю на микротике ovpn-клиент, добавляю сертификаты. Всё успешно подключается, статус Connected. Если выбираю add default route - интернет пропадает.
На этом этапе мои знания заканчиваются. Подскажите пожалуйста, как мне правильно завернуть весь трафик через VPN?

Аватара пользователя
Chupaka
Сообщения: 2420
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: OpenVPN клиент

Сообщение Chupaka »

Приветствую. Маскарадинг на VPN настроен? Какой DNS используется: он должен ходить через VPN или где-то локально?

kedrovnik
Сообщения: 2
Зарегистрирован: 23 мар 2020, 17:27

Re: OpenVPN клиент

Сообщение kedrovnik »

Да, маскарадинг на VPN настроен. DNS присвоен динамический. Хотелось бы чтобы DNS ходил через VPN.
Изображение

Код: Выделить всё

[[email protected]] > /export hide-sensitive 
# mar/23/2020 23:29:37 by RouterOS 6.42.12
# software id = UULM-MZ4C
#
# model = RouterBOARD mAP L-2nD
# serial number = BDEC0A5C0579
/interface bridge
add name=bridge_lan
/interface ovpn-client
add certificate=client.ovpn_1 connect-to=109.174.xx.xx mac-address=\
    02:CA:D1:06:95:C0 name=ovpn-out1 user=xxx
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=\
    allowed mode=dynamic-keys name=rebus supplicant-identity=""
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=\
    allowed mode=dynamic-keys name=mikrotik_mAP supplicant-identity=""
add authentication-types=wpa-psk,wpa2-psk eap-methods="" management-protection=\
    allowed mode=dynamic-keys name=go supplicant-identity=""
/interface wireless
set [ find default-name=wlan1 ] disabled=no security-profile=go ssid=go
add disabled=no keepalive-frames=disabled mac-address=76:4D:28:B2:6A:18 \
    master-interface=wlan1 multicast-buffering=disabled name=wlan2 \
    security-profile=mikrotik_mAP ssid=mikrotik_mAP wds-cost-range=0 \
    wds-default-cost=0 wps-mode=disabled
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=dhcp_pool0 ranges=192.168.99.2-192.168.99.254
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=bridge_lan name=dhcp1
/interface bridge port
add interface=wlan1
add bridge=bridge_lan interface=ether1
add bridge=bridge_lan interface=wlan2
/ip address
add address=192.168.99.1/24 interface=bridge_lan network=192.168.99.0
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=wlan1
/ip dhcp-server network
add address=192.168.99.0/24 gateway=192.168.99.1
/ip firewall mangle
add action=change-ttl chain=prerouting log-prefix=ttl new-ttl=increment:1 \
    passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1
add action=masquerade chain=srcnat out-interface=ovpn-out1
/system clock
set time-zone-name=Asia/Novosibirsk
[[email protected]] > 


Аватара пользователя
Chupaka
Сообщения: 2420
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: OpenVPN клиент

Сообщение Chupaka »

Ну, если под "интернет пропадает" имеется в виду недоступность DNS (нужна хотя бы базовая диагностика), то нужно убедиться, что клиенты получают нужные DNS. На скриншоте - DNS-серверы провайдера?

Так что начните с пинга к недоступным ресурсам, потом пинг по IP (например, 8.8.8.8 или 1.1), а там уже трассировка по IP при необходимости.

Ответить