Щас имеем от свитча (неуправляемого) в микротик приходит 3 кабеля, на 3 интерфеса, на каждом порте поднять статический адрес и промаркирован соответствующий порт. Как сделать все на одном интерфесе и переделать маркировку трафика, чтобы он ходил через свой адресс.
Часть конфигурации роутера
Код: Выделить всё
/interface ethernet
set [ find default-name=ether1 ] comment="INET proxy/ RT /KF" name=ether1_wan1
set [ find default-name=ether2 ] comment="INET PROXY /RT /BEZOPASNOSTH" name=ether2_wan2
set [ find default-name=ether3 ] comment="INET proxy/ RT" name=ether3_wan3
/interface bridge
add add-dhcp-option82=yes comment=sch9 dhcp-snooping=yes name=bridge1
/interface list
add name=WAN
add name=LAN
/routing table
add disabled=no fib name=wan1_route
add disabled=no fib name=wan2_route
add disabled=no fib name=wan3_route
/interface list member
add interface=ether1_wan1 list=WAN
add interface=bridge1 list=LAN
add interface=ether2_wan2 list=WAN
add interface=bridge2 list=LAN
add interface=bridge3 list=LAN
add interface=Sch9Mobile list=LAN
add interface=ether3_wan3 list=WAN
/ip address
add address=192.168.1.1/24 interface=bridge1 network=192.168.1.0
add address=10.33.127.2/24 comment="PROXY RT KF" interface=ether1_wan1 network=10.33.127.0
add address=10.33.127.3/24 comment="PROXY RT NO KF" interface=ether3_wan3 network=10.33.127.0
add address=10.33.127.4/24 comment="RT NO KF" interface=ether2_wan2 network=10.33.127.0
/interface bridge port
add bridge=bridge1 disabled=yes interface=ether3_wan3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=Sch9Mobile interface=ether6
add bridge=bridge2 interface=ether7
add bridge=bridge2 interface=ether8
add bridge=bridge3 interface=ether9
add bridge=bridge1 interface=ether10
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge1 disabled=yes interface=ether1_wan1
add bridge=bridge1 disabled=yes interface=ether2_wan2
/ip firewall address-list
add address=192.168.1.4 list=to_wan1
add address=192.168.1.3 list=to_wan2
add address=192.168.1.2 list=to_wan3
/ip firewall mangle
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=wan1_route passthrough=yes src-address-list=to_wan1
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=wan2_route passthrough=no src-address-list=to_wan2
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=wan3_route passthrough=no src-address-list=to_wan3
/ip route
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether2_wan2 pref-src=0.0.0.0 routing-table=wan2_route scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether1_wan1 pref-src=0.0.0.0 routing-table=wan1_route scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether1_wan1 pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether3_wan3 pref-src=0.0.0.0 routing-table=wan3_route scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether3_wan3 pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether2_wan2 pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
/routing rule
add action=lookup-only-in-table comment=PROXY disabled=no routing-mark=wan1_route table=wan1_route
add action=lookup-only-in-table comment=RT-buh disabled=no routing-mark=wan2_route table=wan2_route
add action=lookup-only-in-table comment=ARM-RT disabled=no routing-mark=wan3_route table=wan3_route