Несколько статистических адресов на одном интерфейсе

Базовая функциональность RouterOS
wolodyawggu
Сообщения: 15
Зарегистрирован: 20 мар 2020, 13:16

Несколько статистических адресов на одном интерфейсе

Сообщение wolodyawggu »

Здравствуйте, интересует задача как сделать несколько статичтических адрессов на 1 интерфейсе?
Щас имеем от свитча (неуправляемого) в микротик приходит 3 кабеля, на 3 интерфеса, на каждом порте поднять статический адрес и промаркирован соответствующий порт. Как сделать все на одном интерфесе и переделать маркировку трафика, чтобы он ходил через свой адресс.
Часть конфигурации роутера

Код: Выделить всё

/interface ethernet
set [ find default-name=ether1 ] comment="INET proxy/ RT /KF" name=ether1_wan1
set [ find default-name=ether2 ] comment="INET PROXY /RT /BEZOPASNOSTH" name=ether2_wan2
set [ find default-name=ether3 ] comment="INET proxy/ RT" name=ether3_wan3
/interface bridge
add add-dhcp-option82=yes comment=sch9 dhcp-snooping=yes name=bridge1
/interface list
add name=WAN
add name=LAN
/routing table
add disabled=no fib name=wan1_route
add disabled=no fib name=wan2_route
add disabled=no fib name=wan3_route
/interface list member
add interface=ether1_wan1 list=WAN
add interface=bridge1 list=LAN
add interface=ether2_wan2 list=WAN
add interface=bridge2 list=LAN
add interface=bridge3 list=LAN
add interface=Sch9Mobile list=LAN
add interface=ether3_wan3 list=WAN
/ip address
add address=192.168.1.1/24 interface=bridge1 network=192.168.1.0
add address=10.33.127.2/24 comment="PROXY RT KF" interface=ether1_wan1 network=10.33.127.0
add address=10.33.127.3/24 comment="PROXY RT NO KF" interface=ether3_wan3 network=10.33.127.0
add address=10.33.127.4/24 comment="RT NO KF" interface=ether2_wan2 network=10.33.127.0
/interface bridge port
add bridge=bridge1 disabled=yes interface=ether3_wan3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=Sch9Mobile interface=ether6
add bridge=bridge2 interface=ether7
add bridge=bridge2 interface=ether8
add bridge=bridge3 interface=ether9
add bridge=bridge1 interface=ether10
add bridge=bridge1 interface=sfp-sfpplus1
add bridge=bridge1 disabled=yes interface=ether1_wan1
add bridge=bridge1 disabled=yes interface=ether2_wan2
/ip firewall address-list
add address=192.168.1.4 list=to_wan1
add address=192.168.1.3 list=to_wan2
add address=192.168.1.2 list=to_wan3
/ip firewall mangle
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=wan1_route passthrough=yes src-address-list=to_wan1
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=wan2_route passthrough=no src-address-list=to_wan2
add action=mark-routing chain=prerouting dst-address=!192.168.0.0/16 new-routing-mark=wan3_route passthrough=no src-address-list=to_wan3
/ip route
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether2_wan2 pref-src=0.0.0.0 routing-table=wan2_route scope=30 suppress-hw-offload=no target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether1_wan1 pref-src=0.0.0.0 routing-table=wan1_route scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether1_wan1 pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether3_wan3 pref-src=0.0.0.0 routing-table=wan3_route scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=3 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether3_wan3 pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.33.127.1%ether2_wan2 pref-src=0.0.0.0 routing-table=main scope=30 suppress-hw-offload=no target-scope=10
/routing rule
add action=lookup-only-in-table comment=PROXY disabled=no routing-mark=wan1_route table=wan1_route
add action=lookup-only-in-table comment=RT-buh disabled=no routing-mark=wan2_route table=wan2_route
add action=lookup-only-in-table comment=ARM-RT disabled=no routing-mark=wan3_route table=wan3_route

Аватара пользователя
Chupaka
Сообщения: 3559
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Несколько статистических адресов на одном интерфейсе

Сообщение Chupaka »

Приветствую.

Собственно, добавляете все адреса на один интерфейс - и потом для выбора адреса используете правила src-nat (текущие вы не показали) типа таких:

/ip fi nat add chain=srcnat src-address-list=to_wan1 action=src-nat to-addresses=10.33.127.2
/ip fi nat add chain=srcnat src-address-list=to_wan2 action=src-nat to-addresses=10.33.127.3
wolodyawggu
Сообщения: 15
Зарегистрирован: 20 мар 2020, 13:16

Re: Несколько статистических адресов на одном интерфейсе

Сообщение wolodyawggu »

Chupaka писал(а): 21 ноя 2022, 12:28 Приветствую.

Собственно, добавляете все адреса на один интерфейс - и потом для выбора адреса используете правила src-nat (текущие вы не показали) типа таких:

/ip fi nat add chain=srcnat src-address-list=to_wan1 action=src-nat to-addresses=10.33.127.2
/ip fi nat add chain=srcnat src-address-list=to_wan2 action=src-nat to-addresses=10.33.127.3
А можно реализовать с маркировкой?
Суть в моем конфиге такова, вы кстати в нем мне помогали, есть 3 интерфейса с разными IP адресами, я их маркирую, через DHCP рабочее место я отправляю в соответствующий лист адресов. или все так же и остается?
Аватара пользователя
Chupaka
Сообщения: 3559
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Несколько статистических адресов на одном интерфейсе

Сообщение Chupaka »

Можно и с маркировкой, но нужно ли? Что вы хотите маркировать? Или основной маршрут должен быть через другой интерфейс?

Если всё через один, то чем добавлять адрес в адрес-лист, маркировать по адрес-листу и натить по метке, проще, наверное, сразу натить по адрес-листу? :)
wolodyawggu
Сообщения: 15
Зарегистрирован: 20 мар 2020, 13:16

Re: Несколько статистических адресов на одном интерфейсе

Сообщение wolodyawggu »

Chupaka писал(а): 22 ноя 2022, 14:37 Можно и с маркировкой, но нужно ли? Что вы хотите маркировать? Или основной маршрут должен быть через другой интерфейс?
Объясню всю суть задумки, мы организация и нам провели ЕСПД, РТ проект. Мы там сделали некоторые дополнительные настройки, но их поместили в разные IP адреса, которые выдал РТ. Сейчас у нас от комутатора РТ и Микротиком стоит свитч неуправляеый, от этого свитч неуправляеого приходят 3 провода в микротик. Задача от 3 задействованных портов перейти к 1 задействованому порту напрямую от коммутатора.
Этот конфиг я настраивал долго. Смысл в чем, чтобы через DHCP я мог регулировать в какой он пойдет адресс лист, порт 1 например контент фильтрация, порт второй усиленная контент фильтрация, 3 порт без фильтрации. Но они должны находиться все в одной сети: папки, обмена, принтера и камеры видеонаблюдения.
----------------
Chupaka писал(а): 22 ноя 2022, 14:37 Можно и с маркировкой, но нужно ли? Что вы хотите маркировать? Или основной маршрут должен быть через другой интерфейс?
Чтобы не особо менять конфигурацию
Chupaka писал(а): 22 ноя 2022, 14:37 Если всё через один, то чем добавлять адрес в адрес-лист, маркировать по адрес-листу и натить по метке, проще, наверное, сразу натить по адрес-листу? :)
Ну он будет корректно отрабатывать.
Если надо полностью конфиг то могу скинуть в личку.
По поводу ната, все банально и просто

Код: Выделить всё

/ip firewall nat
add action=dst-nat chain=dstnat dst-port=554,9988,8045 in-interface=ether1_wan1 protocol=tcp to-addresses=192.168.1.130
add action=masquerade chain=srcnat out-interface-list=WAN
Аватара пользователя
Chupaka
Сообщения: 3559
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск

Re: Несколько статистических адресов на одном интерфейсе

Сообщение Chupaka »

Собственно, если провайдер один, то, видимо, достаточно просто добавить все три адреса на один порт, создать три правила NAT (для каждого из адресов на порту, и перетащить их выше маскарадинга), как я писал выше, и выключить три правила mark-routing. Тогда всё пойдёт через маршрут в таблице main, а уже натироваться будет на нужный адрес в каждом случае