MPLS TE странное поведение

RIP, OSFP, BGP, MPLS/VPLS
timonsterrr
Сообщения: 70
Зарегистрирован: 05 мар 2017, 17:33

MPLS TE странное поведение

Сообщение timonsterrr » 31 окт 2018, 09:44

Всем привет. Решил заморочиться и уйти от LDP к MPLS-TE
Но во с чем столкнулся - поднимаю туннель ТЕ между двумя роутерами. Между ними l2vpn cspf включен один роутер находится в бэкбон зоне, второй не в бэкбон (зона присоединенная к бэкбон)

добавляю в ТЕ интерфейс, динамический путь (предварительно активировав в ospf mpls te area и выбрав в качестве ID loopback) но ни путь ни тем более te интерфйс не поднимаются....если вывожу роутер из присоединенной зоны в бэкбон то все взлетает, вывожу его обратно в свою зону все продолжает работать даже после перезапуска те пути и интерфейса....на обоих роутерах в настройках ospf в качестве te area выбрана бэкбон.

Затем пробую провернуть то же самое с другим роутером из другой зоны....и опять не взлетает пока не сделаешь вывоод роутера в бэкбон зон и ввод обратн ов свою... конфиги ниже
конфиг роутера в приоединенной зоне (у него влан отдан на эзер1 антегом):

Код: Выделить всё

/routing ospf area
add area-id=1.1.2.13 name=1.1.2.13
/routing ospf instance
set [ find default=yes ] mpls-te-area=backbone mpls-te-router-id=loopback0 router-id=10.254.1.13
/routing ospf interface
add interface=ether1 network-type=point-to-point
/routing ospf network
add area=1.1.2.13 network=10.14.1.48/29
add area=1.1.2.13 network=10.254.1.13/32

/mpls traffic-eng interface
add bandwidth=50Mbps interface=ether1
/mpls traffic-eng tunnel-path
add name=tp-R1-dyn
/interface traffic-eng
add bandwidth=50Mbps disabled=no from-address=10.254.1.13 name=traffic-eng-R1 prim
конфиг роутера в бэкбон зоне (к нему влан к соседнему роутеру приходит тегированно 4063):

Код: Выделить всё

/mpls traffic-eng interface
add bandwidth=50Mbps interface=vlan4063-Uranovaya
/mpls traffic-eng tunnel-path
add name=tp-Uranovaya
/interface traffic-eng
add bandwidth=50Mbps disabled=no from-address=10.255.1.2 name=traffic-eng-Uranovaya primary-path=tp-Uranovaya to-address=10.254.1.13
/routing ospf area
add area-id=1.1.2.13 name="1.1.2.13(Uranovaya)"
/routing ospf instance
set [ find default=yes ] mpls-te-area=backbone mpls-te-router-id=loopback0 router-id=10.255.1.2
/routing ospf interface
add interface=vlan10 network-type=ptmp
add interface=vlan4063-Uranovaya network-type=point-to-point
/routing ospf network
add area=backbone network=10.14.1.0/29
add area=backbone network=10.255.1.2/32
add area="1.1.2.13(Uranovaya)" network=10.14.1.48/29

Связность между маршрутизаторами есть, все маршруты к лупбэкам присутствуют....Может есть какие то ограничения или что то еще что я не учел при настройке мплс те?

timonsterrr
Сообщения: 70
Зарегистрирован: 05 мар 2017, 17:33

Re: MPLS TE странное поведение

Сообщение timonsterrr » 03 дек 2018, 12:05

Решение для мультиария ospf - снять чекбокс use cspf (cspf работает только в бэкбон зоне)

timonsterrr
Сообщения: 70
Зарегистрирован: 05 мар 2017, 17:33

Re: MPLS TE странное поведение

Сообщение timonsterrr » 03 дек 2018, 12:08

Есть Другой вопрос - вот TE заработал. VPLS работает через него, что подтверждается информацией в статус vpls Но вот трафик для сетей анонсированных по bgp не могу заставить ходить через TE. В вики микрота написано, что если нестхопом бгп марщрута будет вторая сторона туннеля, то трафик пойдет через туннель. НО так не происходит, бгп сессия поднята между loopback интерфейсами железок. Маршрут строится рекурсвиный, gateway как раз вторая сторона туннеля (тот же адрес) но трафик не идет в туннель...

вот одна сторона туннеля:

Код: Выделить всё

add bandwidth=50Mbps disabled=no from-address=10.255.1.2 name=\
    traffic-eng-Uranovaya primary-path=tp-Uranovaya-dyn secondary-paths=\
    tp-Uranovaya-static to-address=10.254.1.13
Вот вторая:

Код: Выделить всё

/interface traffic-eng
add bandwidth=50Mbps disabled=no from-address=10.254.1.13 name=traffic-eng-R1 primary-path=tp-R1-dyn secondary-paths=tp-R2-static to-address=10.255.1.2
и вот маршрут к сети изученной по бгп на железке 1 (10.255.1.2)

43 ADb 10.16.13.0/24 10.254.1.13 200

как видим некстхоп вторая сторона TE но трафик в TE не уходит...что это баг? недоработка? Но суппорт микротика молчит как рыба об лед.

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: MPLS TE странное поведение

Сообщение Chupaka » 03 дек 2018, 12:58

А print detail ничего интересного по этому маршруту не показывает?

timonsterrr
Сообщения: 70
Зарегистрирован: 05 мар 2017, 17:33

Re: MPLS TE странное поведение

Сообщение timonsterrr » 03 дек 2018, 13:01

Chupaka писал(а):
03 дек 2018, 12:58
А print detail ничего интересного по этому маршруту не показывает?

Код: Выделить всё

0 ADb  dst-address=10.16.13.0/24 gateway=10.254.1.13 
        gateway-status=10.254.1.13 recursive via 10.14.1.54 vlan4063-Uranovaya distance=200 scope=40 
        target-scope=30 bgp-local-pref=100 bgp-origin=igp received-from=peer-Uranovaya

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: MPLS TE странное поведение

Сообщение Chupaka » 03 дек 2018, 13:06

Ну, вот он и объясняет, почему трафик в vlan4063-Uranovaya уходит, не?..

timonsterrr
Сообщения: 70
Зарегистрирован: 05 мар 2017, 17:33

Re: MPLS TE странное поведение

Сообщение timonsterrr » 03 дек 2018, 13:07

Chupaka писал(а):
03 дек 2018, 13:06
Ну, вот он и объясняет, почему трафик в vlan4063-Uranovaya уходит, не?..
Поясните? на сколько вижу - условие что некстхоп вторая сторона туннеля выполнено...исходя из вики микротика трафик должен быть перенаправлен в TE

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: MPLS TE странное поведение

Сообщение Chupaka » 03 дек 2018, 13:09

У данного маршрута шлюз 10.254.1.13. Смотрите маршруты к 10.254.1.13 - там должен быть ответ.

timonsterrr
Сообщения: 70
Зарегистрирован: 05 мар 2017, 17:33

Re: MPLS TE странное поведение

Сообщение timonsterrr » 03 дек 2018, 13:11

Chupaka писал(а):
03 дек 2018, 13:09
У данного маршрута шлюз 10.254.1.13. Смотрите маршруты к 10.254.1.13 - там должен быть ответ.
маршрут к 10.254.1.13

Код: Выделить всё

 ADo  dst-address=10.254.1.13/32 gateway=10.14.1.54 
        gateway-status=10.14.1.54 reachable via  vlan4063-Uranovaya distance=110 scope=20 
        target-scope=10 ospf-metric=20 ospf-type=intra-area 
Изучен из оспф.

Аватара пользователя
Chupaka
Сообщения: 1356
Зарегистрирован: 29 фев 2016, 15:26
Откуда: Минск
Контактная информация:

Re: MPLS TE странное поведение

Сообщение Chupaka » 03 дек 2018, 13:16

И других нет? Значит, это и есть ответ. Роутер знает, что такой шлюз доступен через этот VLAN - и всё.

Ответить